summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-25 19:19:55 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-25 19:19:55 +0000
commit58a63b105fd720ddb6c2f6ee8d6d3ddabc9a7997 (patch)
tree6837a16c0f810890cfb80f00a85536ef7b4e18d9 /media-sound/pd
parentPortage 2.0.38 (diff)
downloadgentoo-2-58a63b105fd720ddb6c2f6ee8d6d3ddabc9a7997.tar.gz
gentoo-2-58a63b105fd720ddb6c2f6ee8d6d3ddabc9a7997.tar.bz2
gentoo-2-58a63b105fd720ddb6c2f6ee8d6d3ddabc9a7997.zip
Patched for compile and install problems. Added X and alsa USE variable
support.
Diffstat (limited to 'media-sound/pd')
-rw-r--r--media-sound/pd/ChangeLog8
-rw-r--r--media-sound/pd/files/0.35.0-r1.patch105
-rw-r--r--media-sound/pd/files/digest-pd-0.35.0-r11
-rw-r--r--media-sound/pd/pd-0.35.0-r1.ebuild66
4 files changed, 179 insertions, 1 deletions
diff --git a/media-sound/pd/ChangeLog b/media-sound/pd/ChangeLog
index 67a062d030ca..629a67b8667e 100644
--- a/media-sound/pd/ChangeLog
+++ b/media-sound/pd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/pd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pd/ChangeLog,v 1.2 2002/08/19 00:44:39 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pd/ChangeLog,v 1.3 2002/09/25 19:19:55 raker Exp $
+
+*pd-0.30.0-r1 (25 Sep 2002)
+
+ 25 Sep 2002; Nick Hadaway <raker@gentoo.org> pd-0.35.0-r1.ebuild,
+ files/digest-pd-0.35.0-r1, files/0.35.0-r1.patch :
+ New patch to fix compile and installation problems.
*pd-0.35.0 (18 Aug 2002)
diff --git a/media-sound/pd/files/0.35.0-r1.patch b/media-sound/pd/files/0.35.0-r1.patch
new file mode 100644
index 000000000000..4a54706dc243
--- /dev/null
+++ b/media-sound/pd/files/0.35.0-r1.patch
@@ -0,0 +1,105 @@
+diff -urN pd-0.35-0/extra/fiddle~/fiddle~.c pd-0.35-0-modified/extra/fiddle~/fiddle~.c
+--- pd-0.35-0/extra/fiddle~/fiddle~.c Mon Jun 10 21:10:24 2002
++++ pd-0.35-0-modified/extra/fiddle~/fiddle~.c Wed Sep 25 13:33:42 2002
+@@ -693,11 +693,11 @@
+
+ for (npitch = 0; npitch < x->x_npitch; npitch++)
+ {
+- int index;
++ int index_gentoo;
+ float best;
+ if (npitch)
+ {
+- for (best = 0, index = -1, j=1; j < maxbin-1; j++)
++ for (best = 0, index_gentoo = -1, j=1; j < maxbin-1; j++)
+ {
+ if (histogram[j] > best && histogram[j] > histogram[j-1] &&
+ histogram[j] > histogram[j+1])
+@@ -717,7 +717,7 @@
+ if (histogram[j + sigfiddle_intpartialonset[k]]
+ > histogram[j]) goto peaknogood;
+ }
+- index = j;
++ index_gentoo = j;
+ best = histogram[j];
+ }
+ peaknogood: ;
+@@ -725,13 +725,13 @@
+ }
+ else
+ {
+- for (best = 0, index = -1, j=0; j < maxbin; j++)
++ for (best = 0, index_gentoo = -1, j=0; j < maxbin; j++)
+ if (histogram[j] > best)
+- index = j, best = histogram[j];
++ index_gentoo = j, best = histogram[j];
+ }
+- if (index < 0) break;
++ if (index_gentoo < 0) break;
+ histvec[npitch].h_value = best;
+- histvec[npitch].h_index = index;
++ histvec[npitch].h_index = index_gentoo;
+ }
+ #if 1
+ if (x->x_nprint)
+@@ -1632,8 +1632,7 @@
+ {
+ if (sp[0]->s_n > x->x_hop) {
+ x->x_downsample = sp[0]->s_n / x->x_hop;
+- post("* warning: fiddle~: will downsample input by
+-%ld",x->x_downsample);
++ post("* warning: fiddle~: will downsample input by %ld",x->x_downsample);
+ x->x_sr = sp[0]->s_sr / x->x_downsample;
+ } else {
+ x->x_downsample = 1;
+diff -urN pd-0.35-0/src/makefile.in pd-0.35-0-modified/src/makefile.in
+--- pd-0.35-0/src/makefile.in Fri May 24 12:08:40 2002
++++ pd-0.35-0-modified/src/makefile.in Wed Sep 25 14:03:37 2002
+@@ -12,6 +12,8 @@
+ INSTALL_PREFIX = @prefix@
+ GFLAGS = -DINSTALL_PREFIX=\"$(INSTALL_PREFIX)\"
+
++MANDIR = @mandir@
++
+ # ALSA compilation
+
+ SOUND_ALSA = @alsa@
+@@ -164,13 +166,14 @@
+ cd ../extra/pique;make @EXTERNTARGET@
+
+ INSTDIR = $(DESTDIR)/$(INSTALL_PREFIX)
++MANINSTDIR = $(DESTDIR)/$(MANDIR)
+ install:
+ install -d $(INSTDIR)/lib/pd/bin
+ install $(BIN_DIR)/$(GUINAME) $(INSTDIR)/lib/pd/bin/$(GUINAME)
+ install $(BIN_DIR)/pd-watchdog $(INSTDIR)/lib/pd/bin/pd-watchdog
+- install -m644 $(BIN_DIR)/pd.tk $(INSTDIR)/lib/pd/bin/pd.tk
++ install -m 644 $(BIN_DIR)/pd.tk $(INSTDIR)/lib/pd/bin/pd.tk
+ install -d $(INSTDIR)/bin
+- install -m755 $(PDEXEC) $(INSTDIR)/bin/pd
++ install -m 755 $(PDEXEC) $(INSTDIR)/bin/pd
+ install -m 755 $(BIN_DIR)/pdsend $(INSTDIR)/bin/pdsend
+ install -m 755 $(BIN_DIR)/pdreceive $(INSTDIR)/bin/pdreceive
+ install -d $(INSTDIR)/lib/pd/extra
+@@ -178,13 +181,14 @@
+ install -m 644 $(EXTERNS) $(INSTDIR)/lib/pd/extra
+ cp -r ../doc $(INSTDIR)/lib/pd/
+ install -d $(INSTDIR)/include
+- install -m644 m_pd.h $(INSTDIR)/include/m_pd.h
+- gzip < ../man/pd.1 > $(INSTDIR)/man/man1/pd.1.gz
+- chmod 644 $(INSTDIR)/man/man1/pd.1.gz
+- gzip < ../man/pdsend.1 > $(INSTDIR)/man/man1/pdsend.1.gz
+- chmod 644 $(INSTDIR)/man/man1/pdsend.1.gz
+- gzip < ../man/pdreceive.1 > $(INSTDIR)/man/man1/pdreceive.1.gz
+- chmod 644 $(INSTDIR)/man/man1/pdreceive.1.gz
++ install -m 644 m_pd.h $(INSTDIR)/include/m_pd.h
++ install -d $(MANINSTDIR)/man1
++ gzip < ../man/pd.1 > $(MANINSTDIR)/man1/pd.1.gz
++ chmod 644 $(MANINSTDIR)/man1/pd.1.gz
++ gzip < ../man/pdsend.1 > $(MANINSTDIR)/man1/pdsend.1.gz
++ chmod 644 $(MANINSTDIR)/man1/pdsend.1.gz
++ gzip < ../man/pdreceive.1 > $(MANINSTDIR)/man1/pdreceive.1.gz
++ chmod 644 $(MANINSTDIR)/man1/pdreceive.1.gz
+
+ local-clean:
+ -rm -f ../obj/* $(BIN_DIR)/pd $(BIN_DIR)/$(GUINAME) $(BIN_DIR)/pdsend \
diff --git a/media-sound/pd/files/digest-pd-0.35.0-r1 b/media-sound/pd/files/digest-pd-0.35.0-r1
new file mode 100644
index 000000000000..6a39bdcd7b73
--- /dev/null
+++ b/media-sound/pd/files/digest-pd-0.35.0-r1
@@ -0,0 +1 @@
+MD5 753920639d209f71a6d2b7de3d092476 pd-0.35-0.linux.tar.gz 1455220
diff --git a/media-sound/pd/pd-0.35.0-r1.ebuild b/media-sound/pd/pd-0.35.0-r1.ebuild
new file mode 100644
index 000000000000..eb7c56cf2d65
--- /dev/null
+++ b/media-sound/pd/pd-0.35.0-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pd/pd-0.35.0-r1.ebuild,v 1.1 2002/09/25 19:19:55 raker Exp $
+
+# Miller Puckette uses nonstandard versioning scheme that we have to crunch
+MY_P=`echo ${P} | sed 's/\.\([0-9]\+\)$/-\1/'`
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="real-time music and multimedia environment"
+SRC_URI="http://www-crca.ucsd.edu/~msp/Software/${MY_P}.linux.tar.gz"
+HOMEPAGE="http://www-crca.ucsd.edu/~msp/software.html"
+
+SLOT="0"
+LICENSE="BSD | as-is"
+KEYWORDS="x86"
+
+DEPEND=">=dev-lang/tcl-8.3.3
+ >=dev-lang/tk-8.3.3
+ alsa? ( >=media-libs/alsa-lib-0.9.0_rc2 )
+ X? ( x11-base/xfree )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S} || die
+ patch -p1 < ${FILESDIR}/0.35.0-r1.patch || die
+
+ cd src || die
+ autoconf || die
+
+}
+
+src_compile() {
+
+ cd src
+
+ local myconf
+
+ use alsa && myconf="--enable-alsa" \
+ || myconf="--disable-alsa"
+
+ use X && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug"
+ else
+ myconf="${myconf} --disable-debug"
+ fi
+
+ econf ${myconf} || die "./configure failed"
+
+ emake || die "parallel make failed"
+
+}
+
+src_install () {
+
+ cd src
+ make \
+ DESTDIR=${D} \
+ install || die "install failed"
+
+}