summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-03-03 16:11:10 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-03-03 16:11:10 +0000
commite1056a88ff5aef8ce387e532e411a574b9e40653 (patch)
treedfaf444380f5da8d3e4f40fa27f952a7551b6c79 /media-sound/protux
parentFix as-needed patch mess up reported by Daniel Glockner (bug #166374) (diff)
downloadgentoo-2-e1056a88ff5aef8ce387e532e411a574b9e40653.tar.gz
gentoo-2-e1056a88ff5aef8ce387e532e411a574b9e40653.tar.bz2
gentoo-2-e1056a88ff5aef8ce387e532e411a574b9e40653.zip
Version bump for bug #127537. protux is now written entirely in Java so adding java herd with the sound herd as the maintainer.
(Portage version: 2.1.2-r12)
Diffstat (limited to 'media-sound/protux')
-rw-r--r--media-sound/protux/ChangeLog9
-rw-r--r--media-sound/protux/files/digest-protux-0.50.1003
-rw-r--r--media-sound/protux/metadata.xml6
-rw-r--r--media-sound/protux/protux-0.50.100.ebuild36
4 files changed, 49 insertions, 5 deletions
diff --git a/media-sound/protux/ChangeLog b/media-sound/protux/ChangeLog
index d6a06937bff6..267686c622c4 100644
--- a/media-sound/protux/ChangeLog
+++ b/media-sound/protux/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/protux
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/protux/ChangeLog,v 1.22 2007/02/09 07:59:23 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/protux/ChangeLog,v 1.23 2007/03/03 16:11:10 betelgeuse Exp $
+
+*protux-0.50.100 (03 Mar 2007)
+
+ 03 Mar 2007; Petteri Räty <betelgeuse@gentoo.org> metadata.xml,
+ +protux-0.50.100.ebuild:
+ Version bump for bug #127537. protux is now written entirely in Java so
+ adding java herd with the sound herd as the maintainer.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/media-sound/protux/files/digest-protux-0.50.100 b/media-sound/protux/files/digest-protux-0.50.100
new file mode 100644
index 000000000000..93d2649c1598
--- /dev/null
+++ b/media-sound/protux/files/digest-protux-0.50.100
@@ -0,0 +1,3 @@
+MD5 11e260eda73d06a5ec392fa42a0176b1 protux-0.50.100.tar.gz 392027
+RMD160 e8806ce35a72e6b93e3df15e6fcd65a254e9950a protux-0.50.100.tar.gz 392027
+SHA256 cb8edab6684ea58c13e5cfcec0b6925f32e35cfca4129ca5ab668234541f78e2 protux-0.50.100.tar.gz 392027
diff --git a/media-sound/protux/metadata.xml b/media-sound/protux/metadata.xml
index ea12fab7b274..77d582bf1752 100644
--- a/media-sound/protux/metadata.xml
+++ b/media-sound/protux/metadata.xml
@@ -1,8 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sound</herd>
-<maintainer>
- <email>sound@gentoo.org</email>
- </maintainer>
+ <herd>sound</herd>
+ <herd>java</herd>
</pkgmetadata>
diff --git a/media-sound/protux/protux-0.50.100.ebuild b/media-sound/protux/protux-0.50.100.ebuild
new file mode 100644
index 000000000000..49f8bf3e9502
--- /dev/null
+++ b/media-sound/protux/protux-0.50.100.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/protux/protux-0.50.100.ebuild,v 1.1 2007/03/03 16:11:10 betelgeuse Exp $
+
+inherit java-pkg-2
+
+DESCRIPTION="Professional Audio Tools for GNU/Linux"
+HOMEPAGE="http://protux.sourceforge.net/"
+SRC_URI="http://${PN}.sourceforge.net/releases/${P}.tar.gz"
+
+IUSE="source"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND=">=virtual/jdk-1.5"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ cd src
+ ejavac -encoding latin1 $(find . -name "*.java")
+ jar cf ${PN}.jar $(find . -name "*.class") || die
+}
+
+src_install() {
+ java-pkg_dojar src/${PN}.jar
+ dodoc AUTHORS BUGLIST ChangeLog COPYRIGHT INSTALL README TODO || die
+ use source && java-pkg_dosrc src/org
+ # pwd like this because it does not find resources otherwise
+ java-pkg_dolauncher ${PN} \
+ --main org.protux.Main \
+ --pwd /usr/share/${PN}
+ insinto /usr/share/${PN}
+ doins -r resources || die
+}