summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-03-27 12:13:03 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-03-27 12:13:03 +0000
commitb73817403efd6fdf875af0187efee1ad6c47bbe6 (patch)
tree35c709356da61a99bbb0e562374d7390b123e714 /media-sound/qjackctl
parentUnmask www-client/opera-11.62. (diff)
downloadgentoo-2-b73817403efd6fdf875af0187efee1ad6c47bbe6.tar.gz
gentoo-2-b73817403efd6fdf875af0187efee1ad6c47bbe6.tar.bz2
gentoo-2-b73817403efd6fdf875af0187efee1ad6c47bbe6.zip
Migrate to qt4-r2.eclass, ACK'ed by aballier in bug #409705.
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/qjackctl')
-rw-r--r--media-sound/qjackctl/ChangeLog7
-rw-r--r--media-sound/qjackctl/qjackctl-0.3.8.ebuild28
2 files changed, 18 insertions, 17 deletions
diff --git a/media-sound/qjackctl/ChangeLog b/media-sound/qjackctl/ChangeLog
index f7fa064725e3..2768e6b32914 100644
--- a/media-sound/qjackctl/ChangeLog
+++ b/media-sound/qjackctl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/qjackctl
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.71 2011/08/12 18:51:07 xarthisius Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.72 2012/03/27 12:13:03 pesa Exp $
+
+ 27 Mar 2012; Davide Pesavento <pesa@gentoo.org> qjackctl-0.3.8.ebuild:
+ Migrate to qt4-r2.eclass, ACK'ed by aballier in bug #409705.
12 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org> qjackctl-0.3.2.ebuild,
qjackctl-0.3.7.ebuild, qjackctl-0.3.8.ebuild:
diff --git a/media-sound/qjackctl/qjackctl-0.3.8.ebuild b/media-sound/qjackctl/qjackctl-0.3.8.ebuild
index d197f6231d65..b8856f901666 100644
--- a/media-sound/qjackctl/qjackctl-0.3.8.ebuild
+++ b/media-sound/qjackctl/qjackctl-0.3.8.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/qjackctl-0.3.8.ebuild,v 1.2 2011/08/12 18:51:07 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/qjackctl-0.3.8.ebuild,v 1.3 2012/03/27 12:13:03 pesa Exp $
-EAPI=2
+EAPI=4
-inherit qt4
+inherit qt4-r2
DESCRIPTION="A Qt application to control the JACK Audio Connection Kit and ALSA sequencer connections."
HOMEPAGE="http://qjackctl.sourceforge.net/"
@@ -16,14 +16,17 @@ KEYWORDS="~amd64 ~x86"
IUSE="alsa dbus debug portaudio"
-RDEPEND="alsa? ( media-libs/alsa-lib )
+RDEPEND="
+ >=media-sound/jack-audio-connection-kit-0.109.2
x11-libs/qt-core:4
x11-libs/qt-gui:4
- dbus? ( x11-libs/qt-dbus )
- portaudio? ( media-libs/portaudio )
- >=media-sound/jack-audio-connection-kit-0.109.2"
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( x11-libs/qt-dbus:4 )
+ portaudio? ( media-libs/portaudio )"
DEPEND="${RDEPEND}"
+DOCS="AUTHORS ChangeLog README TODO TRANSLATORS"
+
src_configure() {
econf \
$(use_enable alsa alsa-seq) \
@@ -33,15 +36,10 @@ src_configure() {
# Emulate what the Makefile does, so that we can get the correct
# compiler used.
- eqmake4 ${PN}.pro -o ${PN}.mak || die "eqmake4 failed"
+ eqmake4 ${PN}.pro -o ${PN}.mak
}
src_compile() {
- emake -f ${PN}.mak || die "emake failed"
+ emake -f ${PN}.mak
lupdate ${PN}.pro || die "lupdate failed"
}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README ChangeLog TODO AUTHORS TRANSLATORS
-}