summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-07-11 18:43:16 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-07-11 18:43:16 +0000
commitc8214e227931a879a04731d1f333c56ee4d3d71e (patch)
treecea49d5eca181d3f3e83eb6b830381859d44e304 /media-sound/qjackctl
parentVersion bump. Fixes bug 371375. Remove bundled sysfsutils. Some QA fixes. Rem... (diff)
downloadgentoo-2-c8214e227931a879a04731d1f333c56ee4d3d71e.tar.gz
gentoo-2-c8214e227931a879a04731d1f333c56ee4d3d71e.tar.bz2
gentoo-2-c8214e227931a879a04731d1f333c56ee4d3d71e.zip
version bump, bug #374281
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/qjackctl')
-rw-r--r--media-sound/qjackctl/ChangeLog7
-rw-r--r--media-sound/qjackctl/qjackctl-0.3.8.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/media-sound/qjackctl/ChangeLog b/media-sound/qjackctl/ChangeLog
index b24cc275a56b..20fd8dd6937c 100644
--- a/media-sound/qjackctl/ChangeLog
+++ b/media-sound/qjackctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/qjackctl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.69 2011/04/17 12:49:49 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.70 2011/07/11 18:43:16 aballier Exp $
+
+*qjackctl-0.3.8 (11 Jul 2011)
+
+ 11 Jul 2011; Alexis Ballier <aballier@gentoo.org> +qjackctl-0.3.8.ebuild:
+ version bump, bug #374281
17 Apr 2011; Thomas Kahle <tomka@gentoo.org> qjackctl-0.3.2.ebuild:
Dropping to ~x86 b/c of bugs 331157, 363915.
diff --git a/media-sound/qjackctl/qjackctl-0.3.8.ebuild b/media-sound/qjackctl/qjackctl-0.3.8.ebuild
new file mode 100644
index 000000000000..b17cd50cd16d
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.3.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/qjackctl-0.3.8.ebuild,v 1.1 2011/07/11 18:43:16 aballier Exp $
+
+EAPI=2
+
+inherit qt4
+
+DESCRIPTION="A Qt application to control the JACK Audio Connection Kit and ALSA sequencer connections."
+HOMEPAGE="http://qjackctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="alsa dbus debug portaudio"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ dbus? ( x11-libs/qt-dbus )
+ portaudio? ( media-libs/portaudio )
+ >=media-sound/jack-audio-connection-kit-0.109.2"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable alsa alsa-seq) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable portaudio)
+
+ # Emulate what the Makefile does, so that we can get the correct
+ # compiler used.
+ eqmake4 ${PN}.pro -o ${PN}.mak || die "eqmake4 failed"
+}
+
+src_compile() {
+ emake -f ${PN}.mak || die "emake failed"
+ lupdate ${PN}.pro || die "lupdate failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog TODO AUTHORS TRANSLATORS
+}