summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-10 12:29:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-10 12:29:34 +0000
commit03150259bca63d70ab8ebc0e963a2ba8e7b3670f (patch)
tree265b787ca16424a0684a95ee09299e8bffb2a8de /media-sound/qsynth
parentUpdate to EAPI=2 and USE deps. (diff)
downloadgentoo-2-03150259bca63d70ab8ebc0e963a2ba8e7b3670f.tar.gz
gentoo-2-03150259bca63d70ab8ebc0e963a2ba8e7b3670f.tar.bz2
gentoo-2-03150259bca63d70ab8ebc0e963a2ba8e7b3670f.zip
Update to EAPI=2 and USE deps.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'media-sound/qsynth')
-rw-r--r--media-sound/qsynth/ChangeLog8
-rw-r--r--media-sound/qsynth/qsynth-0.3.3-r1.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/media-sound/qsynth/ChangeLog b/media-sound/qsynth/ChangeLog
index b78125f0f824..ae6f2e1e5dd6 100644
--- a/media-sound/qsynth/ChangeLog
+++ b/media-sound/qsynth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/qsynth
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/ChangeLog,v 1.43 2008/07/28 21:24:17 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/ChangeLog,v 1.44 2008/10/10 12:29:34 flameeyes Exp $
+
+*qsynth-0.3.3-r1 (10 Oct 2008)
+
+ 10 Oct 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +qsynth-0.3.3-r1.ebuild:
+ Update to EAPI=2 and USE deps.
28 Jul 2008; Carsten Lohrke <carlo@gentoo.org> qsynth-0.3.1-r1.ebuild:
QA: Get rid of deprecated qt4_min_version().
diff --git a/media-sound/qsynth/qsynth-0.3.3-r1.ebuild b/media-sound/qsynth/qsynth-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..ac8f88dce407
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.3.3-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/qsynth-0.3.3-r1.ebuild,v 1.1 2008/10/10 12:29:34 flameeyes Exp $
+
+EAPI=2
+
+inherit qt4 eutils flag-o-matic
+
+DESCRIPTION="A Qt application to control FluidSynth"
+HOMEPAGE="http://qsynth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="debug jack alsa"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="
+ || ( (
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ ) =x11-libs/qt-4.3*:4 )
+ >=media-sound/fluidsynth-1.0.7a[jack?,alsa?]
+ !jack? ( !alsa? ( >=media-sound/fluidsynth-1.0.7a[oss] ) )"
+
+src_configure() {
+ # Stupidly, qsynth's configure does *not* use pkg-config to
+ # discover the presence of Qt4, but uses fixed paths; as they
+ # don't really work that well for our case, let's just use this
+ # nasty hack and be done with it. *NOTE*: this hinders
+ # cross-compile.
+ append-flags -I/usr/include/qt4
+ append-ldflags -L/usr/$(get_libdir)/qt4
+
+ econf \
+ $(use_enable debug) \
+ || die "econf failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README TODO
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm -rf "${D}/usr/share/applications/qsynth.desktop"
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}