summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-05-12 15:26:34 +0000
committerSamuli Suominen <drac@gentoo.org>2008-05-12 15:26:34 +0000
commit11b7ec6a3a05b802f8f9d86a37b04c0cd5162f86 (patch)
tree0dc8213589967a2454a9fbbfaa9ad1440e83cade /media-sound/shell-fm
parentalpha/ia64/sparc stable wrt #221063 (diff)
downloadgentoo-2-11b7ec6a3a05b802f8f9d86a37b04c0cd5162f86.tar.gz
gentoo-2-11b7ec6a3a05b802f8f9d86a37b04c0cd5162f86.tar.bz2
gentoo-2-11b7ec6a3a05b802f8f9d86a37b04c0cd5162f86.zip
Version bump.
(Portage version: 2.1.5_rc7)
Diffstat (limited to 'media-sound/shell-fm')
-rw-r--r--media-sound/shell-fm/ChangeLog9
-rw-r--r--media-sound/shell-fm/shell-fm-0.5.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/media-sound/shell-fm/ChangeLog b/media-sound/shell-fm/ChangeLog
index e1a253b1996d..51ebdcf705f6 100644
--- a/media-sound/shell-fm/ChangeLog
+++ b/media-sound/shell-fm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/shell-fm
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/ChangeLog,v 1.7 2007/11/19 22:22:25 drac Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/ChangeLog,v 1.8 2008/05/12 15:26:34 drac Exp $
+
+*shell-fm-0.5 (12 May 2008)
+
+ 12 May 2008; Samuli Suominen <drac@gentoo.org> +shell-fm-0.5.ebuild:
+ Version bump.
*shell-fm-0.4 (19 Nov 2007)
diff --git a/media-sound/shell-fm/shell-fm-0.5.ebuild b/media-sound/shell-fm/shell-fm-0.5.ebuild
new file mode 100644
index 000000000000..760443ec6265
--- /dev/null
+++ b/media-sound/shell-fm/shell-fm-0.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/shell-fm-0.5.ebuild,v 1.1 2008/05/12 15:26:34 drac Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A lightweight console based player for Last.FM radio streams."
+HOMEPAGE="http://nex.scrapping.cc/code/shell-fm"
+SRC_URI="http://nex.scrapping.cc/code/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libmad
+ media-libs/libao"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:gcc:$(tc-getCC):" -e "s:-Os:${CFLAGS}:" \
+ source/Makefile || die "sed failed."
+}
+
+src_compile() {
+ tc-export CC
+ emake -C source || die "emake failed."
+}
+
+src_install() {
+ dobin source/${PN} || die "dobin failed."
+ doman manual/${PN}.1
+ insinto /usr/share/doc/${PF}/scripts
+ doins scripts/{*.sh,zcontrol} || die "doins failed."
+}