summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2010-04-18 00:23:14 +0000
committerJoseph Jezak <josejx@gentoo.org>2010-04-18 00:23:14 +0000
commit81afbb1cb217a6533c31664f1449759533fb6711 (patch)
treea00d1465d77055e1a73ed6b64effc784782031cb /media-sound/shell-fm
parentInitial commit of new ck-sources, see bug #297169. (diff)
downloadgentoo-2-81afbb1cb217a6533c31664f1449759533fb6711.tar.gz
gentoo-2-81afbb1cb217a6533c31664f1449759533fb6711.tar.bz2
gentoo-2-81afbb1cb217a6533c31664f1449759533fb6711.zip
Add flags for ppc to build with big endian support, fixes bug #303667.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/shell-fm')
-rw-r--r--media-sound/shell-fm/ChangeLog7
-rw-r--r--media-sound/shell-fm/shell-fm-0.7.ebuild10
2 files changed, 11 insertions, 6 deletions
diff --git a/media-sound/shell-fm/ChangeLog b/media-sound/shell-fm/ChangeLog
index 6e0ecf7b159e..714d211972de 100644
--- a/media-sound/shell-fm/ChangeLog
+++ b/media-sound/shell-fm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/shell-fm
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/ChangeLog,v 1.12 2009/11/24 14:09:05 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/ChangeLog,v 1.13 2010/04/18 00:23:14 josejx Exp $
+
+ 18 Apr 2010; Joseph Jezak <josejx@gentoo.org> shell-fm-0.7.ebuild:
+ Add flags for ppc to build with big endian support, fixes bug #303667.
24 Nov 2009; Diego E. Pettenò <flameeyes@gentoo.org>
-shell-fm-0.6.ebuild, shell-fm-0.7.ebuild,
diff --git a/media-sound/shell-fm/shell-fm-0.7.ebuild b/media-sound/shell-fm/shell-fm-0.7.ebuild
index 051e3638cbc6..a05e7337e7c8 100644
--- a/media-sound/shell-fm/shell-fm-0.7.ebuild
+++ b/media-sound/shell-fm/shell-fm-0.7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/shell-fm-0.7.ebuild,v 1.2 2009/11/24 14:09:05 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/shell-fm-0.7.ebuild,v 1.3 2010/04/18 00:23:14 josejx Exp $
EAPI=2
-inherit toolchain-funcs eutils
+inherit flag-o-matic toolchain-funcs eutils
DESCRIPTION="A lightweight console based player for Last.FM radio streams"
HOMEPAGE="http://nex.scrapping.cc/shell-fm/"
@@ -24,12 +24,14 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}/${P}-asneeded.patch"
-
sed -i -e "s:-Os::" source/Makefile || die "sed failed"
}
src_compile() {
tc-export CC
+ if use ppc; then
+ append-flags -DWORDS_BIGENDIAN=1
+ fi
emake || die "emake failed"
}