summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-03-15 19:02:38 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-03-15 19:02:38 +0000
commitd6778f04ccacce7e361aebc79abd42e271a96f20 (patch)
treeb0de456ac60e964a086653552755dfc1067bb5ff /media-sound/sox/sox-13.0.0.ebuild
parentRemove mask for app-shells/tcsh-6.14-r31 as it is no longer in the tree (diff)
downloadgentoo-2-d6778f04ccacce7e361aebc79abd42e271a96f20.tar.gz
gentoo-2-d6778f04ccacce7e361aebc79abd42e271a96f20.tar.bz2
gentoo-2-d6778f04ccacce7e361aebc79abd42e271a96f20.zip
Version bump, bug #170990
(Portage version: 2.1.2.2)
Diffstat (limited to 'media-sound/sox/sox-13.0.0.ebuild')
-rw-r--r--media-sound/sox/sox-13.0.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-sound/sox/sox-13.0.0.ebuild b/media-sound/sox/sox-13.0.0.ebuild
new file mode 100644
index 000000000000..d49481177ba7
--- /dev/null
+++ b/media-sound/sox/sox-13.0.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-13.0.0.ebuild,v 1.1 2007/03/15 19:02:38 aballier Exp $
+
+inherit flag-o-matic eutils autotools
+
+DESCRIPTION="The swiss army knife of sound processing programs"
+HOMEPAGE="http://sox.sourceforge.net"
+SRC_URI="mirror://sourceforge/sox/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa debug flac encode mad ogg libsamplerate sndfile"
+
+DEPEND="virtual/libc
+ alsa? ( media-libs/alsa-lib )
+ encode? ( media-sound/lame )
+ flac? ( media-libs/flac )
+ mad? ( media-libs/libmad )
+ sndfile? ( media-libs/libsndfile )
+ libsamplerate? ( media-libs/libsamplerate )
+ media-libs/libvorbis
+ media-libs/libogg"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-flac113.patch"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile () {
+ # Fixes wav segfaults. See Bug #35745.
+ append-flags -fsigned-char
+
+ econf $(use_enable alsa alsa-dsp) \
+ $(use_with encode lame) \
+ $(use_with mad) \
+ $(use_enable debug) \
+ $(use_with sndfile) \
+ $(use_with flac) \
+ $(use_with libsamplerate samplerate) \
+ --enable-oss-dsp \
+ --enable-fast-ulaw \
+ --enable-fast-alaw \
+ || die "configure failed"
+
+ #workaround for flac, it wants to include a damn config.h file
+ touch src/config.h
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc NEWS ChangeLog README AUTHORS
+}