summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-09-21 11:53:37 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-09-21 11:53:37 +0000
commit811aa813ea779a02a05f71446858837f2f37dd8b (patch)
tree812e9e51bc26068da797cc3816aafedbc2a617ce /media-sound/teamspeak-client-bin
parentVersion bump to 3.0.9, fixes bug #485540 reported by Markus Saarinen. (diff)
downloadgentoo-2-811aa813ea779a02a05f71446858837f2f37dd8b.tar.gz
gentoo-2-811aa813ea779a02a05f71446858837f2f37dd8b.tar.bz2
gentoo-2-811aa813ea779a02a05f71446858837f2f37dd8b.zip
Version bump to 3.0.12, fixes bug #485540 reported by Markus Saarinen.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'media-sound/teamspeak-client-bin')
-rw-r--r--media-sound/teamspeak-client-bin/ChangeLog8
-rw-r--r--media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.12.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/media-sound/teamspeak-client-bin/ChangeLog b/media-sound/teamspeak-client-bin/ChangeLog
index 1ec13d5356c0..172060199c66 100644
--- a/media-sound/teamspeak-client-bin/ChangeLog
+++ b/media-sound/teamspeak-client-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/teamspeak-client-bin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak-client-bin/ChangeLog,v 1.33 2013/08/07 20:28:10 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak-client-bin/ChangeLog,v 1.34 2013/09/21 11:53:37 tomwij Exp $
+
+*teamspeak-client-bin-3.0.12 (21 Sep 2013)
+
+ 21 Sep 2013; Tom Wijsman <TomWij@gentoo.org>
+ +teamspeak-client-bin-3.0.12.ebuild, metadata.xml:
+ Version bump to 3.0.12, fixes bug #485540 reported by Markus Saarinen.
*teamspeak-client-bin-3.0.11.1 (07 Aug 2013)
diff --git a/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.12.ebuild b/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.12.ebuild
new file mode 100644
index 000000000000..7373d9a0f942
--- /dev/null
+++ b/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.12.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.12.ebuild,v 1.1 2013/09/21 11:53:37 tomwij Exp $
+
+EAPI=5
+
+inherit eutils unpacker
+
+DESCRIPTION="TeamSpeak Client - Voice Communication Software"
+HOMEPAGE="http://www.teamspeak.com/"
+LICENSE="teamspeak3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="fetch mirror strip"
+
+SRC_URI="amd64? ( http://ftp.4players.de/pub/hosted/ts3/releases/${PV}/TeamSpeak3-Client-linux_amd64-${PV/_/-}.run )
+ x86? ( http://ftp.4players.de/pub/hosted/ts3/releases/${PV}/TeamSpeak3-Client-linux_x86-${PV/_/-}.run )"
+
+RDEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4[accessibility,xinerama]
+ dev-qt/qtsql:4
+ sys-libs/glibc
+ sys-libs/zlib"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ if use amd64 ; then
+ einfo "Please download TeamSpeak3-Client-linux_amd64-${PV/_/-}.run"
+ elif use x86 ; then
+ einfo "Please download TeamSpeak3-Client-linux_x86-${PV/_/-}.run"
+ fi
+ einfo "from ${HOMEPAGE}?page=downloads and place this"
+ einfo "file in ${DISTDIR}"
+}
+
+src_prepare() {
+ # Remove the qt-libraries as they just cause trouble with the system's Qt, see bug #328807.
+ rm libQt* || die "Couldn't remove bundled Qt libraries."
+
+ # Rename the tsclient to its shorter version, required by the teamspeak3 script we install.
+ mv ts3client_linux_* ts3client || die "Couldn't rename ts3client to its shorter version."
+}
+
+src_install() {
+ dodir /opt/teamspeak3-client
+ insinto /opt/teamspeak3-client
+ doins -r *
+
+ fperms +x /opt/teamspeak3-client/ts3client
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/teamspeak3"
+
+ make_desktop_entry teamspeak3 TeamSpeak3 \
+ "/opt/teamspeak3-client/pluginsdk/docs/client_html/images/logo.png" \
+ Network
+}