summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-05-16 11:40:39 +0000
committerSamuli Suominen <drac@gentoo.org>2008-05-16 11:40:39 +0000
commitc17ac968bf249e657d373cecd48d8a2111d07380 (patch)
tree33431511869cd14f23b3781c1752f4599b2481c6 /media-sound/tunapie
parentFixed WRQ handling in tftpd, backported changes from debian and now we reopen... (diff)
downloadgentoo-2-c17ac968bf249e657d373cecd48d8a2111d07380.tar.gz
gentoo-2-c17ac968bf249e657d373cecd48d8a2111d07380.tar.bz2
gentoo-2-c17ac968bf249e657d373cecd48d8a2111d07380.zip
Version bump. Install into libdir and properly byte-compile.
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'media-sound/tunapie')
-rw-r--r--media-sound/tunapie/ChangeLog7
-rw-r--r--media-sound/tunapie/tunapie-2.1.6.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/media-sound/tunapie/ChangeLog b/media-sound/tunapie/ChangeLog
index c5fe093dd042..90e49f85af68 100644
--- a/media-sound/tunapie/ChangeLog
+++ b/media-sound/tunapie/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/tunapie
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tunapie/ChangeLog,v 1.3 2008/04/05 17:39:01 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tunapie/ChangeLog,v 1.4 2008/05/16 11:40:39 drac Exp $
+
+*tunapie-2.1.6 (16 May 2008)
+
+ 16 May 2008; Samuli Suominen <drac@gentoo.org> +tunapie-2.1.6.ebuild:
+ Version bump. Install into libdir and properly byte-compile.
*tunapie-2.1.5 (05 Apr 2008)
diff --git a/media-sound/tunapie/tunapie-2.1.6.ebuild b/media-sound/tunapie/tunapie-2.1.6.ebuild
new file mode 100644
index 000000000000..5b05c1f05d6f
--- /dev/null
+++ b/media-sound/tunapie/tunapie-2.1.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tunapie/tunapie-2.1.6.ebuild,v 1.1 2008/05/16 11:40:39 drac Exp $
+
+inherit eutils multilib python
+
+DESCRIPTION="Directory browser for Radio and TV streams"
+HOMEPAGE="http://tunapie.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="offensive"
+
+RDEPEND="=dev-python/wxpython-2.6*"
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:/usr/local/share:/usr/$(get_libdir):" \
+ "${S}"/${PN} || die "sed failed."
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed."
+ doman ${PN}.1
+ dodoc CHANGELOG README
+
+ domenu ${PN}.desktop
+ doicon src/tplogo.xpm
+
+ insinto /usr/$(get_libdir)/${PN}
+ doins src/{*.py,*.png}
+
+ dodir /etc
+
+ if use offensive; then
+ echo 1 > "${D}"/etc/${PN}.config
+ else
+ echo 0 > "${D}"/etc/${PN}.config
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize "${ROOT}"usr/$(get_libdir)/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}