summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-02-02 17:03:41 +0000
committerBen de Groot <yngwin@gentoo.org>2015-02-02 17:03:41 +0000
commit5213ed5be472467257dcd34f95b8f423bc09cc70 (patch)
tree3a3732f7e4fa66887b83da35275ab4d5ce442a1f /media-sound
parentVersion bump, bug #537978 (diff)
downloadgentoo-2-5213ed5be472467257dcd34f95b8f423bc09cc70.tar.gz
gentoo-2-5213ed5be472467257dcd34f95b8f423bc09cc70.tar.bz2
gentoo-2-5213ed5be472467257dcd34f95b8f423bc09cc70.zip
version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x4FDF9CFD2FAC514E!)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/picard/ChangeLog7
-rw-r--r--media-sound/picard/picard-1.3.2.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/media-sound/picard/ChangeLog b/media-sound/picard/ChangeLog
index 7771525ddb5a..2d755baa8028 100644
--- a/media-sound/picard/ChangeLog
+++ b/media-sound/picard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/picard
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/picard/ChangeLog,v 1.51 2015/01/31 14:12:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/picard/ChangeLog,v 1.52 2015/02/02 17:03:41 yngwin Exp $
+
+*picard-1.3.2 (02 Feb 2015)
+
+ 02 Feb 2015; Ben de Groot <yngwin@gentoo.org> +picard-1.3.2.ebuild:
+ version bump
31 Jan 2015; Agostino Sarubbo <ago@gentoo.org> picard-1.3.1.ebuild:
Stable for amd64, wrt bug #534268
diff --git a/media-sound/picard/picard-1.3.2.ebuild b/media-sound/picard/picard-1.3.2.ebuild
new file mode 100644
index 000000000000..7a1a11b41df1
--- /dev/null
+++ b/media-sound/picard/picard-1.3.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/picard/picard-1.3.2.ebuild,v 1.1 2015/02/02 17:03:41 yngwin Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+DISABLE_AUTOFORMATTING=true
+inherit eutils distutils-r1 readme.gentoo
+
+DESCRIPTION="A cross-platform music tagger"
+HOMEPAGE="http://picard.musicbrainz.org/"
+SRC_URI="http://ftp.musicbrainz.org/pub/musicbrainz/picard/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+acoustid +cdda nls"
+
+DEPEND="dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ dev-qt/qtgui:4[accessibility]
+ media-libs/mutagen
+ acoustid? ( >=media-libs/chromaprint-1.0[tools] )
+ cdda? ( >=media-libs/libdiscid-0.1.1 )"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test" # doesn't work with ebuilds
+S=${WORKDIR}/${PN}-release-${PV}
+DOCS="AUTHORS.txt NEWS.txt"
+
+DOC_CONTENTS="If you are upgrading Picard and it does not start,
+try removing Picard's settings:
+ rm ~/.config/MusicBrainz/Picard.conf
+
+You should set the environment variable BROWSER to something like
+ firefox '%s' &
+to let python know which browser to use."
+
+src_compile() {
+ distutils-r1_src_compile $(use nls || echo "--disable-locales")
+}
+
+src_install() {
+ distutils-r1_src_install --disable-autoupdate --skip-build \
+ $(use nls || echo "--disable-locales")
+
+ doicon picard.ico
+ domenu picard.desktop
+ readme.gentoo_create_doc
+}