summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-07-26 16:40:29 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-07-26 16:40:29 +0000
commit6dd9cc25baae27b246e32c9e3a75f83294614036 (patch)
tree21aa8d788b3e11c8f8eb6645a5bf2802bc64e590 /media-sound
parentVersion bump. (diff)
downloadgentoo-2-6dd9cc25baae27b246e32c9e3a75f83294614036.tar.gz
gentoo-2-6dd9cc25baae27b246e32c9e3a75f83294614036.tar.bz2
gentoo-2-6dd9cc25baae27b246e32c9e3a75f83294614036.zip
add live ebuild, add upstream info
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/pnmixer/ChangeLog8
-rw-r--r--media-sound/pnmixer/metadata.xml7
-rw-r--r--media-sound/pnmixer/pnmixer-9999.ebuild57
3 files changed, 69 insertions, 3 deletions
diff --git a/media-sound/pnmixer/ChangeLog b/media-sound/pnmixer/ChangeLog
index 597d1f4b3202..b4d13cac3ae9 100644
--- a/media-sound/pnmixer/ChangeLog
+++ b/media-sound/pnmixer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/pnmixer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pnmixer/ChangeLog,v 1.9 2014/06/30 00:34:26 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pnmixer/ChangeLog,v 1.10 2014/07/26 16:40:29 hasufell Exp $
+
+*pnmixer-9999 (26 Jul 2014)
+
+ 26 Jul 2014; Julian Ospald <hasufell@gentoo.org> +pnmixer-9999.ebuild,
+ metadata.xml:
+ add live ebuild, add upstream info
30 Jun 2014; Julian Ospald <hasufell@gentoo.org>
pnmixer-0.6_pre20111213.ebuild:
diff --git a/media-sound/pnmixer/metadata.xml b/media-sound/pnmixer/metadata.xml
index bfabcd0164b9..858f74ca808e 100644
--- a/media-sound/pnmixer/metadata.xml
+++ b/media-sound/pnmixer/metadata.xml
@@ -5,5 +5,8 @@
<email>hasufell@gentoo.org</email>
<name>Julian Ospald</name>
</maintainer>
-</pkgmetadata>
-
+ <upstream>
+ <doc lang="en">https://github.com/nicklan/pnmixer/wiki</doc>
+ <bugs-to>https://github.com/nicklan/pnmixer/issues</bugs-to>
+ </upstream>
+</pkgmetadata> \ No newline at end of file
diff --git a/media-sound/pnmixer/pnmixer-9999.ebuild b/media-sound/pnmixer/pnmixer-9999.ebuild
new file mode 100644
index 000000000000..27ec2c005156
--- /dev/null
+++ b/media-sound/pnmixer/pnmixer-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pnmixer/pnmixer-9999.ebuild,v 1.1 2014/07/26 16:40:29 hasufell Exp $
+
+EAPI=5
+
+WANT_LIBTOOL=none
+inherit autotools eutils gnome2-utils git-2
+
+DESCRIPTION="Volume mixer for the system tray"
+HOMEPAGE="https://github.com/nicklan/pnmixer"
+EGIT_REPO_URI="git@github.com:nicklan/pnmixer.git
+ https://github.com/nicklan/pnmixer.git"
+EGIT_BRANCH="master"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug libnotify"
+
+RDEPEND="dev-libs/glib:2
+ media-libs/alsa-lib
+ >=x11-libs/gtk+-3.6:3
+ x11-libs/libX11
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with libnotify) \
+ $(use_enable debug) \
+ --enable-minimal-flags \
+ --with-gtk3
+}
+
+src_install() {
+ default
+ newicon -s 128 pixmaps/${PN}-about.png ${PN}.png
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}