summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-01-14 06:44:24 +0000
committerTim Harder <radhermit@gentoo.org>2011-01-14 06:44:24 +0000
commit7cea5664c648bb5d88888cda0180dd5dde877cba (patch)
tree4a6feb8aa6cc8c1e7bc17882c405a04085c057be /media-sound
parentVersion bump. Update required libmpdclient version. (diff)
downloadgentoo-2-7cea5664c648bb5d88888cda0180dd5dde877cba.tar.gz
gentoo-2-7cea5664c648bb5d88888cda0180dd5dde877cba.tar.bz2
gentoo-2-7cea5664c648bb5d88888cda0180dd5dde877cba.zip
Version bump. Update required libmpdclient version.
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpdscribble/ChangeLog9
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.21.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/media-sound/mpdscribble/ChangeLog b/media-sound/mpdscribble/ChangeLog
index 1fd901dd7523..d4930f686aa3 100644
--- a/media-sound/mpdscribble/ChangeLog
+++ b/media-sound/mpdscribble/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/mpdscribble
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/ChangeLog,v 1.39 2010/10/11 17:03:25 radhermit Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/ChangeLog,v 1.40 2011/01/14 06:44:24 radhermit Exp $
+
+*mpdscribble-0.21 (14 Jan 2011)
+
+ 14 Jan 2011; Tim Harder <radhermit@gentoo.org> +mpdscribble-0.21.ebuild:
+ Version bump. Update required libmpdclient version.
*mpdscribble-0.20 (11 Oct 2010)
diff --git a/media-sound/mpdscribble/mpdscribble-0.21.ebuild b/media-sound/mpdscribble/mpdscribble-0.21.ebuild
new file mode 100644
index 000000000000..74260d66e4b8
--- /dev/null
+++ b/media-sound/mpdscribble/mpdscribble-0.21.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpdscribble/mpdscribble-0.21.ebuild,v 1.1 2011/01/14 06:44:24 radhermit Exp $
+
+EAPI=2
+WANT_AUTOMAKE="1.11"
+inherit autotools eutils
+
+DESCRIPTION="An MPD client that submits information to Audioscrobbler"
+HOMEPAGE="http://mpd.wikia.com/wiki/Client:Mpdscribble"
+SRC_URI="mirror://sourceforge/musicpd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="+curl"
+
+RDEPEND=">=dev-libs/glib-2.16:2
+ >=media-libs/libmpdclient-2.2
+ curl? ( net-misc/curl )
+ !curl? ( net-libs/libsoup:2.4 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.18-ldadd_gthread.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myclient=soup
+ use curl && myclient=curl
+ econf \
+ --disable-dependency-tracking \
+ --with-http-client=${myclient}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble
+ chmod 600 "${D}"/etc/mpdscribble.conf
+ dodoc AUTHORS NEWS README
+ rm -r -f "${D}"/usr/share/doc/${PN}
+ dodir /var/cache/mpdscribble
+}