summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-03-28 12:18:04 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-03-28 12:18:04 +0000
commit84e6d8a104e71079722fece56983a7dc460c85f7 (patch)
tree9f41bbfc9537f8231f7611f87f6d3d315aa76cbf /media-sound
parentVersion bump dev-haskell/alex. (diff)
downloadgentoo-2-84e6d8a104e71079722fece56983a7dc460c85f7.tar.gz
gentoo-2-84e6d8a104e71079722fece56983a7dc460c85f7.tar.bz2
gentoo-2-84e6d8a104e71079722fece56983a7dc460c85f7.zip
Applied upstream patch to fix a crash on startup on the info applet caused by a Qt bug.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/ChangeLog9
-rw-r--r--media-sound/amarok/amarok-2.3.0-r1.ebuild120
-rw-r--r--media-sound/amarok/files/amarok-2.3.0-crash_fix_info_applet.patch61
3 files changed, 189 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 6dbd54c8dc3f..1a1118094efd 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/amarok
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.368 2010/03/15 12:32:41 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.369 2010/03/28 12:18:04 jmbsvicetto Exp $
+
+*amarok-2.3.0-r1 (28 Mar 2010)
+
+ 28 Mar 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +amarok-2.3.0-r1.ebuild, +files/amarok-2.3.0-crash_fix_info_applet.patch:
+ Applied upstream patch to fix a crash on startup on the info applet caused
+ by a Qt bug.
*amarok-2.3.0 (15 Mar 2010)
diff --git a/media-sound/amarok/amarok-2.3.0-r1.ebuild b/media-sound/amarok/amarok-2.3.0-r1.ebuild
new file mode 100644
index 000000000000..75edaeb26711
--- /dev/null
+++ b/media-sound/amarok/amarok-2.3.0-r1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-2.3.0-r1.ebuild,v 1.1 2010/03/28 12:18:04 jmbsvicetto Exp $
+
+EAPI="2"
+
+# Translations are only in the tarballs, not the git repo
+if [[ ${PV} != *9999* ]]; then
+ KDE_LINGUAS="bg ca cs da de en_GB es et eu fi fr it ja km nb nds nl
+ pa pl pt pt_BR ru sl sr sr@latin sv th tr uk wa zh_TW"
+else
+ EGIT_REPO_URI="git://gitorious.org/${PN}/${PN}.git"
+ GIT_ECLASS="git"
+fi
+OPENGL_REQUIRED="optional"
+inherit kde4-base ${GIT_ECLASS}
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="4"
+IUSE="cdda daap debug embedded ipod lastfm mp3tunes mtp semantic-desktop"
+
+# ipod requires gdk enabled and also gtk compiled in libgpod
+DEPEND="
+ app-crypt/qca:2
+ >=app-misc/strigi-0.5.7[dbus,qt4]
+ >=dev-db/mysql-5.0.76
+ >=media-libs/taglib-1.6.1[asf,mp4]
+ >=media-libs/taglib-extras-1.0.1
+ >=kde-base/kdelibs-${KDE_MINIMAL}[opengl?,semantic-desktop?]
+ sys-libs/zlib
+ x11-libs/qt-script
+ >=x11-libs/qtscriptgenerator-0.1.0
+ embedded? ( <dev-db/mysql-5.1[embedded,-minimal] )
+ cdda? (
+ >=kde-base/libkcddb-${KDE_MINIMAL}
+ >=kde-base/libkcompactdisc-${KDE_MINIMAL}
+ >=kde-base/kdemultimedia-kioslaves-${KDE_MINIMAL}
+ )
+ ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
+ lastfm? ( >=media-libs/liblastfm-0.3.0 )
+ mp3tunes? (
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-libs/loudmouth
+ net-misc/curl
+ x11-libs/qt-core[glib]
+ )
+ mtp? ( >=media-libs/libmtp-0.3.0 )
+"
+RDEPEND="${DEPEND}
+ >=kde-base/phonon-kde-${KDE_MINIMAL}
+ >=media-sound/amarok-utils-${PV}
+ semantic-desktop? ( >=kde-base/nepomuk-${KDE_MINIMAL} )
+"
+
+PATCHES=( "${FILESDIR}/${P}-crash_fix_info_applet.patch" )
+
+# Tests require gmock - http://code.google.com/p/gmock/
+# It's not in the tree yet
+RESTRICT="test"
+
+# Only really required for live ebuild, to skip git_src_prepare
+src_prepare() {
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_PLAYER=ON
+ -DWITH_UTILITIES=OFF
+ -DWITH_Libgcrypt=OFF
+ $(cmake-utils_use embedded WITH_MYSQL_EMBEDDED)
+ $(cmake-utils_use_with ipod)
+ $(cmake-utils_use_with ipod Gdk)
+ $(cmake-utils_use_with lastfm LibLastFm)
+ $(cmake-utils_use_with mtp)
+ $(cmake-utils_use_with mp3tunes MP3Tunes)
+ )
+ # $(cmake-utils_use_with semantic-desktop Nepomuk)
+ # $(cmake-utils_use_with semantic-desktop Soprano)
+
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if use daap; then
+ echo
+ elog "You have installed amarok with daap support."
+ elog "You may be interested in installing www-servers/mongrel as well."
+ echo
+ fi
+
+ if ! use embedded; then
+ echo
+ elog "You've disabled the amarok support for embedded mysql DBs."
+ elog "You'll have to configure amarok to use an external db server."
+ echo
+ elog "Please read http://amaroklive.com/wiki/MySQL_Server for details on how"
+ elog "to configure the external db and migrate your data from the embedded database."
+ echo
+
+ if has_version "dev-db/mysql[minimal]"; then
+ elog "You built mysql with the minimal use flag, so it doesn't include the server."
+ elog "You won't be able to use the local mysql installation to store your amarok collection."
+ echo
+ fi
+ fi
+}
diff --git a/media-sound/amarok/files/amarok-2.3.0-crash_fix_info_applet.patch b/media-sound/amarok/files/amarok-2.3.0-crash_fix_info_applet.patch
new file mode 100644
index 000000000000..bd92cd01d1bb
--- /dev/null
+++ b/media-sound/amarok/files/amarok-2.3.0-crash_fix_info_applet.patch
@@ -0,0 +1,61 @@
+diff --git a/src/context/applets/info/InfoApplet.cpp b/src/context/applets/info/InfoApplet.cpp
+index 166da4c..e415e98 100644
+--- a/src/context/applets/info/InfoApplet.cpp
++++ b/src/context/applets/info/InfoApplet.cpp
+@@ -40,18 +40,30 @@ QString InfoApplet::s_defaultHtml = "<html>"
+
+ InfoApplet::InfoApplet( QObject* parent, const QVariantList& args )
+ : Context::Applet( parent, args )
++ , m_webView( 0 )
+ , m_initialized( false )
+ , m_currentPlaylist( 0 )
++
+ {
+ setHasConfigurationInterface( false );
+ setBackgroundHints( Plasma::Applet::NoBackground );
++}
++
++InfoApplet::~InfoApplet()
++{
++ delete m_webView;
++}
++
++
++void InfoApplet::init()
++{
+
+ dataEngine( "amarok-info" )->connectSource( "info", this );
+
+ m_webView = new AmarokWebView( this );
+
+ resize( 500, -1 );
+-
++
+ QPalette p = m_webView->palette();
+ p.setColor( QPalette::Dark, QColor( 255, 255, 255, 0) );
+ p.setColor( QPalette::Window, QColor( 255, 255, 255, 0) );
+@@ -62,11 +74,6 @@ InfoApplet::InfoApplet( QObject* parent, const QVariantList& args )
+ constraintsEvent();
+ }
+
+-InfoApplet::~InfoApplet()
+-{
+- delete m_webView;
+-}
+-
+ void InfoApplet::constraintsEvent( Plasma::Constraints constraints )
+ {
+ Q_UNUSED( constraints )
+diff --git a/src/context/applets/info/InfoApplet.h b/src/context/applets/info/InfoApplet.h
+index 4be28fc..775ea7c 100644
+--- a/src/context/applets/info/InfoApplet.h
++++ b/src/context/applets/info/InfoApplet.h
+@@ -48,6 +48,8 @@ public:
+ InfoApplet( QObject* parent, const QVariantList& args );
+ virtual ~InfoApplet();
+
++ void init();
++
+ void paintInterface( QPainter *painter, const QStyleOptionGraphicsItem *option, const QRect &contentsRect );
+ void constraintsEvent( Plasma::Constraints constraints = Plasma::AllConstraints );
+