summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-26 12:54:33 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-26 12:54:33 +0000
commit886fe0657f7f7f276ef5bec7ab14516bd48eb5a3 (patch)
tree260c089fbffc865629c95cd2cd243933d16cac97 /media-sound
parent*** empty log message *** (diff)
downloadgentoo-2-886fe0657f7f7f276ef5bec7ab14516bd48eb5a3.tar.gz
gentoo-2-886fe0657f7f7f276ef5bec7ab14516bd48eb5a3.tar.bz2
gentoo-2-886fe0657f7f7f276ef5bec7ab14516bd48eb5a3.zip
*** empty log message ***
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/sox/files/digest-sox-12.17.11
-rw-r--r--media-sound/sox/sox-12.17.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-sound/sox/files/digest-sox-12.17.1 b/media-sound/sox/files/digest-sox-12.17.1
new file mode 100644
index 000000000000..4e8cf2cbf15f
--- /dev/null
+++ b/media-sound/sox/files/digest-sox-12.17.1
@@ -0,0 +1 @@
+MD5 9afc59e4c5221462a24fa6092038b6b3 sox-12.17.1.tar.gz
diff --git a/media-sound/sox/sox-12.17.1.ebuild b/media-sound/sox/sox-12.17.1.ebuild
new file mode 100644
index 000000000000..98232ab56f93
--- /dev/null
+++ b/media-sound/sox/sox-12.17.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-12.17.1.ebuild,v 1.1 2000/11/26 12:52:14 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The swiss army knife of sound processing programs"
+SRC_URI="http://download.sourceforge.net/sox/${A}"
+HOMEPAGE="http://home.sprynet.com/~cgabwell/sox.html"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=media-sound/alsa-driver-0.5.9"
+
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr --host=${CHOST} \
+ --enable-fast-ulaw --enable-fast-alaw --with-alsa-dsp
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ into /usr
+ dobin sox
+ doman sox.1
+ dodoc Changelog Copyright README TODO *.txt
+
+}
+
+
+
+