summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-15 22:06:44 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-15 22:06:44 +0000
commitdba08efbb52e9826d7265e4fa1b757cb1ced6b8f (patch)
treeec47bc6b994b770b59c620f4e9fa2a60cf412895 /media-sound
parentStable on alpha wrt bug #117606 (diff)
downloadgentoo-2-dba08efbb52e9826d7265e4fa1b757cb1ced6b8f.tar.gz
gentoo-2-dba08efbb52e9826d7265e4fa1b757cb1ced6b8f.tar.bz2
gentoo-2-dba08efbb52e9826d7265e4fa1b757cb1ced6b8f.zip
Version bump, add support for honouring LINGUAS, avoid building and installing extraneous data.
(Portage version: 2529-svn)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/ChangeLog8
-rw-r--r--media-sound/amarok/Manifest12
-rw-r--r--media-sound/amarok/amarok-1.3.8.ebuild116
-rw-r--r--media-sound/amarok/files/digest-amarok-1.3.81
4 files changed, 126 insertions, 11 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index b8d413b65e34..bc5fa2d80155 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.96 2006/01/11 16:04:34 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.97 2006/01/15 22:06:44 flameeyes Exp $
+
+*amarok-1.3.8 (15 Jan 2006)
+
+ 15 Jan 2006; Diego Pettenò <flameeyes@gentoo.org> +amarok-1.3.8.ebuild:
+ Version bump, add support for honouring LINGUAS, avoid building and
+ installing extraneous data.
11 Jan 2006; Diego Pettenò <flameeyes@gentoo.org> -amarok-1.3.7.ebuild:
Drop old version.
diff --git a/media-sound/amarok/Manifest b/media-sound/amarok/Manifest
index 13e9cc158cf9..dd4b99ed4d8d 100644
--- a/media-sound/amarok/Manifest
+++ b/media-sound/amarok/Manifest
@@ -1,20 +1,12 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 b4f69295517c6ca6951ba988cbadf8bd ChangeLog 15308
MD5 fae91b0167ef3ca3233931dbb86a52e9 amarok-1.2.4.ebuild 2385
MD5 e2b134909d4ab6144cf63677a3675894 amarok-1.3.6.ebuild 3208
MD5 df7e9ec392b1691ca97bd5c2c67f1dc8 amarok-1.3.7-r1.ebuild 3353
+MD5 51d7c5273d16f2906254a15def603e2c amarok-1.3.8.ebuild 3838
MD5 540d52ae55cc72876ea41f14032b6abf files/amarok-1.3.7-lyrc.patch 869
MD5 32030194ea3f2079d1db17aa160f63a2 files/amarok-gcc4.gz 522
MD5 9966964d087dd7c05b7fa2efeff9b1ac files/digest-amarok-1.2.4 66
MD5 d8cfb3a78866379e2ac9b439de887551 files/digest-amarok-1.3.6 66
MD5 cbac7ded5054d6932dda9754aa7d8aa7 files/digest-amarok-1.3.7-r1 66
+MD5 4cdce240143e17652ea80b4b7c58ddaa files/digest-amarok-1.3.8 66
MD5 b23600108f12c98a4fd574d3487ee598 metadata.xml 175
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDxSyeAiZjviIA2XgRAi2kAKC70ccGDvUT2HZT/t8i/GgG+9SMPACfavk9
-qHFxySN6FkY290j2YaaLM2A=
-=dZuI
------END PGP SIGNATURE-----
diff --git a/media-sound/amarok/amarok-1.3.8.ebuild b/media-sound/amarok/amarok-1.3.8.ebuild
new file mode 100644
index 000000000000..818b0d2ad554
--- /dev/null
+++ b/media-sound/amarok/amarok-1.3.8.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.3.8.ebuild,v 1.1 2006/01/15 22:06:44 flameeyes Exp $
+
+inherit kde eutils flag-o-matic
+
+MY_P="${P/_rc/_RC}"
+S="${WORKDIR}/${P/_rc*//}"
+
+DESCRIPTION="amaroK - the audio player for KDE."
+HOMEPAGE="http://amarok.kde.org/"
+SRC_URI="mirror://sourceforge/amarok/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="arts flac gstreamer kde mp3 mysql noamazon opengl postgres xine xmms
+visualization vorbis musicbrainz"
+# kde: enables compilation of the konqueror sidebar plugin
+
+DEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
+ arts? ( kde-base/arts
+ || ( kde-base/kdemultimedia-arts kde-base/kdemultimedia ) )
+ xine? ( >=media-libs/xine-lib-1_rc4 )
+ gstreamer? ( =media-libs/gstreamer-0.8*
+ =media-libs/gst-plugins-0.8* )
+ musicbrainz? ( =media-libs/tunepimp-0.3* )
+ >=media-libs/taglib-1.4
+ mysql? ( >=dev-db/mysql-4.0.16 )
+ postgres? ( dev-db/postgresql )
+ opengl? ( virtual/opengl )
+ xmms? ( >=media-sound/xmms-1.2 )
+ visualization? ( media-libs/libsdl
+ >=media-plugins/libvisual-plugins-0.2 )"
+
+RDEPEND="${DEPEND}
+ gstreamer? ( mp3? ( =media-plugins/gst-plugins-mad-0.8* )
+ vorbis? ( =media-plugins/gst-plugins-ogg-0.8*
+ =media-plugins/gst-plugins-vorbis-0.8* )
+ flac? ( =media-plugins/gst-plugins-flac-0.8* ) )"
+
+DEPEND="${DEPEND}
+ >=dev-util/pkgconfig-0.9.0"
+
+need-kde 3.3
+
+pkg_setup() {
+ if use arts && ! use xine && ! use gstreamer; then
+ ewarn "aRts support is deprecated, if you have problems please consider"
+ ewarn "enabling support for Xine (preferred) or GStreamer"
+ ewarn "(emerge amarok again with USE=\"xine\" or USE=\"gstreamer\")."
+ ebeep 2
+ fi
+
+ if ! use arts && ! use xine && ! use gstreamer; then
+ eerror "amaroK needs either aRts (deprecated), Xine (preferred) or GStreamer to work,"
+ eerror "please try again with USE=\"arts\", USE=\"xine\" or USE=\"gstreamer\"."
+ die
+ fi
+
+ # check whether kdelibs was compiled with arts support
+ kde_pkg_setup
+
+ append-flags -fno-inline
+}
+
+src_unpack() {
+ kde_src_unpack
+
+ LANGS="$(ls ${S}/po | grep -v Makefile)"
+ LANGS_DOC="$(ls ${S}/doc | grep -v Makefile)"
+
+ MAKE_PO=$(echo $(echo "${LINGUAS} ${LANGS}" | fmt -w 1 | sort | uniq -d))
+ MAKE_DOC=$(echo $(echo "${LINGUAS} ${LANGS_DOC}" | fmt -w 1 | sort | uniq -d))
+
+ sed -i -r -e "s:^SUBDIRS =.*:SUBDIRS = ${MAKE_PO}:" ${S}/po/Makefile.am || die "sed for locale failed"
+ sed -i -r -e "s:^SUBDIRS =.*:SUBDIRS = \. ${MAKE_DOC} amarok:" ${S}/doc/Makefile.am || die "sed for locale failed"
+
+ rm -f ${S}/configure
+}
+
+src_compile() {
+ # amarok does not respect kde coding standards, and makes a lot of
+ # assuptions regarding its installation directory. For this reason,
+ # it must be installed in the KDE install directory.
+ PREFIX="${KDEDIR}"
+
+ # Extra, unsupported engines are forcefully disabled.
+ local myconf="$(use_with arts) $(use_with xine) $(use_with gstreamer)
+ $(use_enable mysql) $(use_enable postgres postgresql)
+ $(use_with opengl) $(use_with xmms)
+ $(use_with visualization libvisual)
+ $(use_enable !noamazon amazon)
+ $(use_with musicbrainz)
+ --without-helix
+ --without-mas
+ --without-nmm"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ # Workaround to use amaroK from outside KDE
+
+ # move the desktop file in /usr/share
+ dodir /usr/share/applications/kde
+ mv ${D}${KDEDIR}/share/applications/kde/amarok.desktop \
+ ${D}/usr/share/applications/kde/amarok.desktop || die
+ # move icons, too
+ dodir /usr/share/icons
+ mv ${D}${KDEDIR}/share/icons/hicolor \
+ ${D}/usr/share/icons || die
+}
+
diff --git a/media-sound/amarok/files/digest-amarok-1.3.8 b/media-sound/amarok/files/digest-amarok-1.3.8
new file mode 100644
index 000000000000..5e2eb832b205
--- /dev/null
+++ b/media-sound/amarok/files/digest-amarok-1.3.8
@@ -0,0 +1 @@
+MD5 fd1ee0509568e5f9f7d0aeb9af094786 amarok-1.3.8.tar.bz2 8728423