summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-04-25 20:04:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-04-25 20:04:35 +0000
commitf6b2cba682b5b643b2ce47d835a1f1fa8b2f385c (patch)
tree3772af1d437a0179f7aae397c4abb726ef8a2fd8 /media-sound
parentgimp for gimp-print (diff)
downloadgentoo-2-f6b2cba682b5b643b2ce47d835a1f1fa8b2f385c.tar.gz
gentoo-2-f6b2cba682b5b643b2ce47d835a1f1fa8b2f385c.tar.bz2
gentoo-2-f6b2cba682b5b643b2ce47d835a1f1fa8b2f385c.zip
Fix wxwidgets handling by using the eclass, thanks to Ryan Hill <dirtyepic@gentoo.org>, bug #175650
(Portage version: 2.1.2.4)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacity/ChangeLog7
-rw-r--r--media-sound/audacity/audacity-1.3.2-r1.ebuild11
2 files changed, 15 insertions, 3 deletions
diff --git a/media-sound/audacity/ChangeLog b/media-sound/audacity/ChangeLog
index 3b53505472b0..f5dd12059a7a 100644
--- a/media-sound/audacity/ChangeLog
+++ b/media-sound/audacity/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/audacity
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.56 2007/03/10 01:14:27 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.57 2007/04/25 20:04:35 aballier Exp $
+
+ 25 Apr 2007; Alexis Ballier <aballier@gentoo.org>
+ audacity-1.3.2-r1.ebuild:
+ Fix wxwidgets handling by using the eclass, thanks to Ryan Hill
+ <dirtyepic@gentoo.org>, bug #175650
10 Mar 2007; Alexis Ballier <aballier@gentoo.org>
+files/audacity-1.3.2-desktopentry.patch, audacity-1.3.2-r1.ebuild:
diff --git a/media-sound/audacity/audacity-1.3.2-r1.ebuild b/media-sound/audacity/audacity-1.3.2-r1.ebuild
index e334c9e60457..c55318c365d2 100644
--- a/media-sound/audacity/audacity-1.3.2-r1.ebuild
+++ b/media-sound/audacity/audacity-1.3.2-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.2-r1.ebuild,v 1.5 2007/03/10 01:14:27 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.2-r1.ebuild,v 1.6 2007/04/25 20:04:35 aballier Exp $
-inherit eutils autotools
+inherit eutils autotools wxwidgets
IUSE="flac ladspa libsamplerate mp3 sse unicode vorbis"
@@ -51,6 +51,13 @@ src_unpack() {
src_compile() {
local myconf
+ WX_GTK_VER="2.6"
+
+ if use unicode; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets gtk2
+ fi
myconf="${myconf} --with-libsndfile=system"
myconf="${myconf} --with-libexpat=system"