summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-05 11:59:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-05 11:59:36 +0000
commitf7d93f14dd0fe179c199f5ffad3bef76692853dd (patch)
tree03953d6edb295bb2004482c09c5539ca8736d6ad /media-sound
parentstable x86, bug 343883 (diff)
downloadgentoo-2-f7d93f14dd0fe179c199f5ffad3bef76692853dd.tar.gz
gentoo-2-f7d93f14dd0fe179c199f5ffad3bef76692853dd.tar.bz2
gentoo-2-f7d93f14dd0fe179c199f5ffad3bef76692853dd.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/gejengel/ChangeLog8
-rw-r--r--media-sound/gejengel/files/gejengel-0.1.4-libnotify-0.7.patch26
-rw-r--r--media-sound/gejengel/gejengel-0.1.4.ebuild12
3 files changed, 40 insertions, 6 deletions
diff --git a/media-sound/gejengel/ChangeLog b/media-sound/gejengel/ChangeLog
index b4c82bddaca2..785d49252953 100644
--- a/media-sound/gejengel/ChangeLog
+++ b/media-sound/gejengel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/gejengel
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gejengel/ChangeLog,v 1.16 2010/10/03 20:11:48 hwoarang Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gejengel/ChangeLog,v 1.17 2011/02/05 11:59:36 ssuominen Exp $
+
+ 05 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> gejengel-0.1.4.ebuild,
+ +files/gejengel-0.1.4-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
03 Oct 2010; Markos Chandras <hwoarang@gentoo.org>
-files/gejengel-0.1.2-plugin.patch, -files/gejengel-0.1.2_64bit_fix.patch,
diff --git a/media-sound/gejengel/files/gejengel-0.1.4-libnotify-0.7.patch b/media-sound/gejengel/files/gejengel-0.1.4-libnotify-0.7.patch
new file mode 100644
index 000000000000..8026d89725c5
--- /dev/null
+++ b/media-sound/gejengel/files/gejengel-0.1.4-libnotify-0.7.patch
@@ -0,0 +1,26 @@
+--- src/Plugins/notificationplugin.cpp
++++ src/Plugins/notificationplugin.cpp
+@@ -33,6 +33,10 @@
+ #include "ui/sharedfunctions.h"
+ #include "MusicLibrary/album.h"
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ using namespace std;
+ using namespace Gtk;
+
+@@ -85,7 +89,12 @@
+ }
+ }
+
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ m_pNotification = notify_notification_new("dummy", "", NULL);
++#else
+ m_pNotification = notify_notification_new("dummy", "", NULL, NULL);
++#endif
++
+ notify_notification_set_timeout (m_pNotification, NOTIFY_EXPIRES_DEFAULT);
+ notify_notification_set_urgency (m_pNotification, NOTIFY_URGENCY_NORMAL);
+
diff --git a/media-sound/gejengel/gejengel-0.1.4.ebuild b/media-sound/gejengel/gejengel-0.1.4.ebuild
index ff5ceadfdc93..f101ee2753d4 100644
--- a/media-sound/gejengel/gejengel-0.1.4.ebuild
+++ b/media-sound/gejengel/gejengel-0.1.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/gejengel/gejengel-0.1.4.ebuild,v 1.3 2010/08/31 12:56:14 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gejengel/gejengel-0.1.4.ebuild,v 1.4 2011/02/05 11:59:36 ssuominen Exp $
-EAPI=2
-inherit base eutils multilib
+EAPI=3
+inherit eutils multilib
DESCRIPTION="Lightweight audio player"
HOMEPAGE="http://code.google.com/p/gejengel"
@@ -34,6 +34,10 @@ DEPEND="${RDEPEND}
dev-libs/libxdg-basedir
>=sys-devel/automake-1.11"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+}
+
src_configure() {
econf \
--disable-dependency-tracking \