summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-04-11 23:39:08 +0000
committerBen de Groot <yngwin@gentoo.org>2008-04-11 23:39:08 +0000
commitf9441c625ab8fdf21d28476dc6460f42eb8f14b4 (patch)
tree7502bcbf085adc0c58614503b9d33d36090007ec /media-sound
parentdev-cpp/libgnomemm: Bump to 2.22.0 (upstream version bump, nothing new) (diff)
downloadgentoo-2-f9441c625ab8fdf21d28476dc6460f42eb8f14b4.tar.gz
gentoo-2-f9441c625ab8fdf21d28476dc6460f42eb8f14b4.tar.bz2
gentoo-2-f9441c625ab8fdf21d28476dc6460f42eb8f14b4.zip
Initial commit. Fixes bug 131294.
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lastfmproxy/ChangeLog10
-rw-r--r--media-sound/lastfmproxy/Manifest5
-rwxr-xr-xmedia-sound/lastfmproxy/files/lastfmproxy.rc22
-rw-r--r--media-sound/lastfmproxy/lastfmproxy-1.3b.ebuild42
-rw-r--r--media-sound/lastfmproxy/metadata.xml9
5 files changed, 88 insertions, 0 deletions
diff --git a/media-sound/lastfmproxy/ChangeLog b/media-sound/lastfmproxy/ChangeLog
new file mode 100644
index 000000000000..f357d886e8c3
--- /dev/null
+++ b/media-sound/lastfmproxy/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/lastfmproxy
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmproxy/ChangeLog,v 1.1 2008/04/11 23:39:07 yngwin Exp $
+
+*lastfmproxy-1.3b (11 Apr 2008)
+
+ 11 Apr 2008; Ben de Groot <yngwin@gentoo.org> +files/lastfmproxy.rc,
+ +metadata.xml, +lastfmproxy-1.3b.ebuild:
+ Initial commit. Ebuild adapted from Daniel Pielmeier and bug 131294.
+
diff --git a/media-sound/lastfmproxy/Manifest b/media-sound/lastfmproxy/Manifest
new file mode 100644
index 000000000000..e65b8cf61846
--- /dev/null
+++ b/media-sound/lastfmproxy/Manifest
@@ -0,0 +1,5 @@
+AUX lastfmproxy.rc 491 RMD160 0256968525a646ce99273f52a11d120ae80cd46a SHA1 2f5298cdd7f7507c7e2ce8a4a50876010041a56f SHA256 c48564ec68765c12b6284e686582307e79a330617c4c34ec96ea302375606b3a
+DIST lastfmproxy-1.3b.tar.gz 32079 RMD160 d4e4c53a34699eee9ee65402e25fb82a81272505 SHA1 ee6a4ef118d76efefa1dff36c85e48c925ebc4c0 SHA256 b66be0fcc76e557d1306660162db946f97262335f3528cf5d303b3ab3410a881
+EBUILD lastfmproxy-1.3b.ebuild 1229 RMD160 f4b8dc4709fb3988f258b5a3ea395ca5be62ca9a SHA1 db719553447797f61b5302e5c2ef8e8dcdd94416 SHA256 fde684a48e75972524465f57ef8e103165abf824693c82de2c181d72ff4d4dab
+MISC ChangeLog 343 RMD160 f2267b8ca1b4991b1b05992758ab55075584e799 SHA1 a71597c60edc176d87e04201da14384c46b52e80 SHA256 d15e79a903d6343e1159f53272ff60742bd2ac7cfe88cc4cdbd3903c6214c8c4
+MISC metadata.xml 258 RMD160 c4368de7af5d7e3eab50ac09bb3c0ff1f89b48a5 SHA1 d325a145243dc9f942c9a6eda3b5904530c1b668 SHA256 4fc3e9816ac88894a53efd0217b7b7526a12c717bf1d0a2eda601031566b155b
diff --git a/media-sound/lastfmproxy/files/lastfmproxy.rc b/media-sound/lastfmproxy/files/lastfmproxy.rc
new file mode 100755
index 000000000000..ea19e2e2759b
--- /dev/null
+++ b/media-sound/lastfmproxy/files/lastfmproxy.rc
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+}
+
+start () {
+ ebegin "Starting Last.fm Proxy"
+ start-stop-daemon --start -p /var/run/lastfmproxy.pid -b -m \
+ --exec /usr/share/lastfmproxy/main.py
+ einfo "Stream: http://localhost:1881/lastfm.m3u"
+ einfo "Web frontend: http://localhost:1881/"
+ eend $?
+}
+
+stop () {
+ ebegin "Stopping Last.fm Proxy"
+ start-stop-daemon --stop --quiet -p /var/run/lastfmproxy.pid -m \
+ --exec /usr/share/lastfmproxy/main.py
+ rm -f /var/run/lastfmproxy.pid
+ eend $?
+}
diff --git a/media-sound/lastfmproxy/lastfmproxy-1.3b.ebuild b/media-sound/lastfmproxy/lastfmproxy-1.3b.ebuild
new file mode 100644
index 000000000000..844f6a0cc85c
--- /dev/null
+++ b/media-sound/lastfmproxy/lastfmproxy-1.3b.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmproxy/lastfmproxy-1.3b.ebuild,v 1.1 2008/04/11 23:39:07 yngwin Exp $
+
+DESCRIPTION="A proxy server for listening to last.fm streams with any stream-capable audio player"
+HOMEPAGE="http://vidar.gimp.org/lastfmproxy/"
+SRC_URI="http://vidar.gimp.org/wp-content/uploads/2007/12/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ BASE=/usr/share/lastfmproxy
+ cd "${S}"
+ dodoc README.txt ChangeLog.txt
+
+ insinto ${BASE}
+ doins -r *.py data
+ fperms 755 ${BASE}/changestation.py ${BASE}/main.py
+
+ newinitd "${FILESDIR}"/lastfmproxy.rc lastfmproxy
+}
+
+pkg_postinst() {
+ echo
+ einfo "Please modify:"
+ einfo " /usr/share/lastfmproxy/config.py"
+ einfo "with last.fm credentials and/or proxy information."
+ einfo ""
+ einfo "Then, to start lastfmproxy:"
+ einfo " /etc/init.d/lastfmproxy start"
+ einfo ""
+ einfo "Here's how to make the lastfm://station links work:"
+ einfo ' In Firefox, open the location "about:config"'
+ einfo ' Right-click, select "New String"'
+ einfo ' As name, enter "network.protocol-handler.app.lastfm"'
+ einfo ' As value, enter "/usr/share/lastfmproxy/changestation.py"'
+ echo
+}
diff --git a/media-sound/lastfmproxy/metadata.xml b/media-sound/lastfmproxy/metadata.xml
new file mode 100644
index 000000000000..6e9c501620f5
--- /dev/null
+++ b/media-sound/lastfmproxy/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ <name>Ben de Groot</name>
+ </maintainer>
+</pkgmetadata>