summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2011-06-02 11:41:44 +0000
committerAlex Legler <a3li@gentoo.org>2011-06-02 11:41:44 +0000
commit65659d3b49b9a0b33913f1f857a4b46ba6132377 (patch)
tree255da8f35b810aa6d1ebe148c158fee6366e54d6 /media-tv/tvtime
parentRespect C(XX)FLAGS (bug #217964), respect LDFLAGS (bug #369793), and add depe... (diff)
downloadgentoo-2-65659d3b49b9a0b33913f1f857a4b46ba6132377.tar.gz
gentoo-2-65659d3b49b9a0b33913f1f857a4b46ba6132377.tar.bz2
gentoo-2-65659d3b49b9a0b33913f1f857a4b46ba6132377.zip
Fix building against libpng-1.5. Closes bug 369663 by Christoph Mende.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'media-tv/tvtime')
-rw-r--r--media-tv/tvtime/ChangeLog6
-rw-r--r--media-tv/tvtime/files/tvtime-libpng-1.5.patch14
-rw-r--r--media-tv/tvtime/tvtime-1.0.2_p20110131.ebuild3
3 files changed, 21 insertions, 2 deletions
diff --git a/media-tv/tvtime/ChangeLog b/media-tv/tvtime/ChangeLog
index 2b8ec10e4242..984017613115 100644
--- a/media-tv/tvtime/ChangeLog
+++ b/media-tv/tvtime/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/tvtime
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/ChangeLog,v 1.49 2011/05/29 22:08:33 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/ChangeLog,v 1.50 2011/06/02 11:41:44 a3li Exp $
+
+ 02 Jun 2011; Alex Legler <a3li@gentoo.org> tvtime-1.0.2_p20110131.ebuild,
+ +files/tvtime-libpng-1.5.patch:
+ Fix building against libpng-1.5. Closes bug 369663 by Christoph Mende.
*tvtime-1.0.2_p20110131 (29 May 2011)
diff --git a/media-tv/tvtime/files/tvtime-libpng-1.5.patch b/media-tv/tvtime/files/tvtime-libpng-1.5.patch
new file mode 100644
index 000000000000..bfa22ed98d02
--- /dev/null
+++ b/media-tv/tvtime/files/tvtime-libpng-1.5.patch
@@ -0,0 +1,14 @@
+Include zlib.h which is no longer implicitly included with libpng-1.5
+Bug 369663
+
+diff -ru tvtime-111b28cca42d.orig/src/pngoutput.c tvtime-111b28cca42d/src/pngoutput.c
+--- tvtime-111b28cca42d.orig/src/pngoutput.c 2011-02-01 02:35:26.000000000 +0100
++++ tvtime-111b28cca42d/src/pngoutput.c 2011-06-02 13:36:55.965999463 +0200
+@@ -18,6 +18,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <zlib.h>
+ #include <png.h>
+ #include "pngoutput.h"
+
diff --git a/media-tv/tvtime/tvtime-1.0.2_p20110131.ebuild b/media-tv/tvtime/tvtime-1.0.2_p20110131.ebuild
index 1f511798240e..5f52eb33d719 100644
--- a/media-tv/tvtime/tvtime-1.0.2_p20110131.ebuild
+++ b/media-tv/tvtime/tvtime-1.0.2_p20110131.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/tvtime-1.0.2_p20110131.ebuild,v 1.1 2011/05/29 22:08:33 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/tvtime-1.0.2_p20110131.ebuild,v 1.2 2011/06/02 11:41:44 a3li Exp $
EAPI=4
inherit eutils autotools
@@ -54,6 +54,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-autotools.patch"
epatch "${FILESDIR}/${P}-gettext.patch"
+ epatch "${FILESDIR}/${PN}-libpng-1.5.patch"
AT_M4DIR="m4" eautoreconf
}