summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-01 05:10:42 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-01 05:10:42 +0000
commitac04cb1d6cc09b60bdd4bb556ad614ed8149b69d (patch)
treeac0145b5e9a7be8c798ff02a141e8fe214c2ee7a /media-tv/tvtime
parentMake it a use, not need, dependency as you might not have tpm hardware. (diff)
downloadgentoo-2-ac04cb1d6cc09b60bdd4bb556ad614ed8149b69d.tar.gz
gentoo-2-ac04cb1d6cc09b60bdd4bb556ad614ed8149b69d.tar.bz2
gentoo-2-ac04cb1d6cc09b60bdd4bb556ad614ed8149b69d.zip
Fix (twice) the build problems with libtool 2.4 and automake 1.7: don't require libtool at all (since there are no libraries built), but also allow building with automake 1.11; both fixes are actually needed, since disabling libtool causes a couple of side problems.
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'media-tv/tvtime')
-rw-r--r--media-tv/tvtime/ChangeLog9
-rw-r--r--media-tv/tvtime/files/tvtime-1.0.2-autotools.patch73
-rw-r--r--media-tv/tvtime/tvtime-1.0.2-r2.ebuild10
3 files changed, 86 insertions, 6 deletions
diff --git a/media-tv/tvtime/ChangeLog b/media-tv/tvtime/ChangeLog
index 22fd67b9cd5a..885c812a334d 100644
--- a/media-tv/tvtime/ChangeLog
+++ b/media-tv/tvtime/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-tv/tvtime
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/ChangeLog,v 1.47 2010/05/03 23:26:07 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/ChangeLog,v 1.48 2010/12/01 05:10:42 flameeyes Exp $
+
+ 01 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org> tvtime-1.0.2-r2.ebuild,
+ +files/tvtime-1.0.2-autotools.patch:
+ Fix (twice) the build problems with libtool 2.4 and automake 1.7: don't
+ require libtool at all (since there are no libraries built), but also allow
+ building with automake 1.11; both fixes are actually needed, since disabling
+ libtool causes a couple of side problems.
03 May 2010; Samuli Suominen <ssuominen@gentoo.org>
tvtime-1.0.2-r2.ebuild:
diff --git a/media-tv/tvtime/files/tvtime-1.0.2-autotools.patch b/media-tv/tvtime/files/tvtime-1.0.2-autotools.patch
new file mode 100644
index 000000000000..bf02ebefa529
--- /dev/null
+++ b/media-tv/tvtime/files/tvtime-1.0.2-autotools.patch
@@ -0,0 +1,73 @@
+Index: tvtime-1.0.2/src/Makefile.am
+===================================================================
+--- tvtime-1.0.2.orig/src/Makefile.am
++++ tvtime-1.0.2/src/Makefile.am
+@@ -19,9 +19,6 @@ pkgsysconfdir = $(sysconfdir)/@PACKAGE@
+ tmpdir = /tmp
+ localedir = $(datadir)/locale
+
+-TTF_CFLAGS = `$(FREETYPE_CONFIG) --cflags`
+-TTF_LIBS = `$(FREETYPE_CONFIG) --libs`
+-
+ # Set the following if you want to specify an additional font directory
+ # FONT_CFLAGS = -DFONTDIR='/usr/share/fonts/truetype/freefont/'
+
+@@ -76,20 +73,20 @@ tvtime_SOURCES = $(COMMON_SRCS) $(OUTPUT
+ tvtime_CFLAGS = $(TTF_CFLAGS) $(PNG_CFLAGS) $(OPT_CFLAGS) \
+ $(PLUGIN_CFLAGS) $(X11_CFLAGS) $(XML2_FLAG) \
+ $(FONT_CFLAGS) $(AM_CFLAGS)
+-tvtime_LDFLAGS = $(TTF_LIBS) $(ZLIB_LIBS) $(PNG_LIBS) \
++tvtime_LDADD = $(TTF_LIBS) $(ZLIB_LIBS) $(PNG_LIBS) \
+ $(X11_LIBS) $(XML2_LIBS) -lm -lsupc++
+
+ tvtime_command_SOURCES = utils.h utils.c tvtimeconf.h tvtimeconf.c \
+ tvtime-command.c
+ tvtime_command_CFLAGS = $(OPT_CFLAGS) $(XML2_FLAG) $(AM_CFLAGS)
+-tvtime_command_LDFLAGS = $(ZLIB_LIBS) $(XML2_LIBS)
++tvtime_command_LDADD = $(ZLIB_LIBS) $(XML2_LIBS)
+ tvtime_configure_SOURCES = utils.h utils.c tvtimeconf.h tvtimeconf.c \
+ tvtime-configure.c
+ tvtime_configure_CFLAGS = $(OPT_CFLAGS) $(XML2_FLAG) $(AM_CFLAGS)
+-tvtime_configure_LDFLAGS = $(ZLIB_LIBS) $(XML2_LIBS)
++tvtime_configure_LDADD = $(ZLIB_LIBS) $(XML2_LIBS)
+ tvtime_scanner_SOURCES = utils.h utils.c videoinput.h videoinput.c \
+ tvtimeconf.h tvtimeconf.c station.h station.c tvtime-scanner.c \
+ mixer.h mixer.c
+ tvtime_scanner_CFLAGS = $(OPT_CFLAGS) $(XML2_FLAG) $(AM_CFLAGS)
+-tvtime_scanner_LDFLAGS = $(ZLIB_LIBS) $(XML2_LIBS)
++tvtime_scanner_LDADD = $(ZLIB_LIBS) $(XML2_LIBS)
+
+Index: tvtime-1.0.2/configure.ac
+===================================================================
+--- tvtime-1.0.2.orig/configure.ac
++++ tvtime-1.0.2/configure.ac
+@@ -10,6 +10,7 @@ if test x"$host_alias" = x""; then host_
+
+ # Check for compilers.
+ AC_PROG_CC
++AM_PROG_CC_C_O
+ AC_CHECK_PROG(found_cc, "$CC", yes, no)
+ test "x$found_cc" = "xyes" || exit 1
+
+@@ -17,9 +18,6 @@ AC_PROG_CXX
+ AC_CHECK_PROG(found_cxx, "$CXX", yes, no)
+ test "x$found_cxx" = "xyes" || exit 1
+
+-# Check for libtool.
+-AC_PROG_LIBTOOL
+-
+ # Checks for header files.
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS([ctype.h dirent.h errno.h fcntl.h getopt.h langinfo.h math.h netinet/in.h pwd.h signal.h stdint.h stdio.h stdlib.h string.h sys/ioctl.h sys/mman.h sys/resource.h sys/stat.h sys/time.h sys/wait.h sys/types.h unistd.h wordexp.h locale.h])
+@@ -65,10 +63,7 @@ dnl ------------------------------------
+ dnl freetype
+ dnl ---------------------------------------------
+ dnl Test for freetype
+-AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no)
+-if test "$FREETYPE_CONFIG" = "no" ; then
+- AC_MSG_ERROR(freetype2 needed and freetype-config not found)
+-fi
++PKG_CHECK_MODULES([TTF], [freetype2])
+
+ dnl ---------------------------------------------
+ dnl libxml2
diff --git a/media-tv/tvtime/tvtime-1.0.2-r2.ebuild b/media-tv/tvtime/tvtime-1.0.2-r2.ebuild
index f2bbe1e56070..606d3e903da7 100644
--- a/media-tv/tvtime/tvtime-1.0.2-r2.ebuild
+++ b/media-tv/tvtime/tvtime-1.0.2-r2.ebuild
@@ -1,9 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/tvtime-1.0.2-r2.ebuild,v 1.6 2010/05/03 23:26:07 ssuominen Exp $
-
-WANT_AUTOMAKE=1.7
-WANT_AUTOCONF=2.5
+# $Header: /var/cvsroot/gentoo-x86/media-tv/tvtime/tvtime-1.0.2-r2.ebuild,v 1.7 2010/12/01 05:10:42 flameeyes Exp $
inherit eutils autotools
@@ -33,7 +30,8 @@ RDEPEND="x11-libs/libSM
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
src_unpack() {
unpack ${A}
@@ -56,6 +54,8 @@ src_unpack() {
epatch "${FILESDIR}/${P}-libsupc++.patch"
+ epatch "${FILESDIR}/${P}-autotools.patch"
+
AT_M4DIR="m4" eautoreconf
}