summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2009-05-28 04:36:33 +0000
committerSteve Dibb <beandog@gentoo.org>2009-05-28 04:36:33 +0000
commit2eaea65c4beb79103a7e4c34d1f713ffc39349ef (patch)
tree24b05a9a15708744082f70830ca4b07f95acdb60 /media-tv/v4l-dvb-hg
parentVersion bump, minor caching improvments, ps3 tweaks, improved libnotify messa... (diff)
downloadgentoo-2-2eaea65c4beb79103a7e4c34d1f713ffc39349ef.tar.gz
gentoo-2-2eaea65c4beb79103a7e4c34d1f713ffc39349ef.tar.bz2
gentoo-2-2eaea65c4beb79103a7e4c34d1f713ffc39349ef.zip
Use ebuild from John Drescher's ebuild, bug 269249
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-tv/v4l-dvb-hg')
-rw-r--r--media-tv/v4l-dvb-hg/ChangeLog9
-rw-r--r--media-tv/v4l-dvb-hg/v4l-dvb-hg-0.1-r3.ebuild132
2 files changed, 139 insertions, 2 deletions
diff --git a/media-tv/v4l-dvb-hg/ChangeLog b/media-tv/v4l-dvb-hg/ChangeLog
index cbd8c50859ec..138cc2e8d674 100644
--- a/media-tv/v4l-dvb-hg/ChangeLog
+++ b/media-tv/v4l-dvb-hg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/v4l-dvb-hg
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/v4l-dvb-hg/ChangeLog,v 1.19 2008/05/21 13:30:44 zzam Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/v4l-dvb-hg/ChangeLog,v 1.20 2009/05/28 04:36:33 beandog Exp $
+
+*v4l-dvb-hg-0.1-r3 (28 May 2009)
+
+ 28 May 2009; Steve Dibb <beandog@gentoo.org> +v4l-dvb-hg-0.1-r3.ebuild:
+ Use ebuild from John Drescher's ebuild, bug 269249
21 May 2008; Matthias Schwarzott <zzam@gentoo.org>
v4l-dvb-hg-0.1-r2.ebuild:
diff --git a/media-tv/v4l-dvb-hg/v4l-dvb-hg-0.1-r3.ebuild b/media-tv/v4l-dvb-hg/v4l-dvb-hg-0.1-r3.ebuild
new file mode 100644
index 000000000000..b291c5616b4f
--- /dev/null
+++ b/media-tv/v4l-dvb-hg/v4l-dvb-hg-0.1-r3.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/v4l-dvb-hg/v4l-dvb-hg-0.1-r3.ebuild,v 1.1 2009/05/28 04:36:33 beandog Exp $
+
+: ${EHG_REPO_URI:=${V4L_DVB_HG_REPO_URI:-http://linuxtv.org/hg/v4l-dvb}}
+
+EAPI="2"
+
+inherit linux-mod eutils toolchain-funcs mercurial savedconfig
+
+DESCRIPTION="Live development version of V4L and DVB driver for kernel 2.6"
+SRC_URI=""
+HOMEPAGE="http://www.linuxtv.org"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+S="${WORKDIR}/${EHG_REPO_URI##*/}/v4l"
+
+pkg_setup()
+{
+ linux-mod_pkg_setup
+ if [[ "${KV_MAJOR}.${KV_MINOR}" != "2.6" ]]; then
+ ewarn "other Kernel than 2.6.x are not supported at the moment."
+ die "unsupported Kernel (not 2.6.x)"
+ fi
+ MODULE_NAMES="dvb(dvb:${S})"
+ BUILD_PARAMS="KDIR=${KERNEL_DIR}"
+ BUILD_TARGETS="default"
+
+ if [[ -d ${ROOT}/lib/modules/${KV_FULL}/v4l-dvb-cvs ]]; then
+ ewarn "There are stale dvb-modules from the ebuild v4l-dvb-cvs."
+ ewarn "Please remove the directory /lib/modules/${KV_FULL}/v4l-dvb-cvs"
+ ewarn "with all its files and subdirectories and then restart emerge."
+ ewarn
+ ewarn "# rm -rf /lib/modules/${KV_FULL}/v4l-dvb-cvs"
+ die "Stale dvb-modules found, restart merge after removing them."
+ fi
+}
+
+src_prepare() {
+
+ einfo "Removing modules-install"
+ sed -i ${S}/Makefile \
+ -e "s/install:: media-install firmware_install/install:: media-install/"
+
+ # apply local patches
+ if test -n "${DVB_LOCAL_PATCHES}";
+ then
+ ewarn "Applying local patches:"
+ for LOCALPATCH in ${DVB_LOCAL_PATCHES};
+ do
+ if test -f "${LOCALPATCH}";
+ then
+ if grep -q linux/drivers "${LOCALPATCH}"; then
+ cd "${S}"/..
+ else
+ cd "${S}"
+ fi
+ epatch "${LOCALPATCH}"
+ fi
+ done
+ else
+ einfo "No additional local patches to use"
+ fi
+
+ export ARCH=$(tc-arch-kernel)
+ make allmodconfig ${BUILD_PARAMS}
+ export ARCH=$(tc-arch)
+
+ echo
+
+ elog "Removing autoload-entry from stradis-driver."
+ sed -i "${S}"/../linux/drivers/media/video/stradis.c -e '/MODULE_DEVICE_TABLE/d'
+
+ cd "${S}"
+ sed -e '/-install::/s:rminstall::' \
+ -i Makefile
+
+ elog "Removing depmod-calls"
+ sed -e '/depmod/d' -i Makefile* scripts/make_makefile.pl scripts/make_kconfig.pl \
+ || die "Failed removing depmod call from Makefile"
+
+ grep depmod * && die "Not removed depmod found."
+
+ mkdir "${WORKDIR}"/header
+ cd "${WORKDIR}"/header
+ cp "${S}"/../linux/include/linux/dvb/* .
+ sed -e '/compiler/d' \
+ -e 's/__user//' \
+ -i *.h
+
+ cd "${S}"
+ restore_config .config
+}
+
+src_install() {
+ # install the modules
+ local DEST="${D}/lib/modules/${KV_FULL}/v4l-dvb"
+ make install \
+ DEST="${DEST}" \
+ KDIR26="${DEST}" \
+ KDIRA="${DEST}" \
+ || die "make install failed"
+
+ cd "${S}"/..
+ dodoc linux/Documentation/dvb/*.txt
+ dosbin linux/Documentation/dvb/get_dvb_firmware
+
+ insinto /usr/include/v4l-dvb-hg/linux/dvb
+ cd "${WORKDIR}/header"
+ doins *.h
+
+ cd "${S}"
+ save_config .config
+}
+
+pkg_postinst() {
+ echo
+ elog "Firmware-files can be found in media-tv/linuxtv-dvb-firmware"
+ echo
+
+ linux-mod_pkg_postinst
+ echo
+ echo
+ elog "if you want to use the IR-port or networking"
+ elog "with the dvb-card you need to"
+ elog "install linuxtv-dvb-apps"
+ echo
+}