summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-03-06 08:02:12 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-03-06 08:02:12 +0000
commit304fccad8221339c0cc98fb9588713d008719995 (patch)
treef2b1fff4dfcf4b6a21c02dc8ffa8594c619565a5 /media-tv
parentStable on alpha, bug 83797. (diff)
downloadgentoo-2-304fccad8221339c0cc98fb9588713d008719995.tar.gz
gentoo-2-304fccad8221339c0cc98fb9588713d008719995.tar.bz2
gentoo-2-304fccad8221339c0cc98fb9588713d008719995.zip
fixed http://bugs.gentoo.org/show_bug.cgi?id=84249
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/ivtv/ChangeLog7
-rw-r--r--media-tv/ivtv/files/digest-ivtv-0.2.0_rc3-r32
-rw-r--r--media-tv/ivtv/ivtv-0.2.0_rc3-r3.ebuild106
3 files changed, 114 insertions, 1 deletions
diff --git a/media-tv/ivtv/ChangeLog b/media-tv/ivtv/ChangeLog
index c117450bbe8e..870634a06c02 100644
--- a/media-tv/ivtv/ChangeLog
+++ b/media-tv/ivtv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-tv/ivtv
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.22 2005/03/04 03:19:42 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.23 2005/03/06 08:02:12 cardoe Exp $
+
+*ivtv-0.2.0_rc3-r3 (06 Mar 2005)
+
+ 06 Mar 2005; Doug Goldstein <cardoe@gentoo.org> +ivtv-0.2.0_rc3-r3.ebuild:
+ fix bug #84249
03 Mar 2005; Doug Goldstein <cardoe@gentoo.org> ivtv-0.2.0_rc3-r2.ebuild:
BUILD_PARAMS="KDIR=${KERNEL_DIR}"
diff --git a/media-tv/ivtv/files/digest-ivtv-0.2.0_rc3-r3 b/media-tv/ivtv/files/digest-ivtv-0.2.0_rc3-r3
new file mode 100644
index 000000000000..7cb41b4a9e9f
--- /dev/null
+++ b/media-tv/ivtv/files/digest-ivtv-0.2.0_rc3-r3
@@ -0,0 +1,2 @@
+MD5 f12ea8ca1cb3680df4bcf9d5115905d5 ivtv-0.2.0-rc3g.tgz 517723
+MD5 173c5ce2c0f16da42a5316ef7cee6834 pvr_1.18.21.22168_inf.zip 676578
diff --git a/media-tv/ivtv/ivtv-0.2.0_rc3-r3.ebuild b/media-tv/ivtv/ivtv-0.2.0_rc3-r3.ebuild
new file mode 100644
index 000000000000..019d4b39b10a
--- /dev/null
+++ b/media-tv/ivtv/ivtv-0.2.0_rc3-r3.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.2.0_rc3-r3.ebuild,v 1.1 2005/03/06 08:02:12 cardoe Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="ivtv driver for Hauppauge PVR[23]50 cards"
+HOMEPAGE="http://205.209.168.201/~ckennedy/ivtv/"
+
+MY_P="${P/_/-}g"
+FW_VER="pvr_1.18.21.22168_inf.zip"
+
+SRC_URI="http://205.209.168.201/~ckennedy/ivtv/${MY_P}.tgz
+ http://205.209.168.201/~ckennedy/ivtv/ivtv-0.2.0-rc/${MY_P}.tgz
+ ftp://ftp.shspvr.com/download/wintv-pvr_250-350/inf/${FW_VER}"
+
+RESTRICT="nomirror"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+IUSE=""
+S="${WORKDIR}/${MY_P}"
+
+MODULE_NAMES="ivtv(extra:${S}/driver)
+ msp3400(extra:${S}/driver)
+ saa7115(extra:${S}/driver)
+ tveeprom(extra:${S}/driver)
+ saa7127(extra:${S}/driver)"
+BUILD_TARGETS="all"
+BUILD_PARAMS="KDIR=${KERNEL_DIR}"
+CONFIG_CHECK="I2C_ALGOBIT VIDEO_DEV"
+
+DEPEND="app-arch/unzip"
+
+src_unpack() {
+ unpack ${MY_P}.tgz
+
+ if grep '^CONFIG_FB=' ${ROOT}${KV_DIR}/.config
+ then
+ MODULE_NAMES="${MODULE_NAMES} ivtv-fb(extra:${S}/driver)"
+ fi
+
+ convert_to_m ${S}/driver/Makefile2.6
+}
+
+src_compile() {
+ cd ${S}/driver
+ linux-mod_src_compile || die "failed to build kernel modules"
+
+ cd ${S}/utils
+ make KERNELDIR=${KERNEL_DIR} || die "build of utils failed"
+}
+
+src_install() {
+ cd ${S}/utils
+ dodir /lib/modules
+ ./ivtvfwextract.pl ${DISTDIR}/${FW_VER} \
+ ${D}/lib/modules/ivtv-fw-enc.bin \
+ ${D}/lib/modules/ivtv-fw-dec.bin
+
+ cd ${S}
+ dodoc README doc/*
+ cd ${S}/utils
+ newdoc README README.utils
+ dodoc README.mythtv-ivtv README.X11
+ dodoc lircd-g.conf lircd.conf lircrc
+
+ cd ${S}/utils
+ #should work... no idea why its not
+ #make KERNELDIR=${KERNEL_DIR} DESTDIR=${D} INSTALLDIR=/usr/bin install-sane || die "failed to install"
+ newbin encoder ivtv-encoder
+ newbin fwapi ivtv-fwapi
+ newbin radio ivtv-radio
+ newbin vbi ivtv-vbi
+ newbin mpegindex ivtv-mpegindex
+ dobin ivtvfbctl ivtvplay ivtvctl
+
+ cd ${S}/driver
+ linux-mod_src_install || die "failed to install modules"
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ einfo "You now have the driver for the Hauppauge PVR-[23]50 cards."
+ einfo "Add ivtv to /etc/modules.autoload.d/kernel-2.X"
+ echo
+ einfo "To get the ir remote working, you'll need to emerge lirc"
+ einfo "with the following set:"
+ einfo "LIRC_OPTS=\"--with-x --with-driver=hauppauge --with-major=61 "
+ einfo " --with-port=none --with-irq=none\" emerge lirc"
+ echo
+ einfo "You can also add the above LIRC_OPTS line to /etc/make.conf for"
+ einfo "it to remain there for future updates."
+ echo
+ einfo "To use vbi, you'll need a few other things, check README.vbi in the docs dir"
+ echo
+ einfo "The ptune* scripts have moved to media-tv/ivtv-ptune, emerge that to use those scripts"
+ echo
+
+ if [ -f "${ROOT}/lib/modules/`uname -r`/kernel/drivers/media/video/msp3400.ko" ] ; then
+ ewarn "You have the msp3400 module that comes with the kernel. It isn't compatible"
+ ewarn "with ivtv. You need to back it up to somewhere else, then run update-modules"
+ fi
+}