summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2007-01-14 22:03:33 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2007-01-14 22:03:33 +0000
commit441da8f66365e8667ef9ed7572056f0d65fdb253 (patch)
tree39a15cdda8e8e0e4df0114a4f303168200220b6f /media-tv
parentEbuild maintenance (diff)
downloadgentoo-2-441da8f66365e8667ef9ed7572056f0d65fdb253.tar.gz
gentoo-2-441da8f66365e8667ef9ed7572056f0d65fdb253.tar.bz2
gentoo-2-441da8f66365e8667ef9ed7572056f0d65fdb253.zip
Version bumped.
(Portage version: 2.1.2_rc4-r9)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/linuxtv-dvb-apps/ChangeLog8
-rw-r--r--media-tv/linuxtv-dvb-apps/files/digest-linuxtv-dvb-apps-1.1.1.200701143
-rw-r--r--media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20070114.ebuild101
3 files changed, 111 insertions, 1 deletions
diff --git a/media-tv/linuxtv-dvb-apps/ChangeLog b/media-tv/linuxtv-dvb-apps/ChangeLog
index 11771426c587..8ab90036fb75 100644
--- a/media-tv/linuxtv-dvb-apps/ChangeLog
+++ b/media-tv/linuxtv-dvb-apps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-tv/linuxtv-dvb-apps
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/linuxtv-dvb-apps/ChangeLog,v 1.23 2007/01/05 17:10:04 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/linuxtv-dvb-apps/ChangeLog,v 1.24 2007/01/14 22:03:33 zzam Exp $
+
+*linuxtv-dvb-apps-1.1.1.20070114 (14 Jan 2007)
+
+ 14 Jan 2007; Matthias Schwarzott <zzam@gentoo.org>
+ +linuxtv-dvb-apps-1.1.1.20070114.ebuild:
+ Version bumped.
05 Jan 2007; Joerg Bornkessel <hd_brummy@gentoo.org>
linuxtv-dvb-apps-1.1.0.ebuild, linuxtv-dvb-apps-1.1.1.20060917.ebuild:
diff --git a/media-tv/linuxtv-dvb-apps/files/digest-linuxtv-dvb-apps-1.1.1.20070114 b/media-tv/linuxtv-dvb-apps/files/digest-linuxtv-dvb-apps-1.1.1.20070114
new file mode 100644
index 000000000000..352b262d796b
--- /dev/null
+++ b/media-tv/linuxtv-dvb-apps/files/digest-linuxtv-dvb-apps-1.1.1.20070114
@@ -0,0 +1,3 @@
+MD5 5a5e7a5f99461d916189df3d3df272b2 linuxtv-dvb-apps-20070114.tar.bz2 311657
+RMD160 7903be5c782d76829d00f16345e1f869e663bbc9 linuxtv-dvb-apps-20070114.tar.bz2 311657
+SHA256 c4fbe3df4cf02a63fb8b6c6343b33b13cfa0400559224e40421f227fa27e5afd linuxtv-dvb-apps-20070114.tar.bz2 311657
diff --git a/media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20070114.ebuild b/media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20070114.ebuild
new file mode 100644
index 000000000000..b879b964f54c
--- /dev/null
+++ b/media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20070114.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/linuxtv-dvb-apps/linuxtv-dvb-apps-1.1.1.20070114.ebuild,v 1.1 2007/01/14 22:03:33 zzam Exp $
+
+
+inherit eutils versionator
+
+MY_P="${PN}-$(get_version_component_range 4)"
+
+IUSE="usb"
+SLOT="0"
+HOMEPAGE="http://www.linuxtv.org/"
+DESCRIPTION="small utils for DVB to scan, zap, view signal strength, ..."
+LICENSE="GPL-2"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="usb? ( >=dev-libs/libusb-0.1.10a )"
+DEPEND="${DEPEND}
+ media-tv/linuxtv-dvb-headers"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack()
+{
+ unpack ${A}
+
+ cd ${S}
+ # disables compilation of ttusb_dec_reset which requires libusb
+ if ! use usb; then
+ sed -i util/Makefile \
+ -e '/ttusb_dec_reset/d' \
+ -e '/dib3000-watch/d'
+ fi
+
+ # do not compile test-progs
+ sed -i Makefile -e '/-C test/d'
+
+ # [QA] Fix library install paths on multilib aware platforms.
+ # (you'd think passing libdir=/usr/$(get_libdir) to emake would work, but
+ # no...)
+ sed -i Make.rules -e "s:\$(prefix)/lib:\$(prefix)/$(get_libdir):g"
+
+ # remove copy of header-files
+ rm -rf ${S}/include
+}
+
+src_compile()
+{
+ # interferes with variable in Makefile
+ unset ARCH
+
+ emake bindir=/usr/bin datadir=/usr/share libdir=/usr/lib || die "failed to compile"
+}
+
+src_install()
+{
+ # interferes with variable in Makefile
+ unset ARCH
+
+ insinto /usr/bin
+ emake bindir=/usr/bin datadir=/usr/share libdir=/usr/lib prefix=/usr \
+ DESTDIR=${D} INSTDIR=${T} install || die "install failed"
+
+ # rename scan to dvbscan
+ mv ${D}/usr/bin/scan ${D}/usr/bin/dvbscan
+
+ # install scan-files
+ local dir
+ for dir in dvb-{s,c,t} atsc; do
+ insinto /usr/share/dvb/scan/${dir}
+ doins ${S}/util/scan/${dir}/*
+ done
+
+ # install zap-files
+ for dir in dvb-{s,c,t} atsc; do
+ insinto /usr/share/dvb/zap/${dir}
+ doins ${S}/util/szap/channels-conf/${dir}/*
+ done
+
+ # install remote-key files
+ insinto /usr/share/dvb/av7110_loadkeys
+ doins ${S}/util/av7110_loadkeys/*.rc*
+
+ # install Documentation
+ dodoc README TODO INSTALL
+ newdoc util/scan/README README.dvbscan
+ newdoc util/szap/README README.zap
+ newdoc util/av7110_loadkeys/README README.av7110_loadkeys
+
+ use usb && newdoc util/ttusb_dec_reset/README README.ttusb_dec_reset
+}
+
+pkg_postinst()
+{
+ elog "Please read the documentation in /usr/share/doc/${PF}."
+ elog "The channel lists and other files are installed in"
+ elog "/usr/share/dvb"
+ elog
+ elog "The scanning utility is now installed as dvbscan."
+}