summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-03-02 09:20:33 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-03-02 09:20:33 +0000
commit79df002e348df5602664cb19f0762b32c11ad753 (patch)
tree41bfa4356b1a7ef1706dcad4502c8e7629536ffe /media-tv
parentrussian characters problems as per bug #83732 (diff)
downloadgentoo-2-79df002e348df5602664cb19f0762b32c11ad753.tar.gz
gentoo-2-79df002e348df5602664cb19f0762b32c11ad753.tar.bz2
gentoo-2-79df002e348df5602664cb19f0762b32c11ad753.zip
switched to linux-mod eclass. major rev bump. cleanups. amd64
(Portage version: 2.0.51.18)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/ivtv/ChangeLog11
-rw-r--r--media-tv/ivtv/files/digest-ivtv-0.2.0_rc3-r22
-rw-r--r--media-tv/ivtv/ivtv-0.2.0_rc3-r2.ebuild98
-rw-r--r--media-tv/ivtv/metadata.xml6
4 files changed, 113 insertions, 4 deletions
diff --git a/media-tv/ivtv/ChangeLog b/media-tv/ivtv/ChangeLog
index 5675414d079d..e359b6024b95 100644
--- a/media-tv/ivtv/ChangeLog
+++ b/media-tv/ivtv/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-tv/ivtv
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.19 2005/02/03 09:50:16 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.20 2005/03/02 09:20:33 cardoe Exp $
+
+*ivtv-0.2.0_rc3-r2 (02 Mar 2005)
+
+ 02 Mar 2005; Doug Goldstein <cardoe@gentoo.org> metadata.xml,
+ +ivtv-0.2.0_rc3-r2.ebuild:
+ switched to linux-mod eclass
+ handful a cleanups and fixups
+ fixes for amd64 by eradicator
+ switched to ivtv 0.2.0-rc3g
03 Feb 2005; Jeremy Huddleston <eradicator@gentoo.org>
ivtv-0.2.0_rc2.ebuild, ivtv-0.2.0_rc3.ebuild:
diff --git a/media-tv/ivtv/files/digest-ivtv-0.2.0_rc3-r2 b/media-tv/ivtv/files/digest-ivtv-0.2.0_rc3-r2
new file mode 100644
index 000000000000..7cb41b4a9e9f
--- /dev/null
+++ b/media-tv/ivtv/files/digest-ivtv-0.2.0_rc3-r2
@@ -0,0 +1,2 @@
+MD5 f12ea8ca1cb3680df4bcf9d5115905d5 ivtv-0.2.0-rc3g.tgz 517723
+MD5 173c5ce2c0f16da42a5316ef7cee6834 pvr_1.18.21.22168_inf.zip 676578
diff --git a/media-tv/ivtv/ivtv-0.2.0_rc3-r2.ebuild b/media-tv/ivtv/ivtv-0.2.0_rc3-r2.ebuild
new file mode 100644
index 000000000000..25124ad28968
--- /dev/null
+++ b/media-tv/ivtv/ivtv-0.2.0_rc3-r2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.2.0_rc3-r2.ebuild,v 1.1 2005/03/02 09:20:33 cardoe Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="ivtv driver for Hauppauge PVR[23]50 cards"
+HOMEPAGE="http://205.209.168.201/~ckennedy/ivtv/"
+
+MY_P="${P/_/-}g"
+FW_VER="pvr_1.18.21.22168_inf.zip"
+
+SRC_URI="http://205.209.168.201/~ckennedy/ivtv/${MY_P}.tgz
+ http://205.209.168.201/~ckennedy/ivtv/ivtv-0.2.0-rc/${MY_P}.tgz
+ ftp://ftp.shspvr.com/download/wintv-pvr_250-350/inf/${FW_VER}"
+
+RESTRICT="nomirror"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+IUSE=""
+S="${WORKDIR}/${MY_P}"
+
+MODULE_NAMES="ivtv(extra:${S}/driver)
+ msp3400(extra:${S}/driver)
+ saa7115(extra:${S}/driver)
+ tveeprom(extra:${S}/driver)
+ saa7127(extra:${S}/driver)"
+BUILD_TARGETS="all"
+#BUILD_PARAMS="KDIR=${KERNEL_DIR}"
+CONFIG_CHECK="I2C_ALGOBIT VIDEO_DEV SND_BT87X"
+
+DEPEND="app-arch/unzip"
+
+src_unpack() {
+ unpack ${MY_P}.tgz
+
+ if grep '^CONFIG_FB=' ${ROOT}${KV_DIR}/.config
+ then
+ MODULE_NAMES="${MODULE_NAMES} ivtv-fb(extra:${S}/driver)"
+ fi
+
+ convert_to_m ${S}/driver/Makefile2.6
+}
+
+src_compile() {
+ cd ${S}/driver
+ linux-mod_src_compile || die "failed to build kernel modules"
+
+ cd ${S}/utils
+ make KERNELDIR=${KERNEL_DIR} || die "build of utils failed"
+}
+
+src_install() {
+ cd ${S}/utils
+ dodir /lib/modules
+ ./ivtvfwextract.pl ${DISTDIR}/${FW_VER} \
+ ${D}/lib/modules/ivtv-fw-enc.bin \
+ ${D}/lib/modules/ivtv-fw-dec.bin
+
+ cd ${S}
+ dodoc README doc/*
+ cd ${S}/utils
+ newdoc README README.utils
+ dodoc README.mythtv-ivtv README.X11
+ dodoc lircd-g.conf lircd.conf lircrc
+
+ make KERNELDIR=${KERNEL_DIR} DESTDIR=${D} INSTALLDIR=/usr/bin install-sane || die "failed to install"
+
+ cd ${S}/driver
+ linux-mod_src_install || die "failed to install modules"
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ einfo "You now have the driver for the Hauppauge PVR-[23]50 cards."
+ einfo "Add ivtv to /etc/modules.autoload.d/kernel-2.X"
+ echo
+ einfo "To get the ir remote working, you'll need to emerge lirc"
+ einfo "with the following set:"
+ einfo "LIRC_OPTS=\"--with-x --with-driver=hauppauge --with-major=61 "
+ einfo " --with-port=none --with-irq=none\" emerge lirc"
+ echo
+ einfo "You can also add the above LIRC_OPTS line to /etc/make.conf for"
+ einfo "it to remain there for future updates."
+ echo
+ einfo "To use vbi, you'll need a few other things, check README.vbi in the docs dir"
+ echo
+ einfo "The ptune* scripts have moved to media-tv/ivtv-ptune, emerge that to use those scripts"
+ echo
+
+ if [ -f "${ROOT}/lib/modules/`uname -r`/kernel/drivers/media/video/msp3400.ko" ] ; then
+ ewarn "You have the msp3400 module that comes with the kernel. It isn't compatible"
+ ewarn "with ivtv. You need to back it up to somewhere else, then run update-modules"
+ fi
+}
diff --git a/media-tv/ivtv/metadata.xml b/media-tv/ivtv/metadata.xml
index b4469516f7b2..1f4aec875596 100644
--- a/media-tv/ivtv/metadata.xml
+++ b/media-tv/ivtv/metadata.xml
@@ -4,9 +4,9 @@
<pkgmetadata>
<herd>media-tv</herd>
<maintainer>
- <email>iggy@gentoo.org</email>
- <name>Brian Jackson</name>
- <description>Actively maintained</description>
+ <email>cardoe@gentoo.org</email>
+ <name>Doug Goldstein</name>
+ <description>driver for Hauppauge tv tuner cards</description>
</maintainer>
<longdescription>
Driver for ivtv based tv tuner cards, currently supports Hauppauge