summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-02-10 15:51:44 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-02-10 15:51:44 +0000
commite9aeb28f797fe1a438acb8ecc8fe2a14b51fd410 (patch)
tree9b347302b2b729314e507f34fc63093ee99cfb5d /media-tv
parentLastrite media-tv/ivtv-firmware wrt #369497 and #446644 (diff)
downloadgentoo-2-e9aeb28f797fe1a438acb8ecc8fe2a14b51fd410.tar.gz
gentoo-2-e9aeb28f797fe1a438acb8ecc8fe2a14b51fd410.tar.bz2
gentoo-2-e9aeb28f797fe1a438acb8ecc8fe2a14b51fd410.zip
old
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/ivtv/ChangeLog6
-rw-r--r--media-tv/ivtv/ivtv-1.0.1.ebuild138
-rw-r--r--media-tv/ivtv/ivtv-1.0.2.ebuild138
-rw-r--r--media-tv/ivtv/ivtv-1.0.3-r2.ebuild145
-rw-r--r--media-tv/ivtv/ivtv-1.1.0-r1.ebuild123
5 files changed, 5 insertions, 545 deletions
diff --git a/media-tv/ivtv/ChangeLog b/media-tv/ivtv/ChangeLog
index 23d6d8123424..098ded818875 100644
--- a/media-tv/ivtv/ChangeLog
+++ b/media-tv/ivtv/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/ivtv
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.114 2013/01/21 22:19:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.115 2013/02/10 15:51:44 ssuominen Exp $
+
+ 10 Feb 2013; Samuli Suominen <ssuominen@gentoo.org> -ivtv-1.0.1.ebuild,
+ -ivtv-1.0.2.ebuild, -ivtv-1.0.3-r2.ebuild, -ivtv-1.1.0-r1.ebuild:
+ old
21 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> ivtv-1.0.1.ebuild,
ivtv-1.0.2.ebuild, ivtv-1.0.3-r2.ebuild:
diff --git a/media-tv/ivtv/ivtv-1.0.1.ebuild b/media-tv/ivtv/ivtv-1.0.1.ebuild
deleted file mode 100644
index f15b10191246..000000000000
--- a/media-tv/ivtv/ivtv-1.0.1.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-1.0.1.ebuild,v 1.11 2013/01/21 22:19:30 ssuominen Exp $
-
-inherit eutils linux-mod
-
-DESCRIPTION="ivtv driver for Hauppauge PVR PCI cards"
-HOMEPAGE="http://www.ivtvdriver.org"
-SRC_URI="http://dl.ivtvdriver.org/ivtv/archive/1.0.x/${P}.tar.gz"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="fbcon"
-RDEPEND="virtual/udev"
-DEPEND="app-arch/unzip"
-PDEPEND=">=media-tv/ivtv-firmware-20070217"
-
-pkg_setup() {
-
- MODULE_NAMES="saa717x(extra:${S}/i2c-drivers)"
- BUILD_TARGETS="all"
- CONFIG_CHECK="EXPERIMENTAL KMOD HAS_IOMEM FW_LOADER I2C I2C_ALGOBIT
- VIDEO_DEV VIDEO_CAPTURE_DRIVERS VIDEO_V4L1 VIDEO_V4L2
- !VIDEO_HELPER_CHIPS_AUTO VIDEO_IVTV"
-
- if use fbcon; then
- MODULE_NAMES="${MODULE_NAMES} ivtv-fb(extra:${S}/driver)"
- CONFIG_CHECK="${CONFIG_CHECK} FB FB_TRIDENT FRAMEBUFFER_CONSOLE FONTS"
- fi
-
- if ! ( kernel_is 2 6 22 ); then
- eerror "Each IVTV driver branch will only work with a specific"
- eerror "linux kernel branch."
- eerror ""
- eerror "You will need to either:"
- eerror "a) emerge a different kernel"
- eerror "b) emerge a different ivtv driver"
- eerror ""
- eerror "See http://ivtvdriver.org/ for more information"
- die "This only works on 2.6.22 kernels"
- fi
-
- if use fbcon; then
- ewarn ""
- ewarn "From the README regarding framebuffer support:"
- ewarn ""
- ewarn "ivtv-fb now requires that you enable the following kernel config"
- ewarn "options: Go to 'Device drivers -> Graphics support'. Enable"
- ewarn "'Support for frame buffer devices'. Enable 'Trident support'"
- ewarn "(the Trident module itself is not required)."
- ewarn ""
- ewarn "To get working console output, keep going to 'Console display"
- ewarn "driver support', and enable 'Framebuffer Console support'."
- ewarn "Enable 'Select compiled-in fonts' & once that's done, you should"
- ewarn "have a list of fonts. Choose one. With the default OSD size,"
- ewarn "'VGA 8x16' gives 80x30(PAL) 80x25(NTSC)."
- ewarn ""
- ewarn "This ebuild checks for all the correct kernel config options for"
- ewarn "framebuffer use with the exception of choosing a font. Be sure"
- ewarn "to pick one yourself!"
- ewarn ""
- fi
-
- ewarn ""
- ewarn "Make sure that your I2C and V4L kernel drivers are loaded as"
- ewarn "modules, and not compiled into the kernel, or IVTV will not"
- ewarn "work."
- ewarn ""
-
- linux-mod_pkg_setup
-
- BUILD_PARAMS="KDIR=${KV_DIR}"
-}
-
-src_compile() {
-
- cd "${S}/driver"
- linux-mod_src_compile || die "failed to build driver"
-
- cd "${S}/utils"
- emake INCDIR="${KV_DIR}/include" || die "failed to build utils "
-}
-
-src_install() {
- cd "${S}/utils"
- make DESTDIR="${D}" PREFIX="/usr" install || die "failed to install utils"
- dobin perl/*.pl
-
- cd "${S}"
- dodoc README* doc/* utils/README.X11 ChangeLog* utils/perl/README.ptune
-
- cd "${S}/driver"
- linux-mod_src_install || die "failed to install modules"
-}
-
-pkg_postinst() {
-
- linux-mod_pkg_postinst
-
- elog ""
- elog "This version of the IVTV driver supports the following hardware:"
- elog "Hauppauge WinTV PVR-250"
- elog "Hauppauge WinTV PVR-350"
- elog "Hauppauge WinTV PVR-150"
- elog "Hauppauge WinTV PVR-500"
- elog "AVerMedia M179"
- elog "Yuan MPG600/Kuroutoshikou iTVC16-STVLP"
- elog "Yuan MPG160/Kuroutoshikou iTVC15-STVLP"
- elog "Yuan PG600/DiamondMM PVR-550 (CX Falcon 2)"
- elog "Adaptec AVC-2410"
- elog "Adaptec AVC-2010"
- elog "Nagase Transgear 5000TV"
- elog "AOpen VA2000MAX-STN6"
- elog "Yuan MPG600GR/Kuroutoshikou CX23416GYC-STVLP"
- elog "I/O Data GV-MVP/RX"
- elog "I/O Data GV-MVP/RX2E"
- elog "Gotview PCI DVD (preliminary support only)"
- elog "Gotview PCI DVD2 Deluxe"
- elog "Yuan MPC622"
- elog ""
- ewarn ""
- ewarn "IMPORTANT: In case of problems first read this page:"
- ewarn "http://www.ivtvdriver.org/index.php/Troubleshooting"
- ewarn ""
- ewarn "If any of these conditions match your setup, you may want to look at the"
- ewarn "README in /usr/share/doc/${PF}/"
- ewarn ""
- ewarn " - Using MythTV, a PVR-350 and the ivtv-fb module"
- ewarn " - Using the ivtv X driver and the ivtv-fb module"
- ewarn " - You want to manually build ivtv against v4l-dvb"
- ewarn ""
- ewarn "Also, the ivtv package comes with lots of documentation regarding setup,"
- ewarn "proper use and debugging utilities."
- ewarn "They are also located in /usr/share/doc/${PF}/"
- ewarn ""
- ewarn "For more information, see the IVTV driver homepage at:"
- ewarn "http://www.ivtvdriver.org/"
-}
diff --git a/media-tv/ivtv/ivtv-1.0.2.ebuild b/media-tv/ivtv/ivtv-1.0.2.ebuild
deleted file mode 100644
index abce1b01eb7e..000000000000
--- a/media-tv/ivtv/ivtv-1.0.2.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-1.0.2.ebuild,v 1.13 2013/01/21 22:19:30 ssuominen Exp $
-
-inherit eutils linux-mod
-
-DESCRIPTION="ivtv driver for Hauppauge PVR PCI cards"
-HOMEPAGE="http://www.ivtvdriver.org"
-SRC_URI="http://dl.ivtvdriver.org/ivtv/archive/1.0.x/${P}.tar.gz"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="fbcon"
-RDEPEND="virtual/udev"
-DEPEND="app-arch/unzip"
-PDEPEND=">=media-tv/ivtv-firmware-20070217"
-
-pkg_setup() {
-
- MODULE_NAMES="saa717x(extra:${S}/i2c-drivers)"
- BUILD_TARGETS="all"
- CONFIG_CHECK="EXPERIMENTAL KMOD HAS_IOMEM FW_LOADER I2C I2C_ALGOBIT
- VIDEO_DEV VIDEO_CAPTURE_DRIVERS VIDEO_V4L1 VIDEO_V4L2
- !VIDEO_HELPER_CHIPS_AUTO VIDEO_IVTV"
-
- if use fbcon; then
- MODULE_NAMES="${MODULE_NAMES} ivtv-fb(extra:${S}/driver)"
- CONFIG_CHECK="${CONFIG_CHECK} FB FB_TRIDENT FRAMEBUFFER_CONSOLE FONTS"
- fi
-
- if ! ( kernel_is 2 6 22 || kernel_is 2 6 23 ); then
- eerror "Each IVTV driver branch will only work with a specific"
- eerror "linux kernel branch."
- eerror ""
- eerror "You will need to either:"
- eerror "a) emerge a different kernel"
- eerror "b) emerge a different ivtv driver"
- eerror ""
- eerror "See http://ivtvdriver.org/ for more information"
- die "This only works on 2.6.22 and 2.6.23 kernels"
- fi
-
- if use fbcon; then
- ewarn ""
- ewarn "From the README regarding framebuffer support:"
- ewarn ""
- ewarn "ivtv-fb now requires that you enable the following kernel config"
- ewarn "options: Go to 'Device drivers -> Graphics support'. Enable"
- ewarn "'Support for frame buffer devices'. Enable 'Trident support'"
- ewarn "(the Trident module itself is not required)."
- ewarn ""
- ewarn "To get working console output, keep going to 'Console display"
- ewarn "driver support', and enable 'Framebuffer Console support'."
- ewarn "Enable 'Select compiled-in fonts' & once that's done, you should"
- ewarn "have a list of fonts. Choose one. With the default OSD size,"
- ewarn "'VGA 8x16' gives 80x30(PAL) 80x25(NTSC)."
- ewarn ""
- ewarn "This ebuild checks for all the correct kernel config options for"
- ewarn "framebuffer use with the exception of choosing a font. Be sure"
- ewarn "to pick one yourself!"
- ewarn ""
- fi
-
- ewarn ""
- ewarn "Make sure that your I2C and V4L kernel drivers are loaded as"
- ewarn "modules, and not compiled into the kernel, or IVTV will not"
- ewarn "work."
- ewarn ""
-
- linux-mod_pkg_setup
-
- BUILD_PARAMS="KDIR=${KV_DIR}"
-}
-
-src_compile() {
-
- cd "${S}/driver"
- linux-mod_src_compile || die "failed to build driver"
-
- cd "${S}/utils"
- emake INCDIR="${KV_DIR}/include" || die "failed to build utils "
-}
-
-src_install() {
- cd "${S}/utils"
- make DESTDIR="${D}" PREFIX="/usr" install || die "failed to install utils"
- dobin perl/*.pl
-
- cd "${S}"
- dodoc README* doc/* utils/README.X11 ChangeLog* utils/perl/README.ptune
-
- cd "${S}/driver"
- linux-mod_src_install || die "failed to install modules"
-}
-
-pkg_postinst() {
-
- linux-mod_pkg_postinst
-
- elog ""
- elog "This version of the IVTV driver supports the following hardware:"
- elog "Hauppauge WinTV PVR-250"
- elog "Hauppauge WinTV PVR-350"
- elog "Hauppauge WinTV PVR-150"
- elog "Hauppauge WinTV PVR-500"
- elog "AVerMedia M179"
- elog "Yuan MPG600/Kuroutoshikou iTVC16-STVLP"
- elog "Yuan MPG160/Kuroutoshikou iTVC15-STVLP"
- elog "Yuan PG600/DiamondMM PVR-550 (CX Falcon 2)"
- elog "Adaptec AVC-2410"
- elog "Adaptec AVC-2010"
- elog "Nagase Transgear 5000TV"
- elog "AOpen VA2000MAX-STN6"
- elog "Yuan MPG600GR/Kuroutoshikou CX23416GYC-STVLP"
- elog "I/O Data GV-MVP/RX"
- elog "I/O Data GV-MVP/RX2E"
- elog "Gotview PCI DVD (preliminary support only)"
- elog "Gotview PCI DVD2 Deluxe"
- elog "Yuan MPC622"
- elog ""
- ewarn ""
- ewarn "IMPORTANT: In case of problems first read this page:"
- ewarn "http://www.ivtvdriver.org/index.php/Troubleshooting"
- ewarn ""
- ewarn "If any of these conditions match your setup, you may want to look at the"
- ewarn "README in /usr/share/doc/${PF}/"
- ewarn ""
- ewarn " - Using MythTV, a PVR-350 and the ivtv-fb module"
- ewarn " - Using the ivtv X driver and the ivtv-fb module"
- ewarn " - You want to manually build ivtv against v4l-dvb"
- ewarn ""
- ewarn "Also, the ivtv package comes with lots of documentation regarding setup,"
- ewarn "proper use and debugging utilities."
- ewarn "They are also located in /usr/share/doc/${PF}/"
- ewarn ""
- ewarn "For more information, see the IVTV driver homepage at:"
- ewarn "http://www.ivtvdriver.org/"
-}
diff --git a/media-tv/ivtv/ivtv-1.0.3-r2.ebuild b/media-tv/ivtv/ivtv-1.0.3-r2.ebuild
deleted file mode 100644
index 2595b1212a22..000000000000
--- a/media-tv/ivtv/ivtv-1.0.3-r2.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-1.0.3-r2.ebuild,v 1.9 2013/01/21 22:19:30 ssuominen Exp $
-
-inherit eutils linux-mod
-
-DESCRIPTION="ivtv driver for Hauppauge PVR PCI cards"
-HOMEPAGE="http://www.ivtvdriver.org"
-SRC_URI="http://dl.ivtvdriver.org/ivtv/archive/1.0.x/${P}.tar.gz"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="fbcon perl"
-RDEPEND="virtual/udev"
-DEPEND="app-arch/unzip"
-PDEPEND=">=media-tv/ivtv-firmware-20070217
- perl? (
- dev-perl/Video-Frequencies
- dev-perl/Video-ivtv
- dev-perl/Config-IniFiles
- virtual/perl-Getopt-Long
- dev-perl/perl-tk )"
-
-pkg_setup() {
-
- MODULE_NAMES="saa717x(extra:${S}/i2c-drivers)"
- BUILD_TARGETS="all"
- CONFIG_CHECK="EXPERIMENTAL KMOD HAS_IOMEM FW_LOADER I2C I2C_ALGOBIT
- VIDEO_DEV VIDEO_CAPTURE_DRIVERS VIDEO_V4L1 VIDEO_V4L2
- !VIDEO_HELPER_CHIPS_AUTO VIDEO_IVTV"
-
- if use fbcon; then
- MODULE_NAMES="${MODULE_NAMES} ivtvfb(extra:${S}/driver)"
- CONFIG_CHECK="${CONFIG_CHECK} FB FB_TRIDENT FRAMEBUFFER_CONSOLE FONTS"
- fi
-
- if ! ( kernel_is 2 6 22 || kernel_is 2 6 23 ); then
- eerror "Each IVTV driver branch will only work with a specific"
- eerror "linux kernel branch."
- eerror ""
- eerror "You will need to either:"
- eerror "a) emerge a different kernel"
- eerror "b) emerge a different ivtv driver"
- eerror ""
- eerror "See http://ivtvdriver.org/ for more information"
- die "This only works on 2.6.22 and 2.6.23 kernels"
- fi
-
- if use fbcon; then
- ewarn ""
- ewarn "From the README regarding framebuffer support:"
- ewarn ""
- ewarn "ivtvfb now requires that you enable the following kernel config"
- ewarn "options: Go to 'Device drivers -> Graphics support'. Enable"
- ewarn "'Support for frame buffer devices'. Enable 'Trident support'"
- ewarn "(the Trident module itself is not required)."
- ewarn ""
- ewarn "To get working console output, keep going to 'Console display"
- ewarn "driver support', and enable 'Framebuffer Console support'."
- ewarn "Enable 'Select compiled-in fonts' & once that's done, you should"
- ewarn "have a list of fonts. Choose one. With the default OSD size,"
- ewarn "'VGA 8x16' gives 80x30(PAL) 80x25(NTSC)."
- ewarn ""
- ewarn "This ebuild checks for all the correct kernel config options for"
- ewarn "framebuffer use with the exception of choosing a font. Be sure"
- ewarn "to pick one yourself!"
- ewarn ""
- fi
-
- ewarn ""
- ewarn "Make sure that your I2C and V4L kernel drivers are loaded as"
- ewarn "modules, and not compiled into the kernel, or IVTV will not"
- ewarn "work."
- ewarn ""
-
- linux-mod_pkg_setup
-
- BUILD_PARAMS="KDIR=${KV_DIR}"
-}
-
-src_compile() {
-
- cd "${S}/driver"
- linux-mod_src_compile || die "failed to build driver"
-
- cd "${S}/utils"
- emake INCDIR="${KV_DIR}/include" || die "failed to build utils "
-}
-
-src_install() {
- cd "${S}/utils"
- make DESTDIR="${D}" PREFIX="/usr" install || die "failed to install utils"
- use perl && dobin perl/*.pl
-
- cd "${S}"
- dodoc README* doc/* ChangeLog*
- use perl && dodoc utils/perl/README.ptune
-
- cd "${S}/driver"
- linux-mod_src_install || die "failed to install modules"
-}
-
-pkg_postinst() {
-
- linux-mod_pkg_postinst
-
- elog ""
- elog "This version of the IVTV driver supports the following hardware:"
- elog "Hauppauge WinTV PVR-250"
- elog "Hauppauge WinTV PVR-350"
- elog "Hauppauge WinTV PVR-150"
- elog "Hauppauge WinTV PVR-500"
- elog "AVerMedia M179"
- elog "Yuan MPG600/Kuroutoshikou iTVC16-STVLP"
- elog "Yuan MPG160/Kuroutoshikou iTVC15-STVLP"
- elog "Yuan PG600/DiamondMM PVR-550 (CX Falcon 2)"
- elog "Adaptec AVC-2410"
- elog "Adaptec AVC-2010"
- elog "Nagase Transgear 5000TV"
- elog "AOpen VA2000MAX-STN6"
- elog "Yuan MPG600GR/Kuroutoshikou CX23416GYC-STVLP"
- elog "I/O Data GV-MVP/RX"
- elog "I/O Data GV-MVP/RX2E"
- elog "Gotview PCI DVD (preliminary support only)"
- elog "Gotview PCI DVD2 Deluxe"
- elog "Yuan MPC622"
- elog ""
- ewarn ""
- ewarn "IMPORTANT: In case of problems first read this page:"
- ewarn "http://www.ivtvdriver.org/index.php/Troubleshooting"
- ewarn ""
- ewarn "If any of these conditions match your setup, you may want to look at the"
- ewarn "README in /usr/share/doc/${PF}/"
- ewarn ""
- ewarn " - Using MythTV, a PVR-350 and the ivtvfb module"
- ewarn " - Using the ivtv X driver and the ivtvfb module"
- ewarn " - You want to manually build ivtv against v4l-dvb"
- ewarn ""
- ewarn "Also, the ivtv package comes with lots of documentation regarding setup,"
- ewarn "proper use and debugging utilities."
- ewarn "They are also located in /usr/share/doc/${PF}/"
- ewarn ""
- ewarn "For more information, see the IVTV driver homepage at:"
- ewarn "http://www.ivtvdriver.org/"
-}
diff --git a/media-tv/ivtv/ivtv-1.1.0-r1.ebuild b/media-tv/ivtv/ivtv-1.1.0-r1.ebuild
deleted file mode 100644
index c5d9a31f7b2c..000000000000
--- a/media-tv/ivtv/ivtv-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-1.1.0-r1.ebuild,v 1.4 2012/11/29 02:22:04 ssuominen Exp $
-
-inherit eutils linux-mod
-
-DESCRIPTION="ivtv driver for Hauppauge PVR PCI cards"
-HOMEPAGE="http://www.ivtvdriver.org"
-SRC_URI="http://dl.ivtvdriver.org/ivtv/archive/1.1.x/${P}.tar.gz"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="perl"
-RDEPEND="virtual/udev"
-DEPEND="app-arch/unzip"
-PDEPEND=">=media-tv/ivtv-firmware-20070217
- perl? (
- dev-perl/Video-Frequencies
- dev-perl/Video-ivtv
- dev-perl/Config-IniFiles
- virtual/perl-Getopt-Long
- dev-perl/perl-tk )"
-
-pkg_setup() {
-
- MODULE_NAMES="saa717x(extra:${S}/i2c-drivers)"
- BUILD_TARGETS="all"
- CONFIG_CHECK="EXPERIMENTAL KMOD HAS_IOMEM FW_LOADER I2C I2C_ALGOBIT
- VIDEO_DEV VIDEO_CAPTURE_DRIVERS VIDEO_V4L1 VIDEO_V4L2
- !VIDEO_HELPER_CHIPS_AUTO VIDEO_IVTV"
-
- if ! ( kernel_is 2 6 24 ); then
- eerror "Each IVTV driver branch will only work with a specific"
- eerror "linux kernel branch."
- eerror ""
- eerror "You will need to either:"
- eerror "a) emerge a different kernel"
- eerror "b) emerge a different ivtv driver"
- eerror ""
- eerror "See http://ivtvdriver.org/ for more information"
- die "This only works on 2.6.24 kernels"
- fi
-
- ewarn ""
- ewarn "Make sure that your I2C and V4L kernel drivers are loaded as"
- ewarn "modules, and not compiled into the kernel, or IVTV will not"
- ewarn "work."
- ewarn ""
-
- linux-mod_pkg_setup
-
- BUILD_PARAMS="KDIR=${KV_DIR}"
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-headers.patch
-}
-
-src_compile() {
- linux-mod_src_compile || die "failed to build driver"
-
- cd "${S}/utils"
- emake INCDIR="${KV_DIR}/include" || die "failed to build utils "
-}
-
-src_install() {
- cd "${S}/utils"
- make DESTDIR="${D}" PREFIX="/usr" install || die "failed to install utils"
- use perl && dobin perl/*.pl
-
- cd "${S}"
- dodoc README* doc/* ChangeLog*
- use perl && dodoc utils/perl/README.ptune
-
- linux-mod_src_install || die "failed to install modules"
-}
-
-pkg_postinst() {
-
- linux-mod_pkg_postinst
-
- elog ""
- elog "This version of the IVTV driver supports the following hardware:"
- elog "Hauppauge WinTV PVR-250"
- elog "Hauppauge WinTV PVR-350"
- elog "Hauppauge WinTV PVR-150"
- elog "Hauppauge WinTV PVR-500"
- elog "AVerMedia M179"
- elog "Yuan MPG600/Kuroutoshikou iTVC16-STVLP"
- elog "Yuan MPG160/Kuroutoshikou iTVC15-STVLP"
- elog "Yuan PG600/DiamondMM PVR-550 (CX Falcon 2)"
- elog "Adaptec AVC-2410"
- elog "Adaptec AVC-2010"
- elog "Nagase Transgear 5000TV"
- elog "AOpen VA2000MAX-STN6"
- elog "Yuan MPG600GR/Kuroutoshikou CX23416GYC-STVLP"
- elog "I/O Data GV-MVP/RX"
- elog "I/O Data GV-MVP/RX2E"
- elog "Gotview PCI DVD (preliminary support only)"
- elog "Gotview PCI DVD2 Deluxe"
- elog "Yuan MPC622"
- elog ""
- ewarn ""
- ewarn "IMPORTANT: In case of problems first read this page:"
- ewarn "http://www.ivtvdriver.org/index.php/Troubleshooting"
- ewarn ""
- ewarn "If any of these conditions match your setup, you may want to look at the"
- ewarn "README in /usr/share/doc/${PF}/"
- ewarn ""
- ewarn " - Using MythTV, a PVR-350 and the ivtvfb module"
- ewarn " - Using the ivtv X driver and the ivtvfb module"
- ewarn " - You want to manually build ivtv against v4l-dvb"
- ewarn ""
- ewarn "Also, the ivtv package comes with lots of documentation regarding setup,"
- ewarn "proper use and debugging utilities."
- ewarn "They are also located in /usr/share/doc/${PF}/"
- ewarn ""
- ewarn "For more information, see the IVTV driver homepage at:"
- ewarn "http://www.ivtvdriver.org/"
-}