summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-10 12:15:52 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-10 12:15:52 +0000
commite94e34c6a83286944c92cc8ded6b279723314a07 (patch)
tree6d4cf02bac1b1035acac99f04a4ac93298ee6993 /media-video/bcast
parent*** empty log message *** (diff)
downloadgentoo-2-e94e34c6a83286944c92cc8ded6b279723314a07.tar.gz
gentoo-2-e94e34c6a83286944c92cc8ded6b279723314a07.tar.bz2
gentoo-2-e94e34c6a83286944c92cc8ded6b279723314a07.zip
changed name becase the old broke emerge
Diffstat (limited to 'media-video/bcast')
-rw-r--r--media-video/bcast/bcast-2000c.ebuild59
-rw-r--r--media-video/bcast/files/digest-bcast-2000c1
2 files changed, 60 insertions, 0 deletions
diff --git a/media-video/bcast/bcast-2000c.ebuild b/media-video/bcast/bcast-2000c.ebuild
new file mode 100644
index 000000000000..b7be9dd9e958
--- /dev/null
+++ b/media-video/bcast/bcast-2000c.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/bcast/bcast-2000c.ebuild,v 1.1 2001/05/10 12:15:52 achim Exp $
+
+A=${P}-src.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Realtime audio and video editor"
+SRC_URI="ftp://heroines.sourceforge.net/pub/heroines/${A}"
+HOMEPAGE="http://heroines.sourceforge.net/"
+
+DEPEND="virtual/glibc
+ >=sys-devel/gcc-2.95.2
+ >=media-sound/esound-0.2.19
+ >=media-libs/jpeg-6b
+ >=media-libs/tiff-3.5.5
+ >=media-libs/libpng-1.0.7
+ virtual/x11"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/bcast
+ cp main.C main.C.orig
+ sed -e "s:/usr/local/bcast/plugins:/usr/X11R6/lib/bcast/plugins:" \
+ main.C.orig > main.C
+ cd ${S}/esound
+ cp esd.h esd.h.orig
+# sed -e "s:<audiofile\.h>:\"\.\./audiofile/audiofile\.h\":" esd.h.orig > esd.h
+ cd ${S}/quicktime/libdv
+ cp dvprivate.h dvprivate.h.orig
+# sed -e "s:<libraw1394/raw1394\.h>:\"\.\./\.\./libraw1394/raw1394\.h\":" dvprivate.h.orig > dvprivate.h
+}
+src_compile() {
+
+ cd ${S}
+ try ./configure
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ into /usr
+ dobin bcast/bcast2000
+ dolib.so bcbase/libbcbase.so
+ dolib.so guicast/libguicast.so
+ insopts -m 755
+ insinto /usr/X11R6/lib/bcast/plugins
+ doins plugins/*.plugin
+ dodoc COPYING
+ docinto html
+ dodoc docs/*.html docs/*.png docs/*.jpg
+
+
+}
+
+
+
diff --git a/media-video/bcast/files/digest-bcast-2000c b/media-video/bcast/files/digest-bcast-2000c
new file mode 100644
index 000000000000..d9839988671f
--- /dev/null
+++ b/media-video/bcast/files/digest-bcast-2000c
@@ -0,0 +1 @@
+MD5 1648ade202eadfca9522d5371c003820 bcast-2000c-src.tar.gz