summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-01-22 23:44:14 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-01-22 23:44:14 +0000
commit36624f1e8aa59da2bbf0df198d654a436a92d987 (patch)
treed61759b06cc57ae844df79ac9a374c0f90461f7c /media-video/cinelerra-cvs
parentkeywording ~amd64 (diff)
downloadgentoo-2-36624f1e8aa59da2bbf0df198d654a436a92d987.tar.gz
gentoo-2-36624f1e8aa59da2bbf0df198d654a436a92d987.tar.bz2
gentoo-2-36624f1e8aa59da2bbf0df198d654a436a92d987.zip
New snapshot
(Portage version: 2.1.2-r2)
Diffstat (limited to 'media-video/cinelerra-cvs')
-rw-r--r--media-video/cinelerra-cvs/ChangeLog8
-rw-r--r--media-video/cinelerra-cvs/cinelerra-cvs-20070122.ebuild103
-rw-r--r--media-video/cinelerra-cvs/files/digest-cinelerra-cvs-200701223
3 files changed, 113 insertions, 1 deletions
diff --git a/media-video/cinelerra-cvs/ChangeLog b/media-video/cinelerra-cvs/ChangeLog
index 98d7e1bfc7bf..57283c81e3e7 100644
--- a/media-video/cinelerra-cvs/ChangeLog
+++ b/media-video/cinelerra-cvs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/cinelerra-cvs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra-cvs/ChangeLog,v 1.25 2007/01/22 22:25:10 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra-cvs/ChangeLog,v 1.26 2007/01/22 23:44:14 aballier Exp $
+
+*cinelerra-cvs-20070122 (22 Jan 2007)
+
+ 22 Jan 2007; Alexis Ballier <aballier@gentoo.org>
+ +cinelerra-cvs-20070122.ebuild:
+ New snapshot
22 Jan 2007; Alexis Ballier <aballier@gentoo.org>
-files/cinelerra-cvs-20060219-gcc41.patch, -cinelerra-cvs-20060219.ebuild,
diff --git a/media-video/cinelerra-cvs/cinelerra-cvs-20070122.ebuild b/media-video/cinelerra-cvs/cinelerra-cvs-20070122.ebuild
new file mode 100644
index 000000000000..d5cf2463ea60
--- /dev/null
+++ b/media-video/cinelerra-cvs/cinelerra-cvs-20070122.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinelerra-cvs/cinelerra-cvs-20070122.ebuild,v 1.1 2007/01/22 23:44:14 aballier Exp $
+
+WANT_AUTOMAKE=1.9
+WANT_AUTOCONF=2.5
+
+inherit toolchain-funcs eutils flag-o-matic autotools
+
+#filter-flags "-fPIC -fforce-addr"
+
+RESTRICT="nostrip"
+
+DESCRIPTION="Cinelerra - Professional Video Editor - Unofficial CVS-version"
+HOMEPAGE="http://cvs.cinelerra.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="3dnow alsa esd mmx oss static truetype ieee1394 css altivec opengl"
+RDEPEND="media-libs/libpng
+ >=media-libs/libdv-1.0.0
+ media-libs/faad2
+ media-libs/faac
+ media-libs/a52dec
+ media-libs/libsndfile
+ media-libs/tiff
+ media-video/ffmpeg
+ media-sound/lame
+ >=sci-libs/fftw-3.0.1
+ >=media-libs/x264-svn-20060302
+ ieee1394? ( media-libs/libiec61883 >=sys-libs/libraw1394-1.2.0 \
+ >=sys-libs/libavc1394-0.5.0 )
+ media-video/mjpegtools
+ alsa? ( media-libs/alsa-lib )
+ esd? ( >=media-sound/esound-0.2.34 )
+ truetype? ( >=media-libs/freetype-2.1.10 )
+ opengl? ( virtual/opengl )
+ >=media-libs/openexr-1.2.2
+ >=media-libs/libvorbis-1.1.0
+ >=media-libs/libogg-1.1
+ >=media-libs/libtheora-1.0_alpha4-r1
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXv
+ x11-libs/libXxf86vm
+ x11-libs/libXext
+ x11-libs/libXvMC
+ x11-libs/libXft
+ ) virtual/x11 )"
+
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ if [[ "$(gcc-major-version)" -lt "4" ]]; then
+ eerror "You need to have gcc 4 or better"
+ eerror "Please follow : http://www.gentoo.org/doc/en/gcc-upgrading.xml"
+ eerror "And have a look at bug #128659"
+ die "You must use gcc 4 or better."
+ fi
+}
+
+src_compile() {
+ AT_M4DIR="m4" eautoreconf
+ econf \
+ `use_enable static` \
+ `use_enable alsa` \
+ `use_enable esd` \
+ `use_enable oss` \
+ `use_enable mmx` \
+ `use_enable 3dnow` \
+ --with-plugindir=/usr/$(get_libdir)/cinelerra \
+ `use_enable truetype freetype2` \
+ `use_enable ieee1394 firewire` \
+ `use_enable css` \
+ `use_enable opengl` \
+ `use_enable altivec` \
+ --with-external-ffmpeg \
+ --with-buildinfo=cust/"SVN r984" \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ dohtml -a png,html,texi,sdw -r doc/*
+ # workaround
+ rm -fR ${D}/usr/include
+ mv ${D}/usr/bin/mpeg3cat ${D}/usr/bin/mpeg3cat.hv
+ mv ${D}/usr/bin/mpeg3dump ${D}/usr/bin/mpeg3dump.hv
+ mv ${D}/usr/bin/mpeg3toc ${D}/usr/bin/mpeg3toc.hv
+ ln -s /usr/bin/mpeg2enc ${D}/usr/$(get_libdir)/cinelerra/mpeg2enc.plugin
+}
+
+pkg_postinst () {
+ elog "Please note that this is unofficial and somewhat experimental code."
+ elog "See cvs.cinelerra.org for a list of changes to the official cinelerra"
+ elog "release."
+}
diff --git a/media-video/cinelerra-cvs/files/digest-cinelerra-cvs-20070122 b/media-video/cinelerra-cvs/files/digest-cinelerra-cvs-20070122
new file mode 100644
index 000000000000..0737c18853c1
--- /dev/null
+++ b/media-video/cinelerra-cvs/files/digest-cinelerra-cvs-20070122
@@ -0,0 +1,3 @@
+MD5 92ce5e927ddbf87b04f607ed12f85e57 cinelerra-cvs-20070122.tar.bz2 46641387
+RMD160 3ff696096166a5a41730687400acadf21a4e8e87 cinelerra-cvs-20070122.tar.bz2 46641387
+SHA256 95b94ef5da7eb4d2278f5c6e069c95f30b48cd2f64273faf730b599705ff6b80 cinelerra-cvs-20070122.tar.bz2 46641387