summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-08-02 23:00:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-08-02 23:00:58 +0000
commita4e8b889b8d2bd8fac93bebfa58980c227daefc5 (patch)
treeffdceabd91e443c50e572c5e6726b9dafe43a8d2 /media-video/clive
parentVersion bump. (diff)
downloadgentoo-2-a4e8b889b8d2bd8fac93bebfa58980c227daefc5.tar.gz
gentoo-2-a4e8b889b8d2bd8fac93bebfa58980c227daefc5.tar.bz2
gentoo-2-a4e8b889b8d2bd8fac93bebfa58980c227daefc5.zip
version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-video/clive')
-rw-r--r--media-video/clive/ChangeLog7
-rw-r--r--media-video/clive/clive-2.2.4.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/media-video/clive/ChangeLog b/media-video/clive/ChangeLog
index 13440b02f608..f4157fb44dfd 100644
--- a/media-video/clive/ChangeLog
+++ b/media-video/clive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/clive
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.49 2009/08/02 22:56:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.50 2009/08/02 23:00:58 aballier Exp $
+
+*clive-2.2.4 (02 Aug 2009)
+
+ 02 Aug 2009; Alexis Ballier <aballier@gentoo.org> +clive-2.2.4.ebuild:
+ version bump
02 Aug 2009; Alexis Ballier <aballier@gentoo.org> -clive-2.1.11.ebuild,
-clive-2.1.12.ebuild, -clive-2.2.2.ebuild:
diff --git a/media-video/clive/clive-2.2.4.ebuild b/media-video/clive/clive-2.2.4.ebuild
new file mode 100644
index 000000000000..080b256bf9b7
--- /dev/null
+++ b/media-video/clive/clive-2.2.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-2.2.4.ebuild,v 1.1 2009/08/02 23:00:58 aballier Exp $
+
+EAPI=2
+
+inherit perl-app
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://clive.sourceforge.net/"
+SRC_URI="http://clive.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="clipboard pager password"
+
+RDEPEND=">=dev-perl/BerkeleyDB-0.34
+ >=dev-perl/Config-Tiny-2.12
+ >=virtual/perl-Digest-SHA-5.47
+ >=dev-perl/HTML-TokeParser-Simple-2.37
+ >=dev-perl/Class-Singleton-1.4
+ >=dev-perl/WWW-Curl-4.05
+ >=dev-perl/XML-Simple-2.18
+ >=dev-perl/Getopt-ArgvFile-1.11
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ clipboard? ( >=dev-perl/Clipboard-0.09 )
+ pager? ( >=dev-perl/IO-Pager-0.05 )
+ password? ( >=dev-perl/Expect-1.21 )"
+DEPEND=""
+
+SRC_TEST=do
+mydoc="TODO"
+
+src_test() {
+ if [ -z "${I_WANT_CLIVE_HOSTS_TESTS}" ] ; then
+ elog "If you wish to run the full testsuite of ${PN}"
+ elog "Please set the variable 'I_WANT_CLIVE_HOSTS_TESTS' variable"
+ elog "Note that the tests try to download some videos from various websites"
+ elog "and thus may randomly fail depending on the site's status."
+ export NO_INTERNET=1
+ fi
+ perl-module_src_test
+}