summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-05-16 16:12:27 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-05-16 16:12:27 +0000
commitb80db9885e5986fb5258a339f3c75f091457266d (patch)
tree41088d9a8bfad955aa83f445bc16f4d5018b2c6c /media-video/em8300-modules
parentAdd ~sparc (diff)
downloadgentoo-2-b80db9885e5986fb5258a339f3c75f091457266d.tar.gz
gentoo-2-b80db9885e5986fb5258a339f3c75f091457266d.tar.bz2
gentoo-2-b80db9885e5986fb5258a339f3c75f091457266d.zip
Installing modprobe conf file now into /etc/modprobe.d as requested in Bug #214024.
(Portage version: 2.1.5)
Diffstat (limited to 'media-video/em8300-modules')
-rw-r--r--media-video/em8300-modules/ChangeLog9
-rw-r--r--media-video/em8300-modules/em8300-modules-0.16.4-r1.ebuild62
2 files changed, 70 insertions, 1 deletions
diff --git a/media-video/em8300-modules/ChangeLog b/media-video/em8300-modules/ChangeLog
index ce39949cc365..490362bacf2d 100644
--- a/media-video/em8300-modules/ChangeLog
+++ b/media-video/em8300-modules/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/em8300-modules
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/ChangeLog,v 1.45 2008/02/29 10:27:16 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/ChangeLog,v 1.46 2008/05/16 16:12:27 zzam Exp $
+
+*em8300-modules-0.16.4-r1 (16 May 2008)
+
+ 16 May 2008; Matthias Schwarzott <zzam@gentoo.org>
+ +em8300-modules-0.16.4-r1.ebuild:
+ Installing modprobe conf file now into /etc/modprobe.d as requested in Bug
+ #214024.
*em8300-modules-0.16.4 (29 Feb 2008)
diff --git a/media-video/em8300-modules/em8300-modules-0.16.4-r1.ebuild b/media-video/em8300-modules/em8300-modules-0.16.4-r1.ebuild
new file mode 100644
index 000000000000..67799433f7d4
--- /dev/null
+++ b/media-video/em8300-modules/em8300-modules-0.16.4-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/em8300-modules-0.16.4-r1.ebuild,v 1.1 2008/05/16 16:12:27 zzam Exp $
+
+inherit eutils linux-mod
+
+MY_P="${P/-modules/}"
+
+DESCRIPTION="em8300 (RealMagic Hollywood+/Creative DXR3) video decoder card kernel modules"
+HOMEPAGE="http://dxr3.sourceforge.net"
+SRC_URI="mirror://sourceforge/dxr3/${MY_P}.tar.gz"
+
+DEPEND="virtual/linux-sources"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+CONFIG_CHECK="I2C_ALGOBIT"
+MODULE_NAMES="em8300(video:) bt865(video:) adv717x(video:)"
+
+S="${WORKDIR}/${MY_P}/modules"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/.."
+}
+
+src_compile() {
+ set_arch_to_kernel
+ cd "${S}"
+ emake KERNEL_LOCATION="${KERNEL_DIR}" || die "emake failed."
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README-modoptions README-modules.conf
+
+ newsbin devices.sh em8300-devices.sh
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/modules.em8300 em8300
+
+ insinto /etc/udev/rules.d
+ newins em8300-udev.rules 15-em8300.rules
+}
+
+pkg_preinst() {
+ linux-mod_pkg_preinst
+
+ local old="${ROOT}/etc/modules.d/em8300"
+ local new="${ROOT}/etc/modprobe.d/em8300"
+
+ if [[ -a ${old} && ! -a ${new} ]]; then
+ elog "Moving old em8300 configuration in /etc/modules.d to new"
+ elog "location in /etc/modprobe.d"
+ mv "${old}" "${new}"
+ fi
+}
+