summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIoannis Aslanidis <deathwing00@gentoo.org>2008-10-27 19:49:50 +0000
committerIoannis Aslanidis <deathwing00@gentoo.org>2008-10-27 19:49:50 +0000
commit571310632a522fc980d126c6d8b88107c6f9c61f (patch)
tree3544d188a17ea8a8388d90777e9aac477dfc2e34 /media-video/flumotion
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-571310632a522fc980d126c6d8b88107c6f9c61f.tar.gz
gentoo-2-571310632a522fc980d126c6d8b88107c6f9c61f.tar.bz2
gentoo-2-571310632a522fc980d126c6d8b88107c6f9c61f.zip
Version bump. Several fixes to the ebuild together with zaheerm@gentoo.org.
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-video/flumotion')
-rw-r--r--media-video/flumotion/ChangeLog11
-rwxr-xr-xmedia-video/flumotion/files/flumotion-init-0.2.02
-rw-r--r--media-video/flumotion/flumotion-0.5.2.ebuild104
-rw-r--r--media-video/flumotion/metadata.xml8
4 files changed, 122 insertions, 3 deletions
diff --git a/media-video/flumotion/ChangeLog b/media-video/flumotion/ChangeLog
index 837b4c9eb0ff..85011b2f5be1 100644
--- a/media-video/flumotion/ChangeLog
+++ b/media-video/flumotion/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/flumotion
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/ChangeLog,v 1.13 2007/11/27 12:06:46 zzam Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/ChangeLog,v 1.14 2008/10/27 19:49:49 deathwing00 Exp $
+
+ 27 Oct 2008; Ioannis Aslanidis <iaslanidis@gentoo.org>
+ files/flumotion-init-0.2.0, metadata.xml, +flumotion-0.5.2.ebuild:
+ Version bump. Added fix for access violation of gconf. Added missing
+ dependency, dev-python/kiwi. All this done together with zaheerm.
+
+*flumotion-0.5.2 (27 Oct 2008)
27 Nov 2007; Matthias Schwarzott <zzam@gentoo.org> flumotion-0.4.1.ebuild:
Fixed quoting.
diff --git a/media-video/flumotion/files/flumotion-init-0.2.0 b/media-video/flumotion/files/flumotion-init-0.2.0
index 50834f076d2d..de571785ff38 100755
--- a/media-video/flumotion/files/flumotion-init-0.2.0
+++ b/media-video/flumotion/files/flumotion-init-0.2.0
@@ -6,7 +6,7 @@ depend() {
start() {
ebegin "Starting Flumotion"
- HOME=/usr/share/flumotion start-stop-daemon --start --chuid flumotion:flumotion --exec /usr/sbin/flumotion start
+ HOME=/usr/share/flumotion start-stop-daemon -o --start --chuid flumotion:flumotion --exec /usr/sbin/flumotion start
eend $?
}
diff --git a/media-video/flumotion/flumotion-0.5.2.ebuild b/media-video/flumotion/flumotion-0.5.2.ebuild
new file mode 100644
index 000000000000..d29b993e8348
--- /dev/null
+++ b/media-video/flumotion/flumotion-0.5.2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/flumotion/flumotion-0.5.2.ebuild,v 1.1 2008/10/27 19:49:49 deathwing00 Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Flumotion Streaming server"
+HOMEPAGE="http://www.flumotion.net"
+SRC_URI="http://www.flumotion.net/src/flumotion/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+KEYWORDS="~x86 ~amd64"
+IUSE="v4l speex jpeg dv"
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.4
+ >=gnome-base/libglade-2
+ >=media-libs/gstreamer-0.10.11
+ >=media-libs/gst-plugins-base-0.10.11
+ =media-libs/gst-plugins-good-0.10*
+ =media-plugins/gst-plugins-gnomevfs-0.10*
+ =media-plugins/gst-plugins-ogg-0.10*
+ =media-plugins/gst-plugins-theora-0.10*
+ =media-plugins/gst-plugins-vorbis-0.10*
+ =media-plugins/gst-plugins-libpng-0.10*
+ =dev-python/gst-python-0.10*
+ v4l? ( =media-plugins/gst-plugins-v4l-0.10* )
+ speex? ( =media-plugins/gst-plugins-speex-0.10* )
+ dv? ( =media-plugins/gst-plugins-dv-0.10*
+ =media-plugins/gst-plugins-raw1394-0.10* )
+ >=dev-python/pygtk-2.8.6
+ >=dev-python/twisted-2.0
+ >=dev-python/twisted-web-0.5.0-r1
+ >=dev-python/twisted-names-0.2.0
+ dev-python/imaging
+ dev-python/kiwi
+ "
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ "
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL \
+ LICENCE.Flumotion LICENCE.GPL \
+ NEWS README TODO"
+
+src_compile() {
+ addpredict "$(unset HOME; echo ~)/.gconf"
+ addpredict "$(unset HOME; echo ~)/.gconfd"
+ mkdir -p "${T}/home"
+ export HOME="${T}/home"
+ export GST_REGISTRY=${T}/home/registry.cache.xml
+ unset LINGUAS
+ econf --disable-install-schemas --localstatedir=/var || die
+
+ emake || die
+ # fix ${exec_prefix} not being expanded
+ cd "${S}"/bin
+ cp flumotion-manager flumotion-manager.orig
+ sed -e 's:${exec_prefix}:/usr':g flumotion-manager.orig \
+ > flumotion-manager
+ cp flumotion-worker flumotion-worker.orig
+ sed -e 's:${exec_prefix}:/usr':g flumotion-worker.orig \
+ > flumotion-worker
+ cp flumotion-admin flumotion-admin.orig
+ sed -e 's:${exec_prefix}:/usr':g flumotion-admin.orig \
+ > flumotion-admin
+}
+
+src_install() {
+ einstall
+
+ dodir /etc/flumotion
+ dodir /etc/flumotion/managers
+ dodir /etc/flumotion/managers/default
+ dodir /etc/flumotion/managers/default/flows
+ dodir /etc/flumotion/workers
+
+ cd "${S}"/conf
+ insinto /etc/flumotion/managers/default
+ doins managers/default/planet.xml
+ insinto /etc/flumotion/workers
+ doins workers/default.xml
+
+ insinto /etc/flumotion
+ doins default.pem
+ newinitd "${FILESDIR}"/flumotion-init-0.2.0 flumotion
+
+ keepdir /var/run/flumotion
+ keepdir /var/log/flumotion
+}
+
+pkg_postinst() {
+ if ! enewgroup flumotion || ! enewuser flumotion -1 -1 /usr/share/flumotion flumotion,audio,video,sys; then
+ die "Unable to add flumotion user and flumotion group."
+ fi
+
+ for dir in /usr/share/flumotion /var/log/flumotion /var/run/flumotion; do
+ chown -R flumotion:flumotion ${dir}
+ chmod -R 755 ${dir}
+ done
+}
+
diff --git a/media-video/flumotion/metadata.xml b/media-video/flumotion/metadata.xml
index 9e260ceca3e3..64409936b37f 100644
--- a/media-video/flumotion/metadata.xml
+++ b/media-video/flumotion/metadata.xml
@@ -2,4 +2,12 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>gstreamer</herd>
+<maintainer>
+ <email>deathwing00@gentoo.org</email>
+ <name>deathwing00</name>
+</maintainer>
+<maintainer>
+ <email>zaheerm@gentoo.org</email>
+ <name>zaheerm</name>
+</maintainer>
</pkgmetadata>