summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-10-28 10:23:11 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-10-28 10:23:11 +0000
commitdd5d92885665e34bbbf90eae71bffa70265fa6da (patch)
tree8c13497de981bf8e977da7fde71c568f9bfe7f5f /media-video/griffith
parentmore quoting (diff)
downloadgentoo-2-dd5d92885665e34bbbf90eae71bffa70265fa6da.tar.gz
gentoo-2-dd5d92885665e34bbbf90eae71bffa70265fa6da.tar.bz2
gentoo-2-dd5d92885665e34bbbf90eae71bffa70265fa6da.zip
Version bump. Bug 343003
(Portage version: 2.2.0_alpha1/cvs/Linux x86_64)
Diffstat (limited to 'media-video/griffith')
-rw-r--r--media-video/griffith/ChangeLog8
-rw-r--r--media-video/griffith/griffith-0.12.1.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/media-video/griffith/ChangeLog b/media-video/griffith/ChangeLog
index e79b41db473f..50613ca42722 100644
--- a/media-video/griffith/ChangeLog
+++ b/media-video/griffith/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/griffith
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.50 2010/10/23 21:38:06 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.51 2010/10/28 10:23:11 hwoarang Exp $
+
+*griffith-0.12.1 (28 Oct 2010)
+
+ 28 Oct 2010; Markos Chandras <hwoarang@gentoo.org>
+ +griffith-0.12.1.ebuild:
+ Version bump. Bug 343003
23 Oct 2010; Markos Chandras <hwoarang@gentoo.org> +griffith-9999.ebuild:
Initial commit of live ebuild. Moved from my overlay
diff --git a/media-video/griffith/griffith-0.12.1.ebuild b/media-video/griffith/griffith-0.12.1.ebuild
new file mode 100644
index 000000000000..b585a1a91463
--- /dev/null
+++ b/media-video/griffith/griffith-0.12.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-0.12.1.ebuild,v 1.1 2010/10/28 10:23:11 hwoarang Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+
+inherit eutils versionator python multilib
+
+ARTWORK_PV="0.9.4"
+
+DESCRIPTION="Movie collection manager"
+HOMEPAGE="http://griffith.berlios.de/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz
+ mirror://berlios/griffith/${PN}-extra-artwork-${ARTWORK_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="csv doc spell"
+
+RDEPEND="dev-python/imaging
+ gnome-base/libglade
+ dev-python/pyxml
+ >=dev-python/pygtk-2.6.1
+ dev-python/pysqlite:2
+ >=dev-python/sqlalchemy-0.5.2
+ >=dev-python/reportlab-1.19
+ csv? ( dev-python/chardet )
+ spell? ( >=dev-python/gnome-python-extras-2.0 )"
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook2X )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e 's#/pl/#/pl.UTF-8/#' \
+ "${S}"/docs/pl/Makefile || die "sed failed"
+
+ sed -i \
+ -e 's/ISO-8859-1/UTF-8/' \
+ "${S}"/lib/gconsole.py || die "sed failed"
+ epatch "${FILESDIR}/0.10-fix_lib_path.patch"
+}
+
+src_compile() {
+ # Nothing to compile and default `emake` spews an error message
+ true
+}
+
+src_install() {
+ use doc || sed -i -e '/docs/d' Makefile
+
+ emake \
+ LIBDIR="${D}/usr/$(get_libdir)/griffith" \
+ DESTDIR="${D}" DOC2MAN=docbook2man.pl install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README THANKS TODO NEWS TRANSLATORS
+
+ cd "${WORKDIR}/${PN}-extra-artwork-${ARTWORK_PV}/"
+ emake DESTDIR="${D}" install || die "emake install artwork failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}