summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-11-29 09:38:47 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-11-29 09:38:47 +0000
commit49928bc2db343a2fae3b605125291ed82baa5e12 (patch)
tree61d86e4f7e362661799391103b027596ed4cee8a /media-video/istanbul
parentBump (diff)
downloadgentoo-2-49928bc2db343a2fae3b605125291ed82baa5e12.tar.gz
gentoo-2-49928bc2db343a2fae3b605125291ed82baa5e12.tar.bz2
gentoo-2-49928bc2db343a2fae3b605125291ed82baa5e12.zip
Fix build failure with recent automake (bug #407683, thanks to Helmut Jarausch et al.) Add git snapshot containing numerous serious bug fixes, and some further fixes from the Debian patchset.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'media-video/istanbul')
-rw-r--r--media-video/istanbul/ChangeLog15
-rw-r--r--media-video/istanbul/files/istanbul-0.2.2-desktop-file.patch18
-rw-r--r--media-video/istanbul/files/istanbul-0.2.2-dir-overwrite.patch31
-rw-r--r--media-video/istanbul/files/istanbul-0.2.2-fix-grab-xid.patch36
-rw-r--r--media-video/istanbul/files/istanbul-0.2.2-fix-preview-window.patch23
-rw-r--r--media-video/istanbul/files/istanbul-0.2.2-noalsa.patch17
-rw-r--r--media-video/istanbul/istanbul-0.2.2.1_pre20120909.ebuild83
-rw-r--r--media-video/istanbul/istanbul-0.2.2.ebuild17
8 files changed, 229 insertions, 11 deletions
diff --git a/media-video/istanbul/ChangeLog b/media-video/istanbul/ChangeLog
index d5aa4453b09b..bf18b9e50597 100644
--- a/media-video/istanbul/ChangeLog
+++ b/media-video/istanbul/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for media-video/istanbul
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/ChangeLog,v 1.20 2012/10/25 20:50:59 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/ChangeLog,v 1.21 2012/11/29 09:38:47 tetromino Exp $
+
+*istanbul-0.2.2.1_pre20120909 (29 Nov 2012)
+
+ 29 Nov 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ istanbul-0.2.2.ebuild, +istanbul-0.2.2.1_pre20120909.ebuild,
+ +files/istanbul-0.2.2-desktop-file.patch,
+ +files/istanbul-0.2.2-dir-overwrite.patch,
+ +files/istanbul-0.2.2-fix-grab-xid.patch,
+ +files/istanbul-0.2.2-fix-preview-window.patch,
+ +files/istanbul-0.2.2-noalsa.patch:
+ Fix build failure with recent automake (bug #407683, thanks to Helmut
+ Jarausch et al.) Add git snapshot containing numerous serious bug fixes, and
+ some further fixes from the Debian patchset.
25 Oct 2012; Gilles Dartiguelongue <eva@gentoo.org> istanbul-0.2.2.ebuild:
Pin gstreamer dependencies to slot 0.10.
diff --git a/media-video/istanbul/files/istanbul-0.2.2-desktop-file.patch b/media-video/istanbul/files/istanbul-0.2.2-desktop-file.patch
new file mode 100644
index 000000000000..b71df11077c2
--- /dev/null
+++ b/media-video/istanbul/files/istanbul-0.2.2-desktop-file.patch
@@ -0,0 +1,18 @@
+diff --git a/data/istanbul.desktop.in b/data/istanbul.desktop.in
+index 4235410..a1b5772 100644
+--- a/data/istanbul.desktop.in
++++ b/data/istanbul.desktop.in
+@@ -1,11 +1,10 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ _Name=Istanbul Desktop Session Recorder
+ _GenericName=Desktop Session Recorder
+ _Comment=Record a video of your desktop session
+ Exec=istanbul
+ Terminal=false
+ Type=Application
+-Icon=istanbul.png
+-Categories=GNOME;Application;AudioVideo;
++Icon=istanbul
++Categories=GTK;GNOME;AudioVideo;
+ StartupNotify=false
diff --git a/media-video/istanbul/files/istanbul-0.2.2-dir-overwrite.patch b/media-video/istanbul/files/istanbul-0.2.2-dir-overwrite.patch
new file mode 100644
index 000000000000..c5873874d3c2
--- /dev/null
+++ b/media-video/istanbul/files/istanbul-0.2.2-dir-overwrite.patch
@@ -0,0 +1,31 @@
+From: Luca Bruno <lucab@debian.org>
+Subject: istanbul: saving screencasts can overwrite directories
+Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=592258
+
+diff --git a/istanbul/main/save_window.py b/istanbul/main/save_window.py
+index dc79ce8..87e5ab0 100644
+--- a/istanbul/main/save_window.py
++++ b/istanbul/main/save_window.py
+@@ -256,7 +256,7 @@ class SaveWindow(gtk.Window):
+ try:
+ trysave = gnomevfs.xfer_uri(gnomevfs.URI("file://%s" % self.location),
+ gnomevfs.URI(self.filechooser.get_uri()),
+- gnomevfs.XFER_DELETE_ITEMS,
++ gnomevfs.XFER_REMOVESOURCE,
+ gnomevfs.XFER_ERROR_MODE_ABORT,
+ gnomevfs.XFER_OVERWRITE_MODE_ABORT)
+ except gnomevfs.FileExistsError:
+@@ -272,10 +272,12 @@ class SaveWindow(gtk.Window):
+ dialog.hide()
+ if res == gtk.RESPONSE_YES:
+ try:
++ if os.path.isdir(self.filechooser.get_uri()[7:]):
++ raise Exception()
+ trysave = gnomevfs.xfer_uri(
+ gnomevfs.URI("file://%s" % self.location),
+ gnomevfs.URI(self.filechooser.get_uri()),
+- gnomevfs.XFER_DELETE_ITEMS,
++ gnomevfs.XFER_REMOVESOURCE,
+ gnomevfs.XFER_ERROR_MODE_ABORT,
+ gnomevfs.XFER_OVERWRITE_MODE_REPLACE)
+ except Exception:
diff --git a/media-video/istanbul/files/istanbul-0.2.2-fix-grab-xid.patch b/media-video/istanbul/files/istanbul-0.2.2-fix-grab-xid.patch
new file mode 100644
index 000000000000..95f534aca284
--- /dev/null
+++ b/media-video/istanbul/files/istanbul-0.2.2-fix-grab-xid.patch
@@ -0,0 +1,36 @@
+From: Jef Spaleta <jspaleta@gmail.com>
+Subject: Try to get the xid on realization of the videowidget
+Origin: upstream
+Bug: https://bugzilla.gnome.org/show_bug.cgi?id=604938
+Bug-Debian: http://bugs.debian.org/554568
+
+Index: istanbul-0.2.2/istanbul/main/save_window.py
+===================================================================
+--- istanbul-0.2.2.orig/istanbul/main/save_window.py 2010-07-08 10:38:56.609390459 +0200
++++ istanbul-0.2.2/istanbul/main/save_window.py 2010-07-08 10:38:53.153107943 +0200
+@@ -35,8 +35,13 @@
+ def __init__(self):
+ gtk.DrawingArea.__init__(self)
+ self.imagesink = None
++ self._xid = None
+ self.unset_flags(gtk.DOUBLE_BUFFERED)
+
++ def do_realize(self):
++ gtk.DrawingArea.do_realize(self)
++ self._xid = self.window.xid
++
+ def do_expose_event(self, event):
+ if self.imagesink:
+ self.imagesink.expose()
+@@ -45,9 +50,9 @@
+ return True
+
+ def set_sink(self, sink):
+- assert self.window.xid
++ assert self._xid is not None
+ self.imagesink = sink
+- self.imagesink.set_xwindow_id(self.window.xid)
++ self.imagesink.set_xwindow_id(self._xid)
+
+ class SaveWindow(gtk.Window):
+ UPDATE_INTERVAL = 500
diff --git a/media-video/istanbul/files/istanbul-0.2.2-fix-preview-window.patch b/media-video/istanbul/files/istanbul-0.2.2-fix-preview-window.patch
new file mode 100644
index 000000000000..181c0622e41b
--- /dev/null
+++ b/media-video/istanbul/files/istanbul-0.2.2-fix-preview-window.patch
@@ -0,0 +1,23 @@
+From: Jef Spaleta <jspaleta@gmail.com>
+Subject: Additional patch to fix preview video widget in save_window.py
+Origin: upstream
+Bug: https://bugzilla.gnome.org/show_bug.cgi?id=604938
+Bug-Debian: http://bugs.debian.org/554568
+
+Index: istanbul-0.2.2/istanbul/main/save_window.py
+===================================================================
+--- istanbul-0.2.2.orig/istanbul/main/save_window.py 2010-07-08 10:39:51.433390429 +0200
++++ istanbul-0.2.2/istanbul/main/save_window.py 2010-07-08 10:39:49.184894943 +0200
+@@ -143,8 +143,11 @@
+ yoptions=0)
+ table.set_row_spacing(0,6)
+ table.set_row_spacing(1,6)
++ def init_videowidget( widget):
++ widget._xid = widget.window.xid
++ self.player.pause()
+ self.videowidget.connect_after('realize',
+- lambda *x: self.player.pause() )
++ init_videowidget )
+ self.videowidget.set_size_request(width, height)
+
+ # create save, edit, cancel buttons
diff --git a/media-video/istanbul/files/istanbul-0.2.2-noalsa.patch b/media-video/istanbul/files/istanbul-0.2.2-noalsa.patch
new file mode 100644
index 000000000000..772dc700c777
--- /dev/null
+++ b/media-video/istanbul/files/istanbul-0.2.2-noalsa.patch
@@ -0,0 +1,17 @@
+From: Luca Bruno <lucab@debian.org>
+Subject: istanbul: Uninstallable on kfreebsd-* (depends on gstreamer0.10-alsa)
+Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=591739
+
+Index: istanbul-0.2.2/istanbul/main/screencast.py
+===================================================================
+--- istanbul-0.2.2.orig/istanbul/main/screencast.py 2010-08-17 11:38:02.898762661 +0200
++++ istanbul-0.2.2/istanbul/main/screencast.py 2010-08-17 11:38:51.154511463 +0200
+@@ -95,7 +95,7 @@
+ if Preferences().has_gconf():
+ asource = 'gconfaudiosrc name=audiosource'
+ else:
+- asource = 'alsasrc name=audiosource'
++ asource = 'autoaudiosrc name=audiosource'
+ acappipeline = '%s ! audioconvert ! vorbisenc' % asource
+
+ vencode_pipeline = 'video/x-raw-yuv,width=%d,height=%d,framerate=%s '\
diff --git a/media-video/istanbul/istanbul-0.2.2.1_pre20120909.ebuild b/media-video/istanbul/istanbul-0.2.2.1_pre20120909.ebuild
new file mode 100644
index 000000000000..33aae917ce2e
--- /dev/null
+++ b/media-video/istanbul/istanbul-0.2.2.1_pre20120909.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/istanbul-0.2.2.1_pre20120909.ebuild,v 1.1 2012/11/29 09:38:47 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="2"
+
+inherit eutils gnome2 python autotools
+
+HOMEPAGE="http://live.gnome.org/Istanbul"
+DESCRIPTION="Istanbul is a screencast application for the Unix desktop"
+#SRC_URI="http://zaheer.merali.org/${P}.tar.bz2"
+SRC_URI="http://dev.gentoo.org/~tetromino/distfiles/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2" # Note: not GPL-2+
+SLOT=0
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.8:0.10
+ >=dev-python/pygtk-2.6
+ >=gnome-base/gconf-2
+ dev-python/gst-python:0.10
+ media-plugins/gst-plugins-ogg:0.10
+ media-plugins/gst-plugins-theora:0.10
+ >=media-libs/libtheora-1.0_alpha6[encode]
+ media-plugins/gst-plugins-gconf:0.10
+ dev-python/python-xlib
+
+ >=dev-python/egg-python-2.11.3
+ >=dev-python/gnome-vfs-python-2
+ >=dev-python/gconf-python-2"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-0.2.2.1"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_clean_py-compile_files
+ cp py-compile common/py-compile-destdir || die
+
+ # .desktop file validation failures
+ epatch "${FILESDIR}/${PN}-0.2.2-desktop-file.patch"
+
+ # important Debian patches
+ epatch "${FILESDIR}/${PN}-0.2.2-fix-grab-xid.patch"
+ epatch "${FILESDIR}/${PN}-0.2.2-fix-preview-window.patch"
+ epatch "${FILESDIR}/${PN}-0.2.2-dir-overwrite.patch"
+ epatch "${FILESDIR}/${PN}-0.2.2-noalsa.patch"
+
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ mkdir -p "${T}/home"
+ export HOME="${T}/home"
+ export GST_REGISTRY=${T}/home/registry.cache.xml
+ addpredict /root/.gconfd
+ addpredict /root/.gconf
+ addpredict /root/.gnome2
+
+ gnome2_src_configure
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize istanbul
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup istanbul
+}
diff --git a/media-video/istanbul/istanbul-0.2.2.ebuild b/media-video/istanbul/istanbul-0.2.2.ebuild
index db286be3e511..68d82b4967bd 100644
--- a/media-video/istanbul/istanbul-0.2.2.ebuild
+++ b/media-video/istanbul/istanbul-0.2.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/istanbul-0.2.2.ebuild,v 1.10 2012/10/25 20:50:59 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/istanbul-0.2.2.ebuild,v 1.11 2012/11/29 09:38:47 tetromino Exp $
-EAPI="3"
+EAPI="5"
GCONF_DEBUG="no"
PYTHON_DEPEND="2"
@@ -12,7 +12,7 @@ HOMEPAGE="http://live.gnome.org/Istanbul"
DESCRIPTION="Istanbul is a screencast application for the Unix desktop"
SRC_URI="http://zaheer.merali.org/${P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2" # Note: not GPL-2+
SLOT=0
KEYWORDS="~amd64 ~x86"
IUSE=""
@@ -40,18 +40,15 @@ pkg_setup() {
}
src_prepare() {
- gnome2_src_prepare
-
- # disable pyc compiling
- mv py-compile py-compile.orig
- ln -s $(type -P true) py-compile
- echo "py_compile = $(type -P true)" > common/python.mk
+ python_clean_py-compile_files
+ cp py-compile common/py-compile-destdir || die
# fix autoreconf failure, bug #230325
epatch "${FILESDIR}/${P}-macro-typo.patch"
- intltoolize --force --copy --automake || die "intltoolize failed"
eautoreconf
+
+ gnome2_src_prepare
}
src_configure() {