summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-06-23 09:09:45 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-06-23 09:09:45 +0000
commit0f78f5511f7246c0daed543d6524eb13e83b6f0e (patch)
tree62a732d71963835845077565db8c33f22a00f7e3 /media-video/libav/libav-9999.ebuild
parentremove myself from metadata (diff)
downloadgentoo-2-0f78f5511f7246c0daed543d6524eb13e83b6f0e.tar.gz
gentoo-2-0f78f5511f7246c0daed543d6524eb13e83b6f0e.tar.bz2
gentoo-2-0f78f5511f7246c0daed543d6524eb13e83b6f0e.zip
Drop no longer workaround for march=native. Fixes bug#458768.
(Portage version: 2.2.0_alpha184/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'media-video/libav/libav-9999.ebuild')
-rw-r--r--media-video/libav/libav-9999.ebuild13
1 files changed, 1 insertions, 12 deletions
diff --git a/media-video/libav/libav-9999.ebuild b/media-video/libav/libav-9999.ebuild
index bd38b92be3dc..156c36cc69fa 100644
--- a/media-video/libav/libav-9999.ebuild
+++ b/media-video/libav/libav-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/libav/libav-9999.ebuild,v 1.59 2013/06/13 12:40:39 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/libav/libav-9999.ebuild,v 1.60 2013/06/23 09:09:45 scarabeus Exp $
EAPI=5
@@ -227,17 +227,6 @@ src_configure() {
# Option to force building pic
use pic && myconf+=" --enable-pic"
- # Try to get cpu type based on CFLAGS.
- # Bug #172723
- # We need to do this so that features of that CPU will be better used
- # If they contain an unknown CPU it will not hurt since configure
- # will just ignore it.
- for i in $(get-flag march) $(get-flag mcpu) $(get-flag mtune) ; do
- [[ "${i}" == "native" ]] && i="host" # bug #273421
- myconf+=" --cpu=${i}"
- break
- done
-
# cross compile support
if tc-is-cross-compiler ; then
myconf+=" --enable-cross-compile --arch=$(tc-arch-kernel) --cross-prefix=${CHOST}-"