summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-03-27 14:42:22 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-03-27 14:42:22 +0000
commit79efbc34d6223ced961ef9784ed89f0a73cd7347 (patch)
treefd2ceb8b877c63617e28f1ced8a5a7a2cd89611c /media-video/libav
parentMarking imagemagick-6.6.8.5 ~ppc for bug 359963 (diff)
downloadgentoo-2-79efbc34d6223ced961ef9784ed89f0a73cd7347.tar.gz
gentoo-2-79efbc34d6223ced961ef9784ed89f0a73cd7347.tar.bz2
gentoo-2-79efbc34d6223ced961ef9784ed89f0a73cd7347.zip
Fixup version settings in snapshot. Remove useless quoting. Handle branching magically.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'media-video/libav')
-rw-r--r--media-video/libav/ChangeLog7
-rw-r--r--media-video/libav/libav-0.6.9999.ebuild10
-rw-r--r--media-video/libav/libav-0.7_pre20110327.ebuild9
-rw-r--r--media-video/libav/libav-9999.ebuild9
4 files changed, 21 insertions, 14 deletions
diff --git a/media-video/libav/ChangeLog b/media-video/libav/ChangeLog
index b9c36f6dc3ba..17825590c180 100644
--- a/media-video/libav/ChangeLog
+++ b/media-video/libav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/libav
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/libav/ChangeLog,v 1.5 2011/03/27 14:32:55 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/libav/ChangeLog,v 1.6 2011/03/27 14:42:22 scarabeus Exp $
+
+ 27 Mar 2011; Tomáš Chvátal <scarabeus@gentoo.org> libav-0.6.9999.ebuild,
+ libav-0.7_pre20110327.ebuild, libav-9999.ebuild:
+ Fixup version settings in snapshot. Remove useless quoting. Handle branching
+ magically.
*libav-0.7_pre20110327 (27 Mar 2011)
diff --git a/media-video/libav/libav-0.6.9999.ebuild b/media-video/libav/libav-0.6.9999.ebuild
index d852b03da1a8..9e66c9058492 100644
--- a/media-video/libav/libav-0.6.9999.ebuild
+++ b/media-video/libav/libav-0.6.9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/libav/libav-0.6.9999.ebuild,v 1.3 2011/03/27 14:11:07 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/libav/libav-0.6.9999.ebuild,v 1.4 2011/03/27 14:42:22 scarabeus Exp $
EAPI=4
if [[ ${PV} == *9999 ]] ; then
SCM="git"
EGIT_REPO_URI="git://git.libav.org/libav.git"
- EGIT_BRANCH="release/0.6"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
fi
inherit eutils flag-o-matic multilib toolchain-funcs ${SCM}
@@ -16,7 +16,7 @@ DESCRIPTION="Complete solution to record, convert and stream audio and video."
HOMEPAGE="http://libav.org/"
if [[ ${PV} == *9999 ]] ; then
SRC_URI=""
-elif [[ "${PV%_p*}" != "${PV}" ]] ; then # Gentoo snapshot
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
SRC_URI="mirror://gentoo/${P}.tar.xz"
else # Official release
SRC_URI="http://${PN}.org/releases/${P}.tar.bz2"
@@ -79,8 +79,8 @@ REQUIRED_USE="bindist? ( !faac )"
src_prepare() {
# if we have snapshot then we need to hardcode the version
- if [[ "${PV%_p*}" != "${PV}" ]]; then
- sed -i -e "s/UNKNOWN/GIT-r${PV#*_p}/" "${S}/version.sh" || die
+ if [[ ${PV%_p*} != ${PV} ]]; then
+ sed -i -e "s/UNKNOWN/DATE-${PV#*_pre}/" "${S}/version.sh" || die
fi
}
diff --git a/media-video/libav/libav-0.7_pre20110327.ebuild b/media-video/libav/libav-0.7_pre20110327.ebuild
index 6eb2d7304b93..2c1c10a4cbad 100644
--- a/media-video/libav/libav-0.7_pre20110327.ebuild
+++ b/media-video/libav/libav-0.7_pre20110327.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/libav/libav-0.7_pre20110327.ebuild,v 1.1 2011/03/27 14:32:55 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/libav/libav-0.7_pre20110327.ebuild,v 1.2 2011/03/27 14:42:22 scarabeus Exp $
EAPI=4
if [[ ${PV} == *9999 ]] ; then
SCM="git"
EGIT_REPO_URI="git://git.libav.org/libav.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
fi
inherit eutils flag-o-matic multilib toolchain-funcs ${SCM}
@@ -15,7 +16,7 @@ DESCRIPTION="Complete solution to record, convert and stream audio and video."
HOMEPAGE="http://libav.org/"
if [[ ${PV} == *9999 ]] ; then
SRC_URI=""
-elif [[ "${PV%_p*}" != "${PV}" ]] ; then # Gentoo snapshot
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
SRC_URI="mirror://gentoo/${P}.tar.xz"
else # Official release
SRC_URI="http://${PN}.org/releases/${P}.tar.bz2"
@@ -78,8 +79,8 @@ REQUIRED_USE="bindist? ( !faac )"
src_prepare() {
# if we have snapshot then we need to hardcode the version
- if [[ "${PV%_p*}" != "${PV}" ]]; then
- sed -i -e "s/UNKNOWN/GIT-r${PV#*_p}/" "${S}/version.sh" || die
+ if [[ ${PV%_p*} != ${PV} ]]; then
+ sed -i -e "s/UNKNOWN/DATE-${PV#*_pre}/" "${S}/version.sh" || die
fi
}
diff --git a/media-video/libav/libav-9999.ebuild b/media-video/libav/libav-9999.ebuild
index 9d3bda189244..cc9e44df52f3 100644
--- a/media-video/libav/libav-9999.ebuild
+++ b/media-video/libav/libav-9999.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/libav/libav-9999.ebuild,v 1.3 2011/03/27 14:11:07 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/libav/libav-9999.ebuild,v 1.4 2011/03/27 14:42:22 scarabeus Exp $
EAPI=4
if [[ ${PV} == *9999 ]] ; then
SCM="git"
EGIT_REPO_URI="git://git.libav.org/libav.git"
+ [[ ${PV%9999} != "" ]] && EGIT_BRANCH="release/${PV%.9999}"
fi
inherit eutils flag-o-matic multilib toolchain-funcs ${SCM}
@@ -15,7 +16,7 @@ DESCRIPTION="Complete solution to record, convert and stream audio and video."
HOMEPAGE="http://libav.org/"
if [[ ${PV} == *9999 ]] ; then
SRC_URI=""
-elif [[ "${PV%_p*}" != "${PV}" ]] ; then # Gentoo snapshot
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
SRC_URI="mirror://gentoo/${P}.tar.xz"
else # Official release
SRC_URI="http://${PN}.org/releases/${P}.tar.bz2"
@@ -78,8 +79,8 @@ REQUIRED_USE="bindist? ( !faac )"
src_prepare() {
# if we have snapshot then we need to hardcode the version
- if [[ "${PV%_p*}" != "${PV}" ]]; then
- sed -i -e "s/UNKNOWN/GIT-r${PV#*_p}/" "${S}/version.sh" || die
+ if [[ ${PV%_p*} != ${PV} ]]; then
+ sed -i -e "s/UNKNOWN/DATE-${PV#*_pre}/" "${S}/version.sh" || die
fi
}