summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-01-06 19:18:54 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-01-06 19:18:54 +0000
commit1d96771fb755a3b1c4210d1439a02b840b37a8dd (patch)
treeeb0f6d23177a5713659a6fdca6c74f136215a031 /media-video/minitube
parentalpha/ia64/sparc stable wrt #389255 (diff)
downloadgentoo-2-1d96771fb755a3b1c4210d1439a02b840b37a8dd.tar.gz
gentoo-2-1d96771fb755a3b1c4210d1439a02b840b37a8dd.tar.bz2
gentoo-2-1d96771fb755a3b1c4210d1439a02b840b37a8dd.zip
Version bump. Bug #397783
(Portage version: 2.2.0_alpha82/cvs/Linux x86_64)
Diffstat (limited to 'media-video/minitube')
-rw-r--r--media-video/minitube/ChangeLog9
-rw-r--r--media-video/minitube/minitube-1.7.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/media-video/minitube/ChangeLog b/media-video/minitube/ChangeLog
index 404280c06ef2..d5bf0fcf23f0 100644
--- a/media-video/minitube/ChangeLog
+++ b/media-video/minitube/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/minitube
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/minitube/ChangeLog,v 1.61 2011/11/02 14:45:46 phajdan.jr Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/minitube/ChangeLog,v 1.62 2012/01/06 19:18:54 hwoarang Exp $
+
+*minitube-1.7 (06 Jan 2012)
+
+ 06 Jan 2012; Markos Chandras <hwoarang@gentoo.org> +minitube-1.7.ebuild:
+ Version bump. Bug #397783
02 Nov 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> minitube-1.6.ebuild:
x86 stable wrt bug #388867
diff --git a/media-video/minitube/minitube-1.7.ebuild b/media-video/minitube/minitube-1.7.ebuild
new file mode 100644
index 000000000000..aab78dd0dde1
--- /dev/null
+++ b/media-video/minitube/minitube-1.7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/minitube/minitube-1.7.ebuild,v 1.1 2012/01/06 19:18:54 hwoarang Exp $
+
+EAPI="4"
+LANGS="ca da es es_AR es_ES el fr gl hr hu ia id it nb nl pl pt pt_BR ro
+ru sl sq sr sv_SE te tr zh_CN"
+LANGSLONG="ca_ES de_DE fi_FI he_IL id_ID ka_GE pl_PL uk_UA"
+
+inherit qt4-r2
+
+DESCRIPTION="Qt4 YouTube Client"
+HOMEPAGE="http://flavio.tordini.org/minitube"
+SRC_URI="http://flavio.tordini.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug kde gstreamer"
+
+DEPEND="x11-libs/qt-gui:4[accessibility]
+ x11-libs/qt-dbus:4
+ kde? ( || ( media-libs/phonon[gstreamer?] x11-libs/qt-phonon:4 ) )
+ !kde? ( || ( x11-libs/qt-phonon media-libs/phonon[gstreamer?] ) )
+ gstreamer? (
+ media-plugins/gst-plugins-soup
+ media-plugins/gst-plugins-ffmpeg
+ media-plugins/gst-plugins-faac
+ media-plugins/gst-plugins-faad
+ )
+"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ newicon images/app.png minitube.png
+ #translations
+ insinto "/usr/share/${PN}/locale/"
+ for x in ${LANGS}; do
+ if ! has ${x} ${LINGUAS}; then
+ rm "${D}"/usr/share/${PN}/locale/${x}.qm || die
+ fi
+ done
+ for x in ${LANGSLONG}; do
+ if ! has ${x%_*} ${LINGUAS}; then
+ rm "${D}"/usr/share/${PN}/locale/${x}.qm || die
+ fi
+ done
+}