summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2002-10-28 01:36:32 +0000
committerZack Welch <zwelch@gentoo.org>2002-10-28 01:36:32 +0000
commitd98833db5636fe860aeba1bb421e12a5a585b84f (patch)
treecd106e85f5b80bf25a637dc809a85e48fc1a9ca4 /media-video/w3cam
parentNew version (diff)
downloadgentoo-2-d98833db5636fe860aeba1bb421e12a5a585b84f.tar.gz
gentoo-2-d98833db5636fe860aeba1bb421e12a5a585b84f.tar.bz2
gentoo-2-d98833db5636fe860aeba1bb421e12a5a585b84f.zip
fixes for w3cam ebuild
Diffstat (limited to 'media-video/w3cam')
-rw-r--r--media-video/w3cam/ChangeLog5
-rw-r--r--media-video/w3cam/w3cam-0.7.2.ebuild20
2 files changed, 15 insertions, 10 deletions
diff --git a/media-video/w3cam/ChangeLog b/media-video/w3cam/ChangeLog
index defa360d81db..6353462d44ca 100644
--- a/media-video/w3cam/ChangeLog
+++ b/media-video/w3cam/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for media-video/w3cam
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/w3cam/ChangeLog,v 1.1 2002/10/24 07:10:09 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/w3cam/ChangeLog,v 1.2 2002/10/28 01:36:32 zwelch Exp $
*w3cam-0.7.2-r1 (23 Oct 2002)
+ 25 Oct 2002; Zach Welch <zwelch@gentoo.org> :
+ fix use flags, add IUSE
+
24 Oct 2002; Zach Welch <zwelch@gentoo.org> :
minor cleanup of ebuild and commit to CVS
diff --git a/media-video/w3cam/w3cam-0.7.2.ebuild b/media-video/w3cam/w3cam-0.7.2.ebuild
index f4045e0dd934..479cde16ad34 100644
--- a/media-video/w3cam/w3cam-0.7.2.ebuild
+++ b/media-video/w3cam/w3cam-0.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/w3cam/w3cam-0.7.2.ebuild,v 1.1 2002/10/24 07:10:09 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/w3cam/w3cam-0.7.2.ebuild,v 1.2 2002/10/28 01:36:32 zwelch Exp $
#
# You can set the default device that vidcat and w3camd use by setting
@@ -10,6 +10,8 @@
# W3CAM_DEVICE="/dev/video0" emerge w3cam
#
+IUSE="truetype"
+
S=${WORKDIR}/${P}
DESCRIPTION="w3cam - a set of small programs to grab images and videos from video4linux devices"
HOMEPAGE="http://mpx.freeshell.org/"
@@ -18,19 +20,19 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86"
DEPEND="virtual/glibc \
- zlib? sys-libs/zlib \
- jpeg? media-libs/jpeg \
- png? media-libs/libpng \
- truetype? media-libs/freetype"
+ sys-libs/zlib \
+ media-libs/jpeg \
+ media-libs/libpng \
+ truetype? ( media-libs/freetype )"
src_compile() {
local myconf
- test -z ${W3CAM_DEVICE} \
- || myconf="${myconf} --with-device=${W3CAM_DEVICE}"
+ test -n "${W3CAM_DEVICE}" && \
+ myconf="${myconf} --with-device=${W3CAM_DEVICE}"
- use truetype \
- || myconf="${myconf} --with-ttf-inc=/usr/include/freetype"
+ use truetype && \
+ myconf="${myconf} --with-ttf-inc=/usr/include/freetype"
./configure \
--host=${CHOST} \