summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-03-26 00:58:34 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-03-26 00:58:34 +0000
commite98ebc81255996353bc37e2f99f9e04896846290 (patch)
tree93d402e91d3412caddc4de4dae2a3ad1f8df32ce /media-video/xine-ui
parentset to stable on ppc and x86 (diff)
downloadgentoo-2-e98ebc81255996353bc37e2f99f9e04896846290.tar.gz
gentoo-2-e98ebc81255996353bc37e2f99f9e04896846290.tar.bz2
gentoo-2-e98ebc81255996353bc37e2f99f9e04896846290.zip
Version bump.
Diffstat (limited to 'media-video/xine-ui')
-rw-r--r--media-video/xine-ui/ChangeLog7
-rw-r--r--media-video/xine-ui/files/digest-xine-ui-0.9.201
-rw-r--r--media-video/xine-ui/xine-ui-0.9.20.ebuild65
3 files changed, 72 insertions, 1 deletions
diff --git a/media-video/xine-ui/ChangeLog b/media-video/xine-ui/ChangeLog
index 8fc0f7c93060..17b81d3486bb 100644
--- a/media-video/xine-ui/ChangeLog
+++ b/media-video/xine-ui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/xine-ui
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.28 2003/03/12 20:16:18 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.29 2003/03/26 00:58:34 agenkin Exp $
+
+*xine-ui-0.9.20 (25 Mar 2003)
+
+ 25 Mar 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Version bump.
*xine-ui-0.9.19 (09 Mar 2003)
diff --git a/media-video/xine-ui/files/digest-xine-ui-0.9.20 b/media-video/xine-ui/files/digest-xine-ui-0.9.20
new file mode 100644
index 000000000000..eed3d9421bb9
--- /dev/null
+++ b/media-video/xine-ui/files/digest-xine-ui-0.9.20
@@ -0,0 +1 @@
+MD5 423d63732d18d3246e31e849b1650de8 xine-ui-0.9.20.tar.gz 2460849
diff --git a/media-video/xine-ui/xine-ui-0.9.20.ebuild b/media-video/xine-ui/xine-ui-0.9.20.ebuild
new file mode 100644
index 000000000000..3e9ea3ababb3
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.9.20.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.20.ebuild,v 1.1 2003/03/26 00:58:34 agenkin Exp $
+
+DESCRIPTION="Skinned front end for Xine movie player."
+HOMEPAGE="http://xine.sourceforge.net/"
+LICENSE="GPL-2"
+
+DEPEND="media-libs/libpng
+ >=media-libs/xine-lib-1_beta9
+ >=net-ftp/curl-7.10.2
+ lirc? ( app-misc/lirc )
+ X? ( virtual/x11 )
+ aalib? ( media-libs/aalib )
+ gnome? ( gnome-base/ORBit )
+ directfb? ( media-libs/aalib
+ >=dev-libs/DirectFB-0.9.9 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+IUSE="X aalib gnome nls directfb lirc"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+S=${WORKDIR}/${P}
+SRC_URI="mirror://sourceforge/xine/${P}.tar.gz"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ #patch -p1 < ${FILESDIR}/xine-ui-configure.patch || die "patch failed"
+
+ use directfb || ( \
+ sed -e "s:dfb::" src/Makefile.in \
+ > src/Makefile.in.hacked
+ mv src/Makefile.in.hacked src/Makefile.in
+ )
+
+ sed -e "s:LDFLAGS =:LDFLAGS = -L/lib:" src/xitk/Makefile.in \
+ > src/xitk/Makefile.in.hacked
+ mv src/xitk/Makefile.in.hacked src/xitk/Makefile.in
+
+}
+
+src_compile() {
+
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}