summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-16 19:32:17 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-16 19:32:17 +0000
commit14992e53d83cc8e34e8772adc99fba07dddd2f82 (patch)
tree250d704ed6081354e250e9a2721100613334d59d /media-video
parentThis was already keyworded but only for 1.0.3, breaking repoman due dropping ... (diff)
downloadgentoo-2-14992e53d83cc8e34e8772adc99fba07dddd2f82.tar.gz
gentoo-2-14992e53d83cc8e34e8772adc99fba07dddd2f82.tar.bz2
gentoo-2-14992e53d83cc8e34e8772adc99fba07dddd2f82.zip
Version bump
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/cheese/ChangeLog7
-rw-r--r--media-video/cheese/cheese-3.8.1.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/media-video/cheese/ChangeLog b/media-video/cheese/ChangeLog
index fbfc35649ff1..bcaf11127950 100644
--- a/media-video/cheese/ChangeLog
+++ b/media-video/cheese/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/cheese
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cheese/ChangeLog,v 1.69 2013/03/28 17:43:59 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cheese/ChangeLog,v 1.70 2013/04/16 19:32:17 pacho Exp $
+
+*cheese-3.8.1 (16 Apr 2013)
+
+ 16 Apr 2013; Pacho Ramos <pacho@gentoo.org> +cheese-3.8.1.ebuild:
+ Version bump
*cheese-3.8.0 (28 Mar 2013)
diff --git a/media-video/cheese/cheese-3.8.1.ebuild b/media-video/cheese/cheese-3.8.1.ebuild
new file mode 100644
index 000000000000..847828f32a02
--- /dev/null
+++ b/media-video/cheese/cheese-3.8.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/cheese/cheese-3.8.1.ebuild,v 1.1 2013/04/16 19:32:17 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.18"
+
+inherit eutils gnome2 multilib vala virtualx
+
+DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
+HOMEPAGE="http://projects.gnome.org/cheese/"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = libcheese soname version
+IUSE="+introspection sendto test"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-3.4.4:3[introspection?]
+ >=x11-libs/cairo-1.10:=
+ >=x11-libs/pango-1.28.0
+ >=gnome-base/gnome-desktop-2.91.6:3=
+ >=gnome-base/librsvg-2.32.0:2
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=media-libs/clutter-1.10:1.0[introspection?]
+ >=media-libs/clutter-gtk-0.91.8:1.0
+ >=media-libs/clutter-gst-1.9:2.0
+ media-libs/cogl:1.0=[introspection?]
+
+ media-video/gnome-video-effects
+ x11-libs/gdk-pixbuf:2[jpeg,introspection?]
+ x11-libs/libX11
+ x11-libs/libXtst
+
+ media-libs/gstreamer:1.0[introspection?]
+ media-libs/gst-plugins-base:1.0[introspection?,ogg,pango,theora,vorbis,X]
+
+ >=virtual/udev-171:=[gudev]
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-good:1.0
+
+ media-plugins/gst-plugins-jpeg:1.0
+ media-plugins/gst-plugins-v4l2:1.0
+ media-plugins/gst-plugins-vpx:1.0
+
+ sendto? ( >=gnome-extra/nautilus-sendto-2.91 )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/libxml2:2
+ >=dev-util/gtk-doc-1.14
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ virtual/pkgconfig
+ x11-proto/xf86vidmodeproto
+ test? ( dev-libs/glib:2[utils] )
+"
+
+src_configure() {
+ gnome2_src_configure \
+ GST_INSPECT=$(type -P true) \
+ $(use_enable introspection) \
+ --disable-lcov \
+ --disable-static \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # Clutter-related sandbox violations when USE="doc introspection" and
+ # FEATURES="-userpriv" (see bug #385917).
+ unset DISPLAY
+ gnome2_src_compile
+}
+
+src_test() {
+ Xemake check
+}