summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-02-21 19:22:19 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-02-21 19:22:19 +0000
commit610729466b9dd1477faaab64585933cb70781337 (patch)
treee545f0bca49bff68e464f0ae41f9e919ac842d4a /media-video
parentfix bug 105616 (diff)
downloadgentoo-2-610729466b9dd1477faaab64585933cb70781337.tar.gz
gentoo-2-610729466b9dd1477faaab64585933cb70781337.tar.bz2
gentoo-2-610729466b9dd1477faaab64585933cb70781337.zip
Minor fixes and openal is back
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mplayer/ChangeLog7
-rw-r--r--media-video/mplayer/mplayer-1.0.20060217.ebuild22
2 files changed, 17 insertions, 12 deletions
diff --git a/media-video/mplayer/ChangeLog b/media-video/mplayer/ChangeLog
index 7a37874a8196..bf3972efcf7b 100644
--- a/media-video/mplayer/ChangeLog
+++ b/media-video/mplayer/ChangeLog
@@ -1,11 +1,16 @@
# ChangeLog for media-video/mplayer
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.345 2006/02/20 22:50:26 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.346 2006/02/21 19:22:19 lu_zero Exp $
20 Feb 2006; Gustavo Zacarias <gustavoz@gentoo.org>
mplayer-1.0.20060217.ebuild:
Stable on sparc wrt security #115760
+ 21 Feb 2006; Luca Barbato <lu_zero@gentoo.org>
+ mplayer-1.0.20060217.ebuild:
+ Fixed some of the logic, openal should work now, thanks to Reimar for
+ helping, as usual
+
20 Feb 2006; Luca Barbato <lu_zero@gentoo.org>
-files/mmst_fix_20050415.diff, -files/rtsp_fix_20050415.diff,
mplayer-1.0.20060217.ebuild:
diff --git a/media-video/mplayer/mplayer-1.0.20060217.ebuild b/media-video/mplayer/mplayer-1.0.20060217.ebuild
index c8dee636ae43..86180a7cb0a0 100644
--- a/media-video/mplayer/mplayer-1.0.20060217.ebuild
+++ b/media-video/mplayer/mplayer-1.0.20060217.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0.20060217.ebuild,v 1.5 2006/02/20 22:50:26 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0.20060217.ebuild,v 1.6 2006/02/21 19:22:19 lu_zero Exp $
inherit eutils flag-o-matic
@@ -9,8 +9,8 @@ IUSE="3dfx 3dnow 3dnowext aac aalib alsa altivec arts bidi bl bindist
cpudetection custom-cflags debug dga doc dts dvb cdparanoia directfb dvd dv
dvdread edl encode esd fbcon gif ggi gtk i8x0 ipv6 jack joystick jpeg libcaca
lirc live livecd lzo mad matroska matrox mmx mmxext musepack nas nls nvidia
-vorbis opengl oss png real rtc samba sdl sse sse2 svga tga theora truetype
-v4l v4l2 win32codecs X xanim xinerama xmms xv xvid xvmc"
+vorbis opengl openal oss png real rtc samba sdl sse sse2 svga tga theora
+truetype v4l v4l2 win32codecs X xanim xinerama xmms xv xvid xvmc"
# openal
BLUV=1.4
SVGV=1.9.17
@@ -28,13 +28,13 @@ DESCRIPTION="Media Player for Linux (snapshot)"
HOMEPAGE="http://www.mplayerhq.hu/"
# 'encode' in USE for MEncoder.
-# openal? ( media-libs/openal )
RDEPEND="xvid? ( >=media-libs/xvid-0.9.0 )
win32codecs? ( >=media-libs/win32codecs-20040916 )
x86? ( real? ( >=media-video/realplayer-10.0.3 ) )
aalib? ( media-libs/aalib )
alsa? ( media-libs/alsa-lib )
arts? ( kde-base/arts )
+ openal? ( media-libs/openal )
bidi? ( dev-libs/fribidi )
cdparanoia? ( media-sound/cdparanoia )
dga? ( || ( x11-libs/libXxf86dga virtual/x11 ) )
@@ -383,13 +383,13 @@ src_compile() {
#############
# Audio Output #
#############
- myconf="${myconf} $(use_enable alsa)"
- myconf="${myconf} $(use_enable arts)"
- myconf="${myconf} $(use_enable esd)"
- myconf="${myconf} $(use_enable mad)"
- myconf="${myconf} $(use_enable nas)"
- myconf="${myconf} --disable-openal" #$(use_enable openal)"
- myconf="${myconf} $(use_enable oss ossaudio)"
+ use alsa || myconf="${myconf} --disable-alsa"
+ use arts || myconf="${myconf} --disable-arts"
+ use esd || myconf="${myconf} --disable-esd"
+ use mad || myconf="${myconf} --disable-mad"
+ use nas || myconf="${myconf} --disable-nas"
+ use openal || myconf="${myconf} --disable-openal"
+ use oss || myconf="${myconf} --disable-ossaudio"
#################
# Advanced Options #