summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-06-02 06:17:09 +0000
committerBen de Groot <yngwin@gentoo.org>2012-06-02 06:17:09 +0000
commitbcd7a4b8755ee48d1d39e3f7a2e66413b516d15b (patch)
tree4fc4f1ecf7049a60e8ba85be7ee9c98908fe60a8 /media-video
parentAdd ppc{,64} mask for smplayer-themes, since there is no longer a working key... (diff)
downloadgentoo-2-bcd7a4b8755ee48d1d39e3f7a2e66413b516d15b.tar.gz
gentoo-2-bcd7a4b8755ee48d1d39e3f7a2e66413b516d15b.tar.bz2
gentoo-2-bcd7a4b8755ee48d1d39e3f7a2e66413b516d15b.zip
Propagate ~alpha keyword from 0.6.9-r2. Drop old and known to be broken versions, even if minor arches fail to keyword and/or stable newer versions.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/smplayer/ChangeLog7
-rw-r--r--media-video/smplayer/smplayer-0.6.9-r1.ebuild101
-rw-r--r--media-video/smplayer/smplayer-0.6.9-r2.ebuild106
-rw-r--r--media-video/smplayer/smplayer-0.6.9.ebuild100
-rw-r--r--media-video/smplayer/smplayer-0.8.0.ebuild4
5 files changed, 8 insertions, 310 deletions
diff --git a/media-video/smplayer/ChangeLog b/media-video/smplayer/ChangeLog
index cecc64cb6317..b1394e7b1fd8 100644
--- a/media-video/smplayer/ChangeLog
+++ b/media-video/smplayer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/smplayer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/smplayer/ChangeLog,v 1.113 2012/05/31 14:25:17 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/smplayer/ChangeLog,v 1.114 2012/06/02 06:17:09 yngwin Exp $
+
+ 02 Jun 2012; Ben de Groot <yngwin@gentoo.org> -smplayer-0.6.9-r1.ebuild,
+ -smplayer-0.6.9-r2.ebuild, -smplayer-0.6.9.ebuild, smplayer-0.8.0.ebuild:
+ Propagate ~alpha keyword from 0.6.9-r2. Drop old and known to be broken
+ versions, even if minor arches fail to keyword and/or stable newer versions.
31 May 2012; Davide Pesavento <pesa@gentoo.org> -smplayer-0.7.1.ebuild:
Remove unused version.
diff --git a/media-video/smplayer/smplayer-0.6.9-r1.ebuild b/media-video/smplayer/smplayer-0.6.9-r1.ebuild
deleted file mode 100644
index 495655a38371..000000000000
--- a/media-video/smplayer/smplayer-0.6.9-r1.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/smplayer/smplayer-0.6.9-r1.ebuild,v 1.2 2011/11/04 17:14:02 sping Exp $
-
-EAPI="2"
-LANGS="bg ca cs de en_US es et eu fi fr gl hu it ja ka ko ku mk nl pl pt_BR
-pt sk sr sv tr zh_CN zh_TW"
-LANGSLONG="ar_SY el_GR ro_RO ru_RU sl_SI uk_UA vi_VN"
-
-inherit eutils qt4-r2
-
-MY_PV=${PV##*_p}
-if [[ "${MY_PV}" != "${PV}" ]]; then
- # svn snapshot
- MY_PV=r${MY_PV}
- MY_P=${PN}-${MY_PV}
- S="${WORKDIR}/${MY_P}"
- SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
-else
- # regular upstream release
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-fi
-
-DESCRIPTION="Great Qt4 GUI front-end for mplayer"
-HOMEPAGE="http://smplayer.berlios.de/"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug"
-
-DEPEND="x11-libs/qt-gui:4"
-MPLAYER_USE="[ass,png]"
-RDEPEND="${DEPEND}
- || ( media-video/mplayer${MPLAYER_USE} media-video/mplayer2${MPLAYER_USE} )"
-
-src_prepare() {
- # Force Ctrl+Q as default quit shortcut
- epatch "${FILESDIR}/${PN}-0.6.8-quit.patch"
-
- # Upstream Makefile sucks
- sed -i -e "/^PREFIX=/s:/usr/local:/usr:" \
- -e "/^DOC_PATH=/s:packages/smplayer:${PF}:" \
- -e '/\.\/get_svn_revision\.sh/,+2c\
- cd src && $(DEFS) $(MAKE)' \
- "${S}"/Makefile || die "sed failed"
-
- # Turn debug message flooding off
- if ! use debug ; then
- sed -i 's:#\(DEFINES += NO_DEBUG_ON_CONSOLE\):\1:' \
- "${S}"/src/smplayer.pro || die "sed failed"
- fi
-}
-
-src_configure() {
- cd "${S}"/src
- echo "#define SVN_REVISION \"SVN-${MY_PV} (Gentoo)\"" > svn_revision.h
- eqmake4
-}
-
-gen_translation() {
- ebegin "Generating $1 translation"
- lrelease ${PN}_${1}.ts
- eend $? || die "failed to generate $1 translation"
-}
-
-src_compile() {
- emake || die
-
- # Generate translations
- cd "${S}"/src/translations
- local lang= nolangs= x=
- for lang in ${LINGUAS}; do
- if has ${lang} ${LANGS}; then
- gen_translation ${lang}
- continue
- elif [[ " ${LANGSLONG} " == *" ${lang}_"* ]]; then
- for x in ${LANGSLONG}; do
- if [[ "${lang}" == "${x%_*}" ]]; then
- gen_translation ${x}
- continue 2
- fi
- done
- fi
- nolangs="${nolangs} ${lang}"
- done
- [[ -n ${nolangs} ]] && ewarn "Sorry, but ${PN} does not support the LINGUAS:" ${nolangs}
- # install fails when no translation is present (bug 244370)
- [[ -z $(ls *.qm 2>/dev/null) ]] && gen_translation en_US
-}
-
-src_install() {
- # remove unneeded copies of GPL
- rm -f Copying.txt docs/{cs,en,ja,ru}/gpl.html
- rm -rf docs/{de,es,nl,ro}
-
- # remove windows-only files
- rm "${S}"/*.bat
-
- emake DESTDIR="${D}" install || die
- prepalldocs
-}
diff --git a/media-video/smplayer/smplayer-0.6.9-r2.ebuild b/media-video/smplayer/smplayer-0.6.9-r2.ebuild
deleted file mode 100644
index c0505d0dd587..000000000000
--- a/media-video/smplayer/smplayer-0.6.9-r2.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/smplayer/smplayer-0.6.9-r2.ebuild,v 1.5 2012/02/19 09:09:44 klausman Exp $
-
-EAPI="2"
-LANGS="bg ca cs de en_US es et eu fi fr gl hu it ja ka ko ku mk nl pl pt_BR
-pt sk sr sv tr zh_CN zh_TW"
-LANGSLONG="ar_SY el_GR ro_RO ru_RU sl_SI uk_UA vi_VN"
-
-inherit eutils qt4-r2
-
-MY_PV=${PV##*_p}
-if [[ "${MY_PV}" != "${PV}" ]]; then
- # svn snapshot
- MY_PV=r${MY_PV}
- MY_P=${PN}-${MY_PV}
- S="${WORKDIR}/${MY_P}"
- SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
-else
- # regular upstream release
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-fi
-
-DESCRIPTION="Great Qt4 GUI front-end for mplayer"
-HOMEPAGE="http://smplayer.berlios.de/"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~x86"
-IUSE="debug"
-
-DEPEND="x11-libs/qt-gui:4
- dev-libs/quazip"
-MPLAYER_USE="[ass,png]"
-RDEPEND="${DEPEND}
- || ( media-video/mplayer${MPLAYER_USE} media-video/mplayer2${MPLAYER_USE} )"
-
-src_prepare() {
- # Force Ctrl+Q as default quit shortcut
- epatch "${FILESDIR}/${PN}-0.6.8-quit.patch"
-
- # Unbundle dev-libs/quazip
- rm -R src/findsubtitles/quazip/ || die
- epatch "${FILESDIR}"/${P}-quazip.patch
-
- # Upstream Makefile sucks
- sed -i -e "/^PREFIX=/s:/usr/local:/usr:" \
- -e "/^DOC_PATH=/s:packages/smplayer:${PF}:" \
- -e '/\.\/get_svn_revision\.sh/,+2c\
- cd src && $(DEFS) $(MAKE)' \
- "${S}"/Makefile || die "sed failed"
-
- # Turn debug message flooding off
- if ! use debug ; then
- sed -i 's:#\(DEFINES += NO_DEBUG_ON_CONSOLE\):\1:' \
- "${S}"/src/smplayer.pro || die "sed failed"
- fi
-}
-
-src_configure() {
- cd "${S}"/src
- echo "#define SVN_REVISION \"SVN-${MY_PV} (Gentoo)\"" > svn_revision.h
- eqmake4
-}
-
-gen_translation() {
- ebegin "Generating $1 translation"
- lrelease ${PN}_${1}.ts
- eend $? || die "failed to generate $1 translation"
-}
-
-src_compile() {
- emake || die
-
- # Generate translations
- cd "${S}"/src/translations
- local lang= nolangs= x=
- for lang in ${LINGUAS}; do
- if has ${lang} ${LANGS}; then
- gen_translation ${lang}
- continue
- elif [[ " ${LANGSLONG} " == *" ${lang}_"* ]]; then
- for x in ${LANGSLONG}; do
- if [[ "${lang}" == "${x%_*}" ]]; then
- gen_translation ${x}
- continue 2
- fi
- done
- fi
- nolangs="${nolangs} ${lang}"
- done
- [[ -n ${nolangs} ]] && ewarn "Sorry, but ${PN} does not support the LINGUAS:" ${nolangs}
- # install fails when no translation is present (bug 244370)
- [[ -z $(ls *.qm 2>/dev/null) ]] && gen_translation en_US
-}
-
-src_install() {
- # remove unneeded copies of GPL
- rm -f Copying.txt docs/{cs,en,ja,ru}/gpl.html
- rm -rf docs/{de,es,nl,ro}
-
- # remove windows-only files
- rm "${S}"/*.bat
-
- emake DESTDIR="${D}" install || die
- prepalldocs
-}
diff --git a/media-video/smplayer/smplayer-0.6.9.ebuild b/media-video/smplayer/smplayer-0.6.9.ebuild
deleted file mode 100644
index 2e6940797c2b..000000000000
--- a/media-video/smplayer/smplayer-0.6.9.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/smplayer/smplayer-0.6.9.ebuild,v 1.9 2010/10/25 03:08:39 jer Exp $
-
-EAPI="2"
-LANGS="bg ca cs de en_US es et eu fi fr gl hu it ja ka ko ku mk nl pl pt_BR
-pt sk sr sv tr zh_CN zh_TW"
-LANGSLONG="ar_SY el_GR ro_RO ru_RU sl_SI uk_UA vi_VN"
-
-inherit eutils qt4-r2
-
-MY_PV=${PV##*_p}
-if [[ "${MY_PV}" != "${PV}" ]]; then
- # svn snapshot
- MY_PV=r${MY_PV}
- MY_P=${PN}-${MY_PV}
- S="${WORKDIR}/${MY_P}"
- SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
-else
- # regular upstream release
- SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-fi
-
-DESCRIPTION="Great Qt4 GUI front-end for mplayer"
-HOMEPAGE="http://smplayer.berlios.de/"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="debug"
-
-DEPEND="x11-libs/qt-gui:4"
-RDEPEND="${DEPEND}
- media-video/mplayer[ass,png]"
-
-src_prepare() {
- # Force Ctrl+Q as default quit shortcut
- epatch "${FILESDIR}/${PN}-0.6.8-quit.patch"
-
- # Upstream Makefile sucks
- sed -i -e "/^PREFIX=/s:/usr/local:/usr:" \
- -e "/^DOC_PATH=/s:packages/smplayer:${PF}:" \
- -e '/\.\/get_svn_revision\.sh/,+2c\
- cd src && $(DEFS) $(MAKE)' \
- "${S}"/Makefile || die "sed failed"
-
- # Turn debug message flooding off
- if ! use debug ; then
- sed -i 's:#\(DEFINES += NO_DEBUG_ON_CONSOLE\):\1:' \
- "${S}"/src/smplayer.pro || die "sed failed"
- fi
-}
-
-src_configure() {
- cd "${S}"/src
- echo "#define SVN_REVISION \"SVN-${MY_PV} (Gentoo)\"" > svn_revision.h
- eqmake4
-}
-
-gen_translation() {
- ebegin "Generating $1 translation"
- lrelease ${PN}_${1}.ts
- eend $? || die "failed to generate $1 translation"
-}
-
-src_compile() {
- emake || die
-
- # Generate translations
- cd "${S}"/src/translations
- local lang= nolangs= x=
- for lang in ${LINGUAS}; do
- if has ${lang} ${LANGS}; then
- gen_translation ${lang}
- continue
- elif [[ " ${LANGSLONG} " == *" ${lang}_"* ]]; then
- for x in ${LANGSLONG}; do
- if [[ "${lang}" == "${x%_*}" ]]; then
- gen_translation ${x}
- continue 2
- fi
- done
- fi
- nolangs="${nolangs} ${lang}"
- done
- [[ -n ${nolangs} ]] && ewarn "Sorry, but ${PN} does not support the LINGUAS:" ${nolangs}
- # install fails when no translation is present (bug 244370)
- [[ -z $(ls *.qm 2>/dev/null) ]] && gen_translation en_US
-}
-
-src_install() {
- # remove unneeded copies of GPL
- rm -f Copying.txt docs/{cs,en,ja,ru}/gpl.html
- rm -rf docs/{de,es,nl,ro}
-
- # remove windows-only files
- rm "${S}"/*.bat
-
- emake DESTDIR="${D}" install || die
- prepalldocs
-}
diff --git a/media-video/smplayer/smplayer-0.8.0.ebuild b/media-video/smplayer/smplayer-0.8.0.ebuild
index dc6d61dd379b..89708b86be7d 100644
--- a/media-video/smplayer/smplayer-0.8.0.ebuild
+++ b/media-video/smplayer/smplayer-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/smplayer/smplayer-0.8.0.ebuild,v 1.4 2012/05/30 16:14:19 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/smplayer/smplayer-0.8.0.ebuild,v 1.5 2012/06/02 06:17:09 yngwin Exp $
EAPI=4
LANGS="bg ca cs da de en_US es et eu fi fr gl hr hu it ja ka ko ku lt mk nl pl
@@ -25,7 +25,7 @@ DESCRIPTION="Great Qt4 GUI front-end for mplayer"
HOMEPAGE="http://smplayer.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~arm hppa x86 ~x86-fbsd"
+KEYWORDS="~alpha amd64 ~arm hppa x86 ~x86-fbsd"
IUSE="debug"
DEPEND="x11-libs/qt-gui:4