summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-09-28 01:29:07 +0000
committerMike Frysinger <vapier@gentoo.org>2012-09-28 01:29:07 +0000
commitd1ee72b9f02155c2c9d03fdb79ebeb2b824249f0 (patch)
treee135bd3531ff1d0b014e24380e59c66e05c1b72c /media-video
parentAdd ppc/ppc64 love. (diff)
downloadgentoo-2-d1ee72b9f02155c2c9d03fdb79ebeb2b824249f0.tar.gz
gentoo-2-d1ee72b9f02155c2c9d03fdb79ebeb2b824249f0.tar.bz2
gentoo-2-d1ee72b9f02155c2c9d03fdb79ebeb2b824249f0.zip
Version bump #357255 by Dennis Nezic.
(Portage version: 2.2.0_alpha131/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/clive/ChangeLog10
-rw-r--r--media-video/clive/clive-2.3.0.1.ebuild59
2 files changed, 66 insertions, 3 deletions
diff --git a/media-video/clive/ChangeLog b/media-video/clive/ChangeLog
index 3ab5fd250ca1..634d1e6cada3 100644
--- a/media-video/clive/ChangeLog
+++ b/media-video/clive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/clive
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.72 2011/10/24 04:42:44 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.73 2012/09/28 01:29:07 vapier Exp $
+
+*clive-2.3.0.1 (28 Sep 2012)
+
+ 28 Sep 2012; Mike Frysinger <vapier@gentoo.org> +clive-2.3.0.1.ebuild:
+ Version bump #357255 by Dennis Nezic.
24 Oct 2011; Tim Harder <radhermit@gentoo.org> -clive-2.2.23.ebuild,
-clive-2.2.24.ebuild, -clive-2.2.25.ebuild:
@@ -315,4 +320,3 @@
initial import, sharing this small ebuild I have had for a long time, others
might like the tool too if they hate flash and still want to watch videos
from various websites
-
diff --git a/media-video/clive/clive-2.3.0.1.ebuild b/media-video/clive/clive-2.3.0.1.ebuild
new file mode 100644
index 000000000000..3fde7d5a9d0f
--- /dev/null
+++ b/media-video/clive/clive-2.3.0.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-2.3.0.1.ebuild,v 1.1 2012/09/28 01:29:07 vapier Exp $
+
+EAPI=4
+
+inherit perl-app
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://clive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PV:0:3}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="clipboard pager password test"
+
+RDEPEND=">=dev-perl/BerkeleyDB-0.34
+ >=dev-perl/Config-Tiny-2.12
+ >=virtual/perl-Digest-SHA-5.47
+ >=dev-perl/HTML-TokeParser-Simple-2.37
+ >=dev-perl/Class-Singleton-1.4
+ >=dev-perl/WWW-Curl-4.05
+ >=dev-perl/XML-Simple-2.18
+ >=dev-perl/Getopt-ArgvFile-1.11
+ dev-perl/JSON-XS
+ dev-perl/URI
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ clipboard? ( >=dev-perl/Clipboard-0.09 )
+ pager? ( >=dev-perl/IO-Pager-0.05 )
+ password? ( >=dev-perl/Expect-1.21 )
+ media-libs/quvi
+ || ( net-misc/wget net-misc/curl )"
+DEPEND="test? ( dev-perl/Test-Pod ${RDEPEND} )"
+
+SRC_TEST=do
+mydoc="NEWS"
+
+src_install() {
+ perl-module_src_install
+ dodir /etc/clive
+ cat <<-EOF > "${ED}"/etc/clive/config || die
+ --quvi "quvi %u"
+ --get-with "if type -P wget >/dev/null 2>&1; then wget -c -O %f %u; else curl -L -C - -o %f %u; fi"
+ --filename-format "%t.%s"
+ EOF
+}
+
+src_test() {
+ if [ -z "${I_WANT_CLIVE_HOSTS_TESTS}" ] ; then
+ elog "If you wish to run the full testsuite of ${PN}"
+ elog "Please set the variable 'I_WANT_CLIVE_HOSTS_TESTS' variable"
+ elog "Note that the tests try to download some videos from various websites"
+ elog "and thus may randomly fail depending on the site's status."
+ export NO_INTERNET=1
+ fi
+ perl-module_src_test
+}