summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2010-09-01 19:41:40 +0000
committerDaniel Pielmeier <billie@gentoo.org>2010-09-01 19:41:40 +0000
commite32db6983d772e1d01e6eb58662f991bf5cee54a (patch)
tree33619dd5f1318d2613f308e68efb12ab0501db30 /media-video
parentBug #333923: Need to install my_compiler.h so that PHP compiles. Bug #332565:... (diff)
downloadgentoo-2-e32db6983d772e1d01e6eb58662f991bf5cee54a.tar.gz
gentoo-2-e32db6983d772e1d01e6eb58662f991bf5cee54a.tar.bz2
gentoo-2-e32db6983d772e1d01e6eb58662f991bf5cee54a.zip
Fix dependencies and configuration.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/dvdbackup/ChangeLog5
-rw-r--r--media-video/dvdbackup/dvdbackup-0.4.1.ebuild15
2 files changed, 14 insertions, 6 deletions
diff --git a/media-video/dvdbackup/ChangeLog b/media-video/dvdbackup/ChangeLog
index 1c5b8761c536..9c6832820504 100644
--- a/media-video/dvdbackup/ChangeLog
+++ b/media-video/dvdbackup/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/dvdbackup
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdbackup/ChangeLog,v 1.25 2010/09/01 18:58:21 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdbackup/ChangeLog,v 1.26 2010/09/01 19:41:40 billie Exp $
+
+ 01 Sep 2010; Daniel Pielmeier <billie@gentoo.org> dvdbackup-0.4.1.ebuild:
+ Fix dependencies and configuration.
01 Sep 2010; Sebastian Pipping <sping@gentoo.org> dvdbackup-0.4.1.ebuild:
Add virtual/libintl to deps of 0.4.1. Caught by billie.
diff --git a/media-video/dvdbackup/dvdbackup-0.4.1.ebuild b/media-video/dvdbackup/dvdbackup-0.4.1.ebuild
index 933b09af8721..0035ea6675db 100644
--- a/media-video/dvdbackup/dvdbackup-0.4.1.ebuild
+++ b/media-video/dvdbackup/dvdbackup-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdbackup/dvdbackup-0.4.1.ebuild,v 1.3 2010/09/01 18:58:21 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdbackup/dvdbackup-0.4.1.ebuild,v 1.4 2010/09/01 19:41:40 billie Exp $
EAPI="2"
@@ -11,16 +11,21 @@ SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${P}/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-IUSE=""
+IUSE="nls"
DEPEND=">=media-libs/libdvdread-4.1.3_p1217
- virtual/libintl"
-RDEPEND="${RDEPEND}"
+ nls? ( virtual/libintl )"
+RDEPEND="${DEPEND}"
src_configure() {
- econf --docdir="/usr/share/doc/${PF}"
+ econf \
+ $(use_enable nls) \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --docdir="/usr/share/doc/${PF}"
}
src_install() {
emake DESTDIR="${D}" install || die 'emake install failed'
+ dodoc AUTHORS ChangeLog NEWS README || die 'dodoc failed'
}