summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-06-19 20:16:57 +0000
committerJeroen Roovers <jer@gentoo.org>2012-06-19 20:16:57 +0000
commitc35c7db82923e7fb24d0447b7378411b0c3450bd (patch)
tree8011976279598ddb8578bebc2a902a044fcdfca1 /net-analyzer/argus-clients
parentVersion bump. (diff)
downloadgentoo-2-c35c7db82923e7fb24d0447b7378411b0c3450bd.tar.gz
gentoo-2-c35c7db82923e7fb24d0447b7378411b0c3450bd.tar.bz2
gentoo-2-c35c7db82923e7fb24d0447b7378411b0c3450bd.zip
Version bump.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/argus-clients')
-rw-r--r--net-analyzer/argus-clients/ChangeLog7
-rw-r--r--net-analyzer/argus-clients/argus-clients-3.0.6.2.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/net-analyzer/argus-clients/ChangeLog b/net-analyzer/argus-clients/ChangeLog
index 3f931912abbe..9d073957eef7 100644
--- a/net-analyzer/argus-clients/ChangeLog
+++ b/net-analyzer/argus-clients/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/argus-clients
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/ChangeLog,v 1.42 2012/06/11 07:16:23 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/ChangeLog,v 1.43 2012/06/19 20:16:57 jer Exp $
+
+*argus-clients-3.0.6.2 (19 Jun 2012)
+
+ 19 Jun 2012; Jeroen Roovers <jer@gentoo.org> +argus-clients-3.0.6.2.ebuild:
+ Version bump.
11 Jun 2012; Michael Weber <xmw@gentoo.org> argus-clients-3.0.4.1-r1.ebuild:
ppc stable (bug 369587)
diff --git a/net-analyzer/argus-clients/argus-clients-3.0.6.2.ebuild b/net-analyzer/argus-clients/argus-clients-3.0.6.2.ebuild
new file mode 100644
index 000000000000..913b8a5df78b
--- /dev/null
+++ b/net-analyzer/argus-clients/argus-clients-3.0.6.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/argus-clients-3.0.6.2.ebuild,v 1.1 2012/06/19 20:16:57 jer Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="Clients for net-analyzer/argus"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug ft geoip mysql sasl tcpd"
+
+MY_CDEPEND="
+ net-analyzer/rrdtool[perl]
+ net-libs/libpcap
+ sys-libs/ncurses
+ sys-libs/readline
+ ft? ( net-analyzer/flow-tools )
+ geoip? ( dev-libs/geoip )
+ mysql? ( virtual/mysql )
+ sasl? ( dev-libs/cyrus-sasl )
+"
+
+RDEPEND="
+ ${MY_CDEPEND}
+"
+
+DEPEND="
+ ${MY_CDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.0.4.1-disable-tcp-wrappers-automagic.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug
+ econf \
+ $(use_with ft libft) \
+ $(use_with geoip GeoIP /usr/) \
+ $(use_with sasl) \
+ $(use_with tcpd wrappers) \
+ $(use_with mysql)
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ # argus_parse.a and argus_common.a are supplied by net-analyzer/argus
+ dobin bin/ra*
+ dodoc ChangeLog CREDITS README CHANGES
+ doman man/man{1,5}/*
+}