summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-01-11 18:20:20 +0000
committerJeroen Roovers <jer@gentoo.org>2012-01-11 18:20:20 +0000
commit122357b12a4ce145738735f674802b4b5c7547b7 (patch)
tree99442cde5ee65a04435f290377c4e2f2b1c4a811 /net-analyzer/argus
parentStable for ppc/ppc64; bug #398239 (diff)
downloadgentoo-2-122357b12a4ce145738735f674802b4b5c7547b7.tar.gz
gentoo-2-122357b12a4ce145738735f674802b4b5c7547b7.tar.bz2
gentoo-2-122357b12a4ce145738735f674802b4b5c7547b7.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/argus')
-rw-r--r--net-analyzer/argus/ChangeLog9
-rw-r--r--net-analyzer/argus/argus-3.0.5.8.ebuild73
2 files changed, 80 insertions, 2 deletions
diff --git a/net-analyzer/argus/ChangeLog b/net-analyzer/argus/ChangeLog
index d62ff909ac4e..6acc3b1e47e5 100644
--- a/net-analyzer/argus/ChangeLog
+++ b/net-analyzer/argus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/argus
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/ChangeLog,v 1.38 2011/12/16 16:11:43 jer Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/ChangeLog,v 1.39 2012/01/11 18:20:20 jer Exp $
+
+*argus-3.0.5.8 (11 Jan 2012)
+
+ 11 Jan 2012; Jeroen Roovers <jer@gentoo.org> +argus-3.0.5.8.ebuild:
+ Version bump.
*argus-3.0.5.7 (16 Dec 2011)
diff --git a/net-analyzer/argus/argus-3.0.5.8.ebuild b/net-analyzer/argus/argus-3.0.5.8.ebuild
new file mode 100644
index 000000000000..9aa6d5086c80
--- /dev/null
+++ b/net-analyzer/argus/argus-3.0.5.8.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus/argus-3.0.5.8.ebuild,v 1.1 2012/01/11 18:20:20 jer Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="network Audit Record Generation and Utilization System"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug tcpd"
+
+# sasl? ( >=dev-libs/cyrus-sasl-2.1.22 )
+RDEPEND="net-libs/libpcap
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6"
+
+src_prepare() {
+ sed -e 's:/etc/argus.conf:/etc/argus/argus.conf:' \
+ -i argus/argus.c \
+ -i support/Config/argus.conf \
+ -i man/man8/argus.8 \
+ -i man/man5/argus.conf.5 || die
+
+ sed -e 's:#\(ARGUS_SETUSER_ID=\).*:\1argus:' \
+ -e 's:#\(ARGUS_SETGROUP_ID=\).*:\1argus:' \
+ -e 's:\(#ARGUS_CHROOT_DIR=\).*:\1/var/lib/argus:' \
+ -i support/Config/argus.conf || die
+ epatch \
+ "${FILESDIR}"/${PN}-3.0.4-disable-tcp-wrappers-automagic.patch \
+ "${FILESDIR}"/${PN}-3.0.5-Makefile.patch
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug # enable debugging
+ econf $(use_with tcpd wrappers)
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install () {
+ doman man/man5/* man/man8/*
+ dosbin bin/argus{,bug}
+
+ dodoc ChangeLog CREDITS README
+
+ insinto /etc/argus
+ doins support/Config/argus.conf
+
+ newinitd "${FILESDIR}/argus.initd" argus
+ dodir /var/lib/argus
+}
+
+pkg_preinst() {
+ enewgroup argus
+ enewuser argus -1 -1 /var/lib/argus argus
+}
+
+pkg_postinst() {
+ elog "Note, if you modify ARGUS_DAEMON value in argus.conf it's quite"
+ elog "possible that init script will fail to work."
+}