summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-01-16 11:31:45 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-01-16 11:31:45 +0000
commitbde7f1d540a9abc5684968fd2dae920c5c99b657 (patch)
tree688ecfe7f1536b519116cdb6c3ddd762e294e02b /net-analyzer/cnet
parentVersion bump. Fixes bug 289228 and 482704. (diff)
downloadgentoo-2-bde7f1d540a9abc5684968fd2dae920c5c99b657.tar.gz
gentoo-2-bde7f1d540a9abc5684968fd2dae920c5c99b657.tar.bz2
gentoo-2-bde7f1d540a9abc5684968fd2dae920c5c99b657.zip
Version bump, wrt bug #482320. Thanks to Andrew Savchenko <bircoph AT gmail.com> for initial ebuild and patch
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-analyzer/cnet')
-rw-r--r--net-analyzer/cnet/ChangeLog11
-rw-r--r--net-analyzer/cnet/cnet-3.2.4.ebuild55
-rw-r--r--net-analyzer/cnet/files/cnet-3.2.4-gentoo.patch78
3 files changed, 142 insertions, 2 deletions
diff --git a/net-analyzer/cnet/ChangeLog b/net-analyzer/cnet/ChangeLog
index 62984c63ca3c..6519a48dfca0 100644
--- a/net-analyzer/cnet/ChangeLog
+++ b/net-analyzer/cnet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/cnet
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cnet/ChangeLog,v 1.16 2009/01/15 05:02:55 jer Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cnet/ChangeLog,v 1.17 2014/01/16 11:31:45 pinkbyte Exp $
+
+*cnet-3.2.4 (16 Jan 2014)
+
+ 16 Jan 2014; Sergey Popov <pinkbyte@gentoo.org> +cnet-3.2.4.ebuild,
+ +files/cnet-3.2.4-gentoo.patch:
+ Version bump, wrt bug #482320. Thanks to Andrew Savchenko <bircoph AT
+ gmail.com> for initial ebuild and patch
15 Jan 2009; Jeroen Roovers <jer@gentoo.org>
files/cnet-2.0.10-gentoo.patch, cnet-2.0.10.ebuild:
diff --git a/net-analyzer/cnet/cnet-3.2.4.ebuild b/net-analyzer/cnet/cnet-3.2.4.ebuild
new file mode 100644
index 000000000000..aa302fd7d1a5
--- /dev/null
+++ b/net-analyzer/cnet/cnet-3.2.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cnet/cnet-3.2.4.ebuild,v 1.1 2014/01/16 11:31:45 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Network simulation tool"
+HOMEPAGE="http://www.csse.uwa.edu.au/cnet3/"
+SRC_URI="${P}.tgz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=">=dev-lang/tk-8.5
+ dev-libs/elfutils
+ x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ einfo "Author demands to fill a download form to collect usage information:"
+ einfo "${HOMEPAGE}/download.html"
+ einfo "Please move downloaded file to ${DISTDIR}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ # Set libdir properly
+ sed -i -e "/CNETPATH/s:local/lib:$(get_libdir):" src/preferences.h || die
+ sed -i -e "/^LIBDIR/s:lib:$(get_libdir):" Makefile || die
+
+ epatch_user
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ANNOUNCE
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${P}/examples
+ fi
+}
diff --git a/net-analyzer/cnet/files/cnet-3.2.4-gentoo.patch b/net-analyzer/cnet/files/cnet-3.2.4-gentoo.patch
new file mode 100644
index 000000000000..7357610dd72c
--- /dev/null
+++ b/net-analyzer/cnet/files/cnet-3.2.4-gentoo.patch
@@ -0,0 +1,78 @@
+--- cnet-3.2.4/Makefile.orig 2012-03-23 11:42:31.000000000 +0400
++++ cnet-3.2.4/Makefile 2013-08-24 16:37:29.449886061 +0400
+@@ -6,7 +6,7 @@
+ # Change the following 4 constants to suit your system:
+ #
+ # PREFIX defines the directory below which cnet will be installed.
+-PREFIX = /usr/local
++PREFIX = /usr
+ #PREFIX = $(HOME)
+ #
+ # BINDIR defines the directory where the cnet binary will be installed.
+@@ -16,7 +16,6 @@
+ LIBDIR = $(PREFIX)/lib/cnet
+ #
+ # WWWDIR defines the directory to hold cnet's web-based documentation
+-WWWDIR = /home/httpd/html/cnet
+ #WWWDIR = $(HOME)/WWW/cnet
+ #
+ # ---------------------------------------------------------------------
+@@ -26,15 +26,14 @@
+ @ls -l $(NAME) *.a
+
+ install:
+- make
+- @mkdir -p $(BINDIR) $(LIBDIR)
+- @chmod 755 $(BINDIR) $(LIBDIR)
+- @cp $(NAME) $(BINDIR)/$(NAME)
+- @chmod 755 $(BINDIR)/$(NAME)
+- @rm -rf $(LIBDIR)/*
+- @cp lib/* *.a $(LIBDIR)
+- @chmod 644 $(LIBDIR)/*
+- @ls -l $(BINDIR)/$(NAME) $(LIBDIR)/*.a
++ @mkdir -p $(DESTDIR)$(BINDIR) $(DESTDIR)$(LIBDIR)
++ @chmod 755 $(DESTDIR)$(BINDIR) $(DESTDIR)$(LIBDIR)
++ @cp $(NAME) $(DESTDIR)$(BINDIR)/$(NAME)
++ @chmod 755 $(DESTDIR)$(BINDIR)/$(NAME)
++ @rm -rf $(DESTDIR)$(LIBDIR)/*
++ @cp lib/* *.a $(DESTDIR)$(LIBDIR)
++ @chmod 644 $(DESTDIR)$(LIBDIR)/*
++ @ls -l $(DESTDIR)$(BINDIR)/$(NAME) $(DESTDIR)$(LIBDIR)/*.a
+
+ AND = html/CLICK html/KEYBOARD html/STOPANDWAIT html/TICKTOCK
+ www:
+--- cnet-3.2.4/src/Makefile.linux.orig 2012-03-23 11:42:33.000000000 +0400
++++ cnet-3.2.4/src/Makefile.linux 2013-08-24 16:25:46.437455826 +0400
+@@ -20,10 +20,10 @@
+ XINCLUDES = -I/usr/include/tcl8.5
+ XLIBS = -ltcl8.5 -ltk8.5 -lX11
+ #
+-C99 = gcc -std=c99 -Wall -Werror -pedantic
+-CFLAGS = -O3 -fPIC $(INCLUDES) $(XINCLUDES)
++C99 = $(CC) -std=c99 -pedantic
++CFLAGS += -fPIC $(INCLUDES) $(XINCLUDES)
+ #
+-LD = gcc -rdynamic
++LD = $(CC) -rdynamic
+ LIBDIRS = $(XLIBDIRS)
+ LIBS = -lelf -ldl -lm
+ STRIP = strip
+--- cnet-3.2.4/support/Makefile.common.orig 2014-01-16 13:40:28.364197103 +0400
++++ cnet-3.2.4/support/Makefile.common 2014-01-16 13:41:00.956198672 +0400
+@@ -1,13 +1,13 @@
+ #
+ CC = gcc
+-CFLAGS = -O -std=c99 -pedantic -Wall -Werror -fPIC
++CFLAGS += -O -std=c99 -pedantic -fPIC
+
+ DOTH = cnetsupport.h
+ OBJ = hashtable.o lexical.o md5.o queue.o vector.o
+
+ $(NAME): $(OBJ)
+- ar rc $(NAME) $(OBJ)
+- ranlib $(NAME)
++ $(AR) rc $(NAME) $(OBJ)
++ $(RANLIB) $(NAME)
+ @cp -p $(NAME) ..
+
+ %.o : %.c $(DOTH)