summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Boman <mboman@gentoo.org>2004-02-28 04:58:52 +0000
committerMichael Boman <mboman@gentoo.org>2004-02-28 04:58:52 +0000
commit2a46c1e75e5e7e71582d60d59e506bdf249c8bfc (patch)
tree10b1523083222e29f8becfdc7adf709308a70dc3 /net-analyzer/iplog
parentver bump (diff)
downloadgentoo-2-2a46c1e75e5e7e71582d60d59e506bdf249c8bfc.tar.gz
gentoo-2-2a46c1e75e5e7e71582d60d59e506bdf249c8bfc.tar.bz2
gentoo-2-2a46c1e75e5e7e71582d60d59e506bdf249c8bfc.zip
Marked stable on x86. Closes 42998. Re-indented the init.d script. Changed some internal stuff in the ebuild so it's a bit cleaner.
Diffstat (limited to 'net-analyzer/iplog')
-rw-r--r--net-analyzer/iplog/ChangeLog10
-rw-r--r--net-analyzer/iplog/files/iplog.rc630
-rw-r--r--net-analyzer/iplog/iplog-2.2.3-r2.ebuild13
-rw-r--r--net-analyzer/iplog/metadata.xml11
4 files changed, 40 insertions, 24 deletions
diff --git a/net-analyzer/iplog/ChangeLog b/net-analyzer/iplog/ChangeLog
index cc4590e185d4..73ba3886b6f8 100644
--- a/net-analyzer/iplog/ChangeLog
+++ b/net-analyzer/iplog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/iplog
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iplog/ChangeLog,v 1.7 2003/10/27 05:50:50 robbat2 Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iplog/ChangeLog,v 1.8 2004/02/28 04:58:52 mboman Exp $
+
+ 27 Feb 2004; Michael Boman <mboman@gentoo.org> iplog-2.2.3-r2.ebuild,
+ files/iplog.rc6:
+ - Marked stable on x86. Closes 42998.
+ - re-indented the init.d script.
+ - Changed some internal stuff in the ebuild so it's a bit cleaner.
*iplog-2.2.3-r2 (26 Oct 2003)
diff --git a/net-analyzer/iplog/files/iplog.rc6 b/net-analyzer/iplog/files/iplog.rc6
index e8b816237815..b87b09ddafe5 100644
--- a/net-analyzer/iplog/files/iplog.rc6
+++ b/net-analyzer/iplog/files/iplog.rc6
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iplog/files/iplog.rc6,v 1.1 2003/10/27 05:50:50 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iplog/files/iplog.rc6,v 1.2 2004/02/28 04:58:52 mboman Exp $
depend() {
need net
@@ -11,27 +11,27 @@ pidfile=/var/run/iplog.pid
start() {
ebegin "Starting iplog"
- checkconfig
- rc=$?
- if [ $rc -eq 0 ]; then
- start-stop-daemon --start --quiet --startas /usr/sbin/iplog \
- --pidfile=${pidfile} --name=iplog
- rc=$?
- eend $rc "Failed to start iplog $rc"
- else
- eend $rc "/etc/iplog.conf does not exist!"
- fi
+ checkconfig
+ rc=$?
+ if [ $rc -eq 0 ]; then
+ start-stop-daemon --start --quiet --startas /usr/sbin/iplog \
+ --pidfile=${pidfile} --name=iplog
+ rc=$?
+ eend $rc "Failed to start iplog $rc"
+ else
+ eend $rc "/etc/iplog.conf does not exist!"
+ fi
}
stop() {
ebegin "Stopping iplog"
start-stop-daemon --stop --retry=5 --quiet --pidfile=${pidfile} --name=iplog
- # due to a bug in the program, it doesn't properly remove it's pidfile sometimes
- rm -f ${pidfile}
+ # due to a bug in the program, it doesn't properly remove it's pidfile sometimes
+ rm -f ${pidfile}
eend $? "Failed to stop iplog!"
}
checkconfig() {
- [ -f /etc/iplog.conf ] || return 1
- return 0
+ [ -f /etc/iplog.conf ] || return 1
+ return 0
}
diff --git a/net-analyzer/iplog/iplog-2.2.3-r2.ebuild b/net-analyzer/iplog/iplog-2.2.3-r2.ebuild
index 0925008d8ed2..46bb9cdf472b 100644
--- a/net-analyzer/iplog/iplog-2.2.3-r2.ebuild
+++ b/net-analyzer/iplog/iplog-2.2.3-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iplog/iplog-2.2.3-r2.ebuild,v 1.1 2003/10/27 05:50:50 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iplog/iplog-2.2.3-r2.ebuild,v 1.2 2004/02/28 04:58:52 mboman Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/ojnk/${P}.tar.gz"
LICENSE="GPL-2 | FDL-1.1"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc"
+KEYWORDS="x86 ~ppc ~sparc"
DEPEND="net-libs/libpcap"
@@ -31,8 +31,7 @@ src_install() {
mandir=${D}/usr/share/man \
install || die
dodoc AUTHORS COPYING.* NEWS README TODO example-iplog.conf
- into /
- insinto /etc/init.d
- newins ${FILESDIR}/iplog.rc6 iplog
- chmod +x ${D}/etc/init.d/iplog
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/iplog.rc6 iplog
}
diff --git a/net-analyzer/iplog/metadata.xml b/net-analyzer/iplog/metadata.xml
new file mode 100644
index 000000000000..577c9834431a
--- /dev/null
+++ b/net-analyzer/iplog/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<maintainer>
+ <email>mboman@gentoo.org</email>
+ <name>Michael Boman</name>
+ <description>Interim Maintainer</description>
+</maintainer>
+<longdescription>iplog is a TCP/IP traffic logger.</longdescription>
+</pkgmetadata>