summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-18 23:22:52 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-18 23:22:52 +0000
commitf62937cab196d3ac4f1c7cfe48733508bddb8de2 (patch)
tree9c80a9ffcaeccd18f09aa3ded1da093c3a2bab7e /net-analyzer/iplog
parentrepoman'd (diff)
downloadgentoo-2-f62937cab196d3ac4f1c7cfe48733508bddb8de2.tar.gz
gentoo-2-f62937cab196d3ac4f1c7cfe48733508bddb8de2.tar.bz2
gentoo-2-f62937cab196d3ac4f1c7cfe48733508bddb8de2.zip
repoman'd
Diffstat (limited to 'net-analyzer/iplog')
-rw-r--r--net-analyzer/iplog/iplog-2.2.3.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/net-analyzer/iplog/iplog-2.2.3.ebuild b/net-analyzer/iplog/iplog-2.2.3.ebuild
index 17a0844afb67..5a444b27626d 100644
--- a/net-analyzer/iplog/iplog-2.2.3.ebuild
+++ b/net-analyzer/iplog/iplog-2.2.3.ebuild
@@ -1,27 +1,33 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iplog/iplog-2.2.3.ebuild,v 1.5 2002/07/11 06:30:43 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/iplog/iplog-2.2.3.ebuild,v 1.6 2002/07/18 23:22:46 seemant Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="iplog is a TCP/IP traffic logger"
-SRC_URI="http://download.sourceforge.net/ojnk/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/ojnk/${P}.tar.gz"
HOMEPAGE="http://ojnk.sourceforge.net/"
-DEPEND="virtual/glibc net-libs/libpcap"
+DEPEND="net-libs/libpcap"
+
+SLOT="0"
+LICENSE="GPL-2 | FDL-1.1"
+KEYWORDS="x86"
src_compile() {
- try ./configure --prefix=/usr
- try make CFLAGS="${CFLAGS} -D_REENTRANT" all
+ econf || die
+ make CFLAGS="${CFLAGS} -D_REENTRANT" all || die
}
src_install() {
- try make prefix=${D}/usr mandir=${D}/usr/share/man install
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ install || die
- dodoc AUTHORS COPYING.* NEWS README TODO example-iplog.conf
+ dodoc AUTHORS COPYING.* NEWS README TODO example-iplog.conf
}