summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-06 23:32:57 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-06 23:32:57 +0000
commit94de4f011599c8139f37c291cfa7c66c010ef15b (patch)
tree98a589b5b1838cd928d61fc6405fcaf3f1cc5ddd /net-analyzer/nb/nb-0.8.3.ebuild
parentFixed USE="-python" issue, bug #311215. Removed old revisions. (diff)
downloadgentoo-2-94de4f011599c8139f37c291cfa7c66c010ef15b.tar.gz
gentoo-2-94de4f011599c8139f37c291cfa7c66c010ef15b.tar.bz2
gentoo-2-94de4f011599c8139f37c291cfa7c66c010ef15b.zip
Version bump. Introduce USE=static-libs. Block parallel make since it does not work due to crappy AM files.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/nb/nb-0.8.3.ebuild')
-rw-r--r--net-analyzer/nb/nb-0.8.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/nb/nb-0.8.3.ebuild b/net-analyzer/nb/nb-0.8.3.ebuild
new file mode 100644
index 000000000000..7bc8849a35b7
--- /dev/null
+++ b/net-analyzer/nb/nb-0.8.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nb/nb-0.8.3.ebuild,v 1.1 2011/06/06 23:32:57 jer Exp $
+
+EAPI="3"
+
+inherit autotools-utils
+
+DESCRIPTION="Nodebrain is a tool to monitor and do event correlation."
+HOMEPAGE="http://nodebrain.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nodebrain/nodebrain-${PV}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="static-libs"
+
+DEPEND="dev-lang/perl"
+RDEPEND="!sys-boot/netboot"
+
+S="${WORKDIR}/nodebrain-${PV}"
+
+src_prepare() {
+ # Prevent make from rebuilding this target, since
+ # fdl.texi is not included in the distribution
+ touch doc/nbTutorial/nbTutorial.info || die
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ # Fails at parallel make
+ emake -j1 || die
+}
+
+src_install() {
+ #DIR="${D}/usr" ./install-nb || die "install failed"
+ emake DESTDIR="${D}" install || die
+ use static-libs || remove_libtool_files
+ dodoc AUTHORS NEWS README THANKS sample/*
+ dohtml html/*
+}