summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-06-30 23:12:31 +0000
committerEldad Zack <eldad@gentoo.org>2004-06-30 23:12:31 +0000
commit479ad33f54a068998a15a6a5910fd00731bd9261 (patch)
treef84a9d3471094c5415fc439a5af1df3581e585a6 /net-analyzer/netselect
parentamd64 (Manifest recommit) (diff)
downloadgentoo-2-479ad33f54a068998a15a6a5910fd00731bd9261.tar.gz
gentoo-2-479ad33f54a068998a15a6a5910fd00731bd9261.tar.bz2
gentoo-2-479ad33f54a068998a15a6a5910fd00731bd9261.zip
fixed sudo permissions, closes #47209 ; sed cleanup ; added metadata
Diffstat (limited to 'net-analyzer/netselect')
-rw-r--r--net-analyzer/netselect/ChangeLog10
-rw-r--r--net-analyzer/netselect/Manifest2
-rw-r--r--net-analyzer/netselect/files/digest-netselect-0.3-r11
-rw-r--r--net-analyzer/netselect/metadata.xml6
-rw-r--r--net-analyzer/netselect/netselect-0.3-r1.ebuild31
5 files changed, 49 insertions, 1 deletions
diff --git a/net-analyzer/netselect/ChangeLog b/net-analyzer/netselect/ChangeLog
index d50820a93eb7..54e5f8a377ab 100644
--- a/net-analyzer/netselect/ChangeLog
+++ b/net-analyzer/netselect/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/netselect
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/ChangeLog,v 1.12 2004/06/24 22:12:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/ChangeLog,v 1.13 2004/06/30 23:12:31 eldad Exp $
+
+*netselect-0.3-r1 (01 Jul 2004)
+
+ 01 Jul 2004; Eldad Zack <eldad@gentoo.org> +metadata.xml,
+ +netselect-0.3-r1.ebuild:
+ suid: fixed permissions to 4710, group is set to root:wheel,
+ closes #47209, Thanks to Philipp Kern <phil@lordaeron.in-berlin.de>.
+ sed cleanup, added metadata.
13 May 2004; Michael McCabe <randy@gentoo.org> netselect-0.3.ebuild:
Added s390 keywords
diff --git a/net-analyzer/netselect/Manifest b/net-analyzer/netselect/Manifest
index 07fb18e8e34c..a7ffec2a49ba 100644
--- a/net-analyzer/netselect/Manifest
+++ b/net-analyzer/netselect/Manifest
@@ -1,3 +1,5 @@
+MD5 270fe9e4fe888165691e06c16407e476 netselect-0.3-r1.ebuild 819
MD5 0df09368d31b618b7bd6ddd368e1423a netselect-0.3.ebuild 774
MD5 05fb7173210406449c6d8fd101629fe1 ChangeLog 1167
+MD5 7396c62cc3e5735019287ae62229dd48 files/digest-netselect-0.3-r1 64
MD5 7396c62cc3e5735019287ae62229dd48 files/digest-netselect-0.3 64
diff --git a/net-analyzer/netselect/files/digest-netselect-0.3-r1 b/net-analyzer/netselect/files/digest-netselect-0.3-r1
new file mode 100644
index 000000000000..c6c319950d7b
--- /dev/null
+++ b/net-analyzer/netselect/files/digest-netselect-0.3-r1
@@ -0,0 +1 @@
+MD5 3a3714946db2458e5db3d55373057ef2 netselect-0.3.tar.gz 22047
diff --git a/net-analyzer/netselect/metadata.xml b/net-analyzer/netselect/metadata.xml
new file mode 100644
index 000000000000..a67b15dcc55f
--- /dev/null
+++ b/net-analyzer/netselect/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription>Ultrafast implementation of ping</longdescription>
+</pkgmetadata>
diff --git a/net-analyzer/netselect/netselect-0.3-r1.ebuild b/net-analyzer/netselect/netselect-0.3-r1.ebuild
new file mode 100644
index 000000000000..d4bd28e22eda
--- /dev/null
+++ b/net-analyzer/netselect/netselect-0.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netselect/netselect-0.3-r1.ebuild,v 1.1 2004/06/30 23:12:31 eldad Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Ultrafast implementation of ping."
+HOMEPAGE="http://www.worldvisions.ca/~apenwarr/netselect/"
+SRC_URI="http://www.worldvisions.ca/~apenwarr/netselect/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+
+src_compile() {
+ mv Makefile Makefile.orig
+ sed -e "s:PREFIX =.*:PREFIX = ${D}usr:" \
+ -e "s:CFLAGS =.*:CFLAGS = -Wall -I. -g ${CFLAGS}:" \
+ -e '23,27d' \
+ -e '34d' \
+ -i Makefile
+
+ make || die
+}
+
+src_install () {
+ make install || die
+ fowners root:wheel /usr/bin/netselect
+ fperms 4710 /usr/bin/netselect
+
+ dodoc ChangeLog HISTORY README*
+}